Opened 12 years ago

Closed 10 years ago

#19803 closed defect (fixed)

hunspell not compiling with +universal

Reported by: philip@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: Cc: domiman@…
Port: hunspell

Description (last modified by mf2k (Frank Schima))

philip@water.local> sudo ./port clean hunspell
Password:
--->  Cleaning hunspell
----
philip@water.local> sudo ./port install hunspell +universal
--->  Fetching hunspell
--->  Verifying checksum(s) for hunspell
--->  Extracting hunspell
--->  Applying patches to hunspell
--->  Configuring hunspell
--->  Building hunspell
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_hunspell/work/hunspell-1.2.8" && make all " returned error 2
Command output: Making all in parsers
/usr/bin/g++-4.0 -DHAVE_CONFIG_H -I. -I../..   -I/opt/local/include -isysroot /Developer/SDKs/MacOSX10.5.sdk  -O2 -DLIBDIR=\"/opt/local/share/hunspell:/usr/share/myspell:/usr/share/myspell/dicts\" -isysroot /Developer/SDKs/MacOSX10.5.sdk -arch x86_64 -mmacosx-version-min=10.5 -c -o firstparser.o firstparser.cxx
/usr/bin/g++-4.0 -DHAVE_CONFIG_H -I. -I../..   -I/opt/local/include -isysroot /Developer/SDKs/MacOSX10.5.sdk  -O2 -DLIBDIR=\"/opt/local/share/hunspell:/usr/share/myspell:/usr/share/myspell/dicts\" -isysroot /Developer/SDKs/MacOSX10.5.sdk -arch x86_64 -mmacosx-version-min=10.5 -c -o htmlparser.o htmlparser.cxx
/usr/bin/g++-4.0 -DHAVE_CONFIG_H -I. -I../..   -I/opt/local/include -isysroot /Developer/SDKs/MacOSX10.5.sdk  -O2 -DLIBDIR=\"/opt/local/share/hunspell:/usr/share/myspell:/usr/share/myspell/dicts\" -isysroot /Developer/SDKs/MacOSX10.5.sdk -arch x86_64 -mmacosx-version-min=10.5 -c -o latexparser.o latexparser.cxx
/usr/bin/g++-4.0 -DHAVE_CONFIG_H -I. -I../..   -I/opt/local/include -isysroot /Developer/SDKs/MacOSX10.5.sdk  -O2 -DLIBDIR=\"/opt/local/share/hunspell:/usr/share/myspell:/usr/share/myspell/dicts\" -isysroot /Developer/SDKs/MacOSX10.5.sdk -arch x86_64 -mmacosx-version-min=10.5 -c -o manparser.o manparser.cxx
/usr/bin/g++-4.0 -DHAVE_CONFIG_H -I. -I../..   -I/opt/local/include -isysroot /Developer/SDKs/MacOSX10.5.sdk  -O2 -DLIBDIR=\"/opt/local/share/hunspell:/usr/share/myspell:/usr/share/myspell/dicts\" -isysroot /Developer/SDKs/MacOSX10.5.sdk -arch x86_64 -mmacosx-version-min=10.5 -c -o textparser.o textparser.cxx
rm -f libparsers.a
ar cru libparsers.a firstparser.o htmlparser.o latexparser.o manparser.o textparser.o 
ranlib libparsers.a
/usr/bin/g++-4.0 -DHAVE_CONFIG_H -I. -I../..   -I/opt/local/include -isysroot /Developer/SDKs/MacOSX10.5.sdk  -O2 -DLIBDIR=\"/opt/local/share/hunspell:/usr/share/myspell:/usr/share/myspell/dicts\" -isysroot /Developer/SDKs/MacOSX10.5.sdk -arch x86_64 -mmacosx-version-min=10.5 -c -o testparser.o testparser.cxx
/bin/sh ../../libtool --tag=CXX   --mode=link /usr/bin/g++-4.0  -O2 -DLIBDIR=\"/opt/local/share/hunspell:/usr/share/myspell:/usr/share/myspell/dicts\" -isysroot /Developer/SDKs/MacOSX10.5.sdk -arch x86_64 -mmacosx-version-min=10.5  -L/opt/local/lib -arch x86_64 -mmacosx-version-min=10.5 -o testparser firstparser.o htmlparser.o latexparser.o manparser.o testparser.o textparser.o ../hunspell/libhunspell-1.2.la 
mkdir .libs
/usr/bin/g++-4.0 -O2 -DLIBDIR=\"/opt/local/share/hunspell:/usr/share/myspell:/usr/share/myspell/dicts\" -isysroot /Developer/SDKs/MacOSX10.5.sdk -arch x86_64 -mmacosx-version-min=10.5 -arch x86_64 -mmacosx-version-min=10.5 -o .libs/testparser firstparser.o htmlparser.o latexparser.o manparser.o testparser.o textparser.o -Wl,-bind_at_load  -L/opt/local/lib ../hunspell/.libs/libhunspell-1.2.dylib
ld warning: in ../hunspell/.libs/libhunspell-1.2.dylib, file is not of required architecture
Undefined symbols:
  "unicodeisalpha(unsigned short)", referenced from:
      TextParser::is_wordchar(char*)   in textparser.o
  "u8_u16(w_char*, int, char const*)", referenced from:
      TextParser::is_wordchar(char*)   in textparser.o
  "flag_bsearch(unsigned short*, unsigned short, int)", referenced from:
      TextParser::is_wordchar(char*)   in textparser.o
  "mystrdup(char const*)", referenced from:
      TextParser::get_prevline(int)    in textparser.o
      TextParser::change_token(char const*)in textparser.o
ld: symbol(s) not found
collect2: ld returned 1 exit status
make[3]: *** [testparser] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Error: Status 1 encountered during processing.
philip@water.local>

Please advise and/or request additional information.

Change History (7)

comment:1 Changed 12 years ago by mf2k (Frank Schima)

Description: modified (diff)

comment:2 Changed 12 years ago by jmroot (Joshua Root)

Summary: hunspell not compilinghunspell not compiling with +universal

Looks like it doesn't work with the default universal variant (or possibly just with universal_archs=x86_64). Universal isn't guaranteed to work for everything, 64-bit universal even less so. Normally we would just set universal_variant no on such ports, unless someone supplies a patch to make it work.

comment:3 Changed 11 years ago by ryandesign (Ryan Schmidt)

It builds ok with build_arch x86_64 on Snow Leopard.

Disabling universal variant for now in r57206.

comment:4 Changed 11 years ago by domiman@…

Cc: domiman@… added

Cc Me!

comment:5 in reply to:  2 Changed 11 years ago by emanuel.evans@…

The problem is actually with the i386 arch (x86_64 builds fine). I found that using -m32 instead of -arch i386 fixes the problem, but I don't know how to change it correctly.

comment:6 Changed 11 years ago by nicos_pavlov@…

I think this ticket is fixed, with the version 1.2.8_1 which was made some days ago.

comment:7 Changed 10 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.