Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#19907 closed enhancement (wontfix)

python26 A no_tkinter variant would be nice

Reported by: oliver.andrich@… Owned by: blb@…
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: Cc: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Port: python26

Description

I am not using tkinter at all, but if I want to use the python26 package I have to install tkinter, tk, tcl, parts of X11 and a lot more, what I will never need. May be you can consider this.

The separation of the python25 package was too much because of the virtualenv issue. But instead of seperate packages variants would be fine. I can prefectly live with reinstalling python if I will ever need tkinter.

Change History (4)

comment:1 Changed 11 years ago by mf2k (Frank Schima)

Cc: mcalhoun@… added
Owner: changed from macports-tickets@… to blb@…
Port: python26 added
Type: requestenhancement

comment:2 Changed 11 years ago by oliver.andrich@…

Just a short comment, today I found a way to work around this issue by installing tk variant quartz before installing python itself. Then it skips the complete X11 stuff.

comment:3 Changed 11 years ago by blb@…

Resolution: wontfix
Status: newclosed

See the FAQ entry about this.

comment:4 Changed 11 years ago by oliver.andrich@…

Thanks for the pointer to the FAQ. I can live with that, and I hope on a solution after implementing #126 someday.

Note: See TracTickets for help on using tickets.