Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#19911 closed defect (invalid)

problem in installing py25-mvpa

Reported by: guixue@… Owned by: jameskyle@…
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: py25 pymvpa Cc:
Port: py25-pymvpa

Description (last modified by jmroot (Joshua Root))

I am trying to install pymvpa using macports. following the instruction on pymvpa.org, I am using the following command:

sudo port install py25-pymvpa +scipy +pynifti +hcluster +libsvm +matplotlib +pywavelet

while most of installed went on smoothly, I met this following problem. I wonder if you could help me out. many thanks!

--->  Building py25-pymvpa
Error: Target org.macports.build returned: shell command "cd /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py25-pym

vpa/work/py25-pymvpa-current && CFLAGS='-I/opt/local/include -L/opt/local/lib' python2.5 setup.py build_ext --with-libsvm" returned error 1
Command output: build/src.macosx-10.5-i386-2.5/mvpa/clfs/libsvmc/svmc_wrap.cpp: In function 'void init_svmc()':

build/src.macosx-10.5-i386-2.5/mvpa/clfs/libsvmc/svmc_wrap.cpp:6569: error: 'import_array' was not declared in this scope
build/src.macosx-10.5-i386-2.5/mvpa/clfs/libsvmc/svmc_wrap.cpp:2796:25: error: arrayobject.h: No such file or directory

build/src.macosx-10.5-i386-2.5/mvpa/clfs/libsvmc/svmc_wrap.cpp: In function 'PyObject* svm_node_matrix2numpy_array(svm_node**, int, int)':
build/src.macosx-10.5-i386-2.5/mvpa/clfs/libsvmc/svmc_wrap.cpp:2823: error: 'npy_intp' was not declared in this scope

build/src.macosx-10.5-i386-2.5/mvpa/clfs/libsvmc/svmc_wrap.cpp:2823: error: expected `;' before 'dims'
build/src.macosx-10.5-i386-2.5/mvpa/clfs/libsvmc/svmc_wrap.cpp:2826: error: 'dims' was not declared in this scope

build/src.macosx-10.5-i386-2.5/mvpa/clfs/libsvmc/svmc_wrap.cpp:2826: error: 'NPY_DOUBLE' was not declared in this scope
build/src.macosx-10.5-i386-2.5/mvpa/clfs/libsvmc/svmc_wrap.cpp:2826: error: 'PyArray_SimpleNew' was not declared in this scope

build/src.macosx-10.5-i386-2.5/mvpa/clfs/libsvmc/svmc_wrap.cpp:2829: error: 'PyArrayObject' was not declared in this scope
build/src.macosx-10.5-i386-2.5/mvpa/clfs/libsvmc/svmc_wrap.cpp:2829: error: 'a' was not declared in this scope

build/src.macosx-10.5-i386-2.5/mvpa/clfs/libsvmc/svmc_wrap.cpp:2829: error: expected primary-expression before ')' token
build/src.macosx-10.5-i386-2.5/mvpa/clfs/libsvmc/svmc_wrap.cpp:2829: error: expected `;' before 'array'

build/src.macosx-10.5-i386-2.5/mvpa/clfs/libsvmc/svmc_wrap.cpp:2843: error: expected primary-expression before ')' token
build/src.macosx-10.5-i386-2.5/mvpa/clfs/libsvmc/svmc_wrap.cpp:2843: error: 'PyArray_Return' was not declared in this scope

build/src.macosx-10.5-i386-2.5/mvpa/clfs/libsvmc/svmc_wrap.cpp: In function 'PyObject* doubleppcarray2numpy_array(double**, int, int)':
build/src.macosx-10.5-i386-2.5/mvpa/clfs/libsvmc/svmc_wrap.cpp:2854: error: 'npy_intp' was not declared in this scope

build/src.macosx-10.5-i386-2.5/mvpa/clfs/libsvmc/svmc_wrap.cpp:2854: error: expected `;' before 'dims'
build/src.macosx-10.5-i386-2.5/mvpa/clfs/libsvmc/svmc_wrap.cpp:2857: error: 'dims' was not declared in this scope

build/src.macosx-10.5-i386-2.5/mvpa/clfs/libsvmc/svmc_wrap.cpp:2857: error: 'NPY_DOUBLE' was not declared in this scope
build/src.macosx-10.5-i386-2.5/mvpa/clfs/libsvmc/svmc_wrap.cpp:2857: error: 'PyArray_SimpleNew' was not declared in this scope

build/src.macosx-10.5-i386-2.5/mvpa/clfs/libsvmc/svmc_wrap.cpp:2860: error: 'PyArrayObject' was not declared in this scope
build/src.macosx-10.5-i386-2.5/mvpa/clfs/libsvmc/svmc_wrap.cpp:2860: error: 'a' was not declared in this scope

build/src.macosx-10.5-i386-2.5/mvpa/clfs/libsvmc/svmc_wrap.cpp:2860: error: expected primary-expression before ')' token
build/src.macosx-10.5-i386-2.5/mvpa/clfs/libsvmc/svmc_wrap.cpp:2860: error: expected `;' before 'array'

build/src.macosx-10.5-i386-2.5/mvpa/clfs/libsvmc/svmc_wrap.cpp:2873: error: expected primary-expression before ')' token
build/src.macosx-10.5-i386-2.5/mvpa/clfs/libsvmc/svmc_wrap.cpp:2873: error: 'PyArray_Return' was not declared in this scope

build/src.macosx-10.5-i386-2.5/mvpa/clfs/libsvmc/svmc_wrap.cpp: In function 'void init_svmc()':
build/src.macosx-10.5-i386-2.5/mvpa/clfs/libsvmc/svmc_wrap.cpp:6569: error: 'import_array' was not declared in this scope

error: Command "/usr/bin/g++-4.0 -DNDEBUG -g -fwrapv -O3 -Wall -I/opt/local/include -L/opt/local/lib -I/usr/include/libsvm-2.0/libsvm -I/usr/include/libsvm -I/usr/local/in
clude/libsvm -I/usr/local/include/libsvm-2.0/libsvm -I/usr/local/include -I/opt/local/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/numpy/co

re/include -I/opt/local/Library/Frameworks/Python.framework/Versions/2.5/include/python2.5 -c build/src.macosx-10.5-i386-2.5/mvpa/clfs/libsvmc/svmc_wrap.cpp -o build/temp.
macosx-10.5-i386-2.5/build/src.macosx-10.5-i386-2.5/mvpa/clfs/libsvmc/svmc_wrap.o" failed with exit status 1

Change History (5)

comment:1 Changed 12 years ago by jmroot (Joshua Root)

Description: modified (diff)
Owner: changed from macports-tickets@… to jameskyle@…
Port: py25-pymvpa added
Priority: HighNormal

Please remember to use WikiFormatting.

comment:2 Changed 12 years ago by jameskyle@…

Resolution: invalid
Status: newclosed

Please reattempt installing with the updates I made this weekend, they've fixed a lot of similar problems/build bugs

I'm marking this invalid because is no longer applicable to the current versions of the software involved, but *please* post another ticket with the up to date error info.

cheers,

-james

comment:3 Changed 12 years ago by guixue@…

I still have the same problem. could you let me know if I need to update anything first? Gui

comment:4 in reply to:  3 Changed 12 years ago by mf2k (Frank Schima)

Replying to guixue@…:

I still have the same problem. could you let me know if I need to update anything first? Gui

So you tried the following?

sudo port selfupdate
sudo port upgrade outdated
sudo port clean py25-pymvpa
sudo port install py25-pymvpa +scipy +pynifti +hcluster +libsvm +matplotlib +pywavelet

comment:5 Changed 12 years ago by guixue@…

thanks. works very well now.

Note: See TracTickets for help on using tickets.