Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#19936 closed defect (worksforme)

zsh-4.3.10-doc.tar.bz2 stored under zsh instead of zsh-devel

Reported by: vinc17@… Owned by: nox@…
Priority: High Milestone:
Component: ports Version: 1.7.1
Keywords: Cc:
Port: zsh-devel

Description

It is not possible to upgrade zsh-devel:

prunille:~> sudo port -v upgrade zsh-devel
--->  Fetching zsh-devel
--->  zsh-4.3.10.tar.bz2 doesn't seem to exist in /opt/local/var/macports/distfiles/zsh
--->  Attempting to fetch zsh-4.3.10.tar.bz2 from http://voxel.dl.sourceforge.net/zsh
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 2671k  100 2671k    0     0   127k      0  0:00:21  0:00:21 --:--:--  143k
--->  Verifying checksum(s) for zsh-devel
--->  Checksumming zsh-4.3.10.tar.bz2
--->  Checksumming zsh-4.3.10-doc.tar.bz2
Error: Checksum (md5) mismatch for zsh-4.3.10-doc.tar.bz2
Portfile checksum: zsh-4.3.10-doc.tar.bz2 md5 c7bbc55d7914d7c3c60329d92396f75f
Distfile checksum: zsh-4.3.10-doc.tar.bz2 md5 7a21e2e38381d79473b1a8f2c28461da
Error: Checksum (sha1) mismatch for zsh-4.3.10-doc.tar.bz2
Portfile checksum: zsh-4.3.10-doc.tar.bz2 sha1 e67e10478aa69a9e9cc92986515d337efc30a2bf
Distfile checksum: zsh-4.3.10-doc.tar.bz2 sha1 d5520ed3531a8aed1386063436713a578cd01e0d
Error: Checksum (rmd160) mismatch for zsh-4.3.10-doc.tar.bz2
Portfile checksum: zsh-4.3.10-doc.tar.bz2 rmd160 b56fd30ac63e2d3f2479c7d390ced260cad604f7
Distfile checksum: zsh-4.3.10-doc.tar.bz2 rmd160 8050b6ac33928d01900bab527d87d25094d7e3ed
The correct checksum line may be:
checksums           zsh-4.3.10.tar.bz2 \
                    md5     74c5b275544400082a1cde806c98682a \
                    sha1    132f9ce411bf318abccbae9cdc2f8cc14f8be85b \
                    rmd160  fad1412b76d1388d825cb870681c21696fdfa273 \
                    zsh-4.3.10-doc.tar.bz2 \
                    md5     7a21e2e38381d79473b1a8f2c28461da \
                    sha1    d5520ed3531a8aed1386063436713a578cd01e0d \
                    rmd160  8050b6ac33928d01900bab527d87d25094d7e3ed
Error: Target org.macports.checksum returned: Unable to verify file checksums
Warning: the following items did not execute (for zsh-devel): org.macports.destroot org.macports.extract org.macports.checksum org.macports.patch org.macports.configure org.macports.build
Error: Unable to upgrade port: 1

Change History (10)

comment:1 Changed 12 years ago by vinc17@…

Hmm... the problem seems to come from the fact that zsh-4.3.10-doc.tar.bz2 is stored under zsh instead of zsh-devel, so that "port clean --all zsh-devel" doesn't work as expected. I don't see why zsh-4.3.10-doc.tar.bz2 is stored in a directory belonging to a different port!

comment:2 Changed 12 years ago by vinc17@…

Summary: zsh-devel 4.3.10 checksum mismatchzsh-4.3.10-doc.tar.bz2 stored under zsh instead of zsh-devel

comment:3 Changed 12 years ago by nox@…

Resolution: worksforme
Status: newclosed
Bellcross:dports nox$ sudo port clean -f --all zsh-devel
--->  Cleaning zsh-devel
Bellcross:dports nox$ sudo port checksum zsh-devel +doc
--->  Computing dependencies for zsh-devel
--->  Fetching zsh-devel
--->  Attempting to fetch zsh-4.3.10.tar.bz2 from http://kent.dl.sourceforge.net/zsh
--->  Attempting to fetch zsh-4.3.10-doc.tar.bz2 from http://kent.dl.sourceforge.net/zsh
--->  Verifying checksum(s) for zsh-devel
Bellcross:dports nox$ ls /opt/local/var/macports/distfiles/zsh*
zsh-4.3.10-doc.tar.bz2  zsh-4.3.10.tar.bz2

comment:4 Changed 12 years ago by vinc17@…

It works with the -f option, but this is an undocumented feature and the -f option should never be required. In fact, after some tests, I've found that the problem is due to the fact that contrary to "port upgrade", "port clean" doesn't remember the variant (and using the variant with "port clean" isn't even documented). I've opened bug #19940.

comment:5 Changed 12 years ago by nox@…

The checksum problem does not come from the dist_subdir directive, but because of an invalid fetch, which happens sometimes. I don't put distfiles into zsh-devel/ because someday zsh 4.3 will become stable and zsh port will thus be updated. port does not have to remember any variant as it simply deletes the distfile directory. As zsh-devel as a custom distfile directory, port requires the -f flag: {{ $ sudo port clean --dist zsh-devel ---> Cleaning zsh-devel Warning: Distfiles directory '/opt/local/var/macports/distfiles/zsh' may contain distfiles needed for other ports, use the -f flag to force removal }}}

There is nothing undocumented here.

comment:6 Changed 12 years ago by nox@…

Missing a brace:

$ sudo port clean --dist zsh-devel
--->  Cleaning zsh-devel
Warning: Distfiles directory '/opt/local/var/macports/distfiles/zsh' may contain distfiles needed for other ports, use the -f flag to force removal

comment:7 in reply to:  5 Changed 12 years ago by vinc17@…

Replying to nox@…:

There is nothing undocumented here.

The -f option (as used here) is not documented in the port(1) man page, and I certainly don't want to use an undocumented option (as shown elsewhere, the -f option can do bad things).

comment:8 Changed 12 years ago by nox@…

The -f option won't do bad things here, as said in the warning message. But sure, we can add to the port(1) manpage that clean -f deletes the distfiles subdirectory itself.

comment:9 Changed 12 years ago by blb@…

Note also ticket #16061 about -f.

comment:10 Changed 12 years ago by vinc17@…

Warning messages don't always say everything, so that I tend not to trust them.

Note: See TracTickets for help on using tickets.