Opened 11 years ago

Closed 11 years ago

#19950 closed defect (fixed)

gnupg 1.4.9 links against libusb if installed

Reported by: tobi_m@… Owned by: waqar@…
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: Cc:
Port: gnupg

Description

gnupg links silently against libusb if libusb is already available when installing gnupg. This leads to problems when uninstalling libusb.

Either gnupg should be configured not to link against libusb in any case, or there should be a dependency.

Change History (7)

comment:1 Changed 11 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to waqar@…

comment:2 Changed 11 years ago by blb@…

Which part of gnupg, the gpg executable or another?

comment:3 Changed 11 years ago by tobi_m@…

The gpg executable. However I don't know about the others, I didn't try

comment:4 Changed 11 years ago by tobi_m@…

The simplest solution is probabily ./configure --without-libusb

comment:5 Changed 11 years ago by blb@…

The reason I ask was that this came up with the gnupg2 port (#18884) but that was just with the scdaemon program (which I don't see with gnupg). However I must not have had libusb installed at the time I built gnupg as I can reproduce it here as well now.

As with gnupg2, libusb can simply be added as a dependency since it isn't that big of a port.

comment:6 Changed 11 years ago by roederja

I just had the same problem. I will commit the change to configure with --without-libusb if the maintainer doesn't respond.

comment:7 Changed 11 years ago by roederja

Resolution: fixed
Status: newclosed

Fixed in r62737.

Note: See TracTickets for help on using tickets.