Opened 11 years ago

Closed 11 years ago

#19954 closed defect (duplicate)

subversion-1.6.2 Build fails on Tiger (ppc)

Reported by: cgtobi@… Owned by: danielluke (Daniel J. Luke)
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: subversion svn tiger ppc Cc:
Port: subversion

Description

Build fails during linking

Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_subversion/work/subversion-1.6.2" && make all " returned error 2
Command output: ranlib: file: .libs/libsvn_subr-1.a(win32_crypto.o) has no symbols
ranlib: file: .libs/libsvn_subr-1.a(win32_xlate.o) has no symbols
ranlib: file: .libs/libsvn_subr-1.a(config_win.o) has no symbols
ranlib: file: .libs/libsvn_subr-1.a(win32_crashrpt.o) has no symbol
s
ranlib: file: .libs/libsvn_subr-1.a(win32_crypto.o) has no symbols
ranlib: file: .libs/libsvn_subr-1.a(win32_xlate.o) has no symbols
cd subversion/libsvn_delta && /bin/sh /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_subversion/work/subversion-1.6.2/libtool --tag=CC --silent --mode=link /usr/bin/gcc-4.0  -O2     -L/opt/local/lib    -L/opt/local/lib/db46 -L/opt/local/lib -L/opt/local/lib/db46 -L/opt/local/lib  -rpath /opt/local/lib -o libsvn_delta-1.
la  cancel.lo compat.lo compose_delta.lo debug_editor.lo default_editor.lo depth_filter_editor.lo path_driver.lo svndiff.lo text_delta.lo version.lo xdelta.lo ../../subversion/libsvn_subr/libsvn_subr-1.la /opt/local/lib/libaprutil-1.la  -liconv /opt/local/lib/libapr-1.la -lpthread -lz -lintl  -framework Security -framework CoreFoundation -framework CoreServices
warning: no debug map in executable (-arch ppc)
/bin/sh /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_p
orts_devel_subversion/work/subversion-1.6.2/libtool --tag=CC --silent --mode=compile /usr/bin/gcc-4.0 -I/opt/local/include   -DDARWIN -DSIGPROCMASK_SETS_THREAD_MASK -no-cpp-precomp  -I/opt/local/include/apr-1   -I/opt/local/include/apr-1 -I/opt/local/include  -O2     -I./subversion/include -I./subversion -I/opt/local/include/apr-1   -I/opt/local/include/apr-1 -I/opt/local/include -I/opt/local/include/db46 -I/opt/local/include/neon -I/opt/local/include  -o subversion/libsvn_fs_fs/caching.lo -c subversion/l
ibsvn_fs_fs/caching.c
/bin/sh /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_subversion/work/subversion-1.6.2/libtool --tag=CC --silent --mode=compile /usr/bin/gcc-4.0 -I/opt/local/include   -DDARWIN -DSIGPROCMASK_SETS_THREAD_MASK -no-cpp-precomp  -I/opt/local/include/apr-1   -I/opt/local/include/apr-1 -I/opt/local/include  -O2     -I./subversion/include -I./subversion -I/opt/local/include/apr-1   -I/opt/local/include/apr-1 -I/opt/local/include -I/opt/
local/include/db46 -I/opt/local/include/neon -I/opt/local/include  -o subversion/libsvn_fs_fs/dag.lo -c subversion/libsvn_fs_fs/dag.c
/bin/sh /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_subversion/work/subversion-1.6.2/libtool --tag=CC --silent --mode=compile /usr/bin/gcc-4.0 -I/opt/local/include   -DDARWIN -DSIGPROCMASK_SETS_THREAD_MASK -no-cpp-precomp  -I/opt/local/include/apr-1   -I/opt/local/include/apr-1 -I/opt/local/include  -O2     -I./subver
sion/include -I./subversion -I/opt/local/include/apr-1   -I/opt/local/include/apr-1 -I/opt/local/include -I/opt/local/include/db46 -I/opt/local/include/neon -I/opt/local/include  -o subversion/libsvn_fs_fs/err.lo -c subversion/libsvn_fs_fs/err.c
/bin/sh /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_subversion/work/subversion-1.6.2/libtool --tag=CC --silent --mode=compile /usr/bin/gcc-4.0 -I/opt/local/include   -DDARWIN -DSIGPROCMASK_SETS_THREAD_MASK -
no-cpp-precomp  -I/opt/local/include/apr-1   -I/opt/local/include/apr-1 -I/opt/local/include  -O2     -I./subversion/include -I./subversion -I/opt/local/include/apr-1   -I/opt/local/include/apr-1 -I/opt/local/include -I/opt/local/include/db46 -I/opt/local/include/neon -I/opt/local/include  -o subversion/libsvn_fs_fs/fs.lo -c subversion/libsvn_fs_fs/fs.c
/bin/sh /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_subversion/work/subversion-1.6.2/libtool --ta
g=CC --silent --mode=compile /usr/bin/gcc-4.0 -I/opt/local/include   -DDARWIN -DSIGPROCMASK_SETS_THREAD_MASK -no-cpp-precomp  -I/opt/local/include/apr-1   -I/opt/local/include/apr-1 -I/opt/local/include  -O2     -I./subversion/include -I./subversion -I/opt/local/include/apr-1   -I/opt/local/include/apr-1 -I/opt/local/include -I/opt/local/include/db46 -I/opt/local/include/neon -I/opt/local/include  -o subversion/libsvn_fs_fs/fs_fs.lo -c subversion/libsvn_fs_fs/fs_fs.c
/bin/sh /opt/local/var/macports/build/
_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_subversion/work/subversion-1.6.2/libtool --tag=CC --silent --mode=compile /usr/bin/gcc-4.0 -I/opt/local/include   -DDARWIN -DSIGPROCMASK_SETS_THREAD_MASK -no-cpp-precomp  -I/opt/local/include/apr-1   -I/opt/local/include/apr-1 -I/opt/local/include  -O2     -I./subversion/include -I./subversion -I/opt/local/include/apr-1   -I/opt/local/include/apr-1 -I/opt/local/include -I/opt/local/include/db46 -I/opt/local/include/neon -I/opt/local/in
clude  -o subversion/libsvn_fs_fs/id.lo -c subversion/libsvn_fs_fs/id.c
/bin/sh /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_subversion/work/subversion-1.6.2/libtool --tag=CC --silent --mode=compile /usr/bin/gcc-4.0 -I/opt/local/include   -DDARWIN -DSIGPROCMASK_SETS_THREAD_MASK -no-cpp-precomp  -I/opt/local/include/apr-1   -I/opt/local/include/apr-1 -I/opt/local/include  -O2     -I./subversion/include -I./subversion -I/opt/local/include/apr-1   -I/op
t/local/include/apr-1 -I/opt/local/include -I/opt/local/include/db46 -I/opt/local/include/neon -I/opt/local/include  -o subversion/libsvn_fs_fs/key-gen.lo -c subversion/libsvn_fs_fs/key-gen.c
/bin/sh /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_subversion/work/subversion-1.6.2/libtool --tag=CC --silent --mode=compile /usr/bin/gcc-4.0 -I/opt/local/include   -DDARWIN -DSIGPROCMASK_SETS_THREAD_MASK -no-cpp-precomp  -I/opt/local/include/apr-1   -I/opt/lo
cal/include/apr-1 -I/opt/local/include  -O2     -I./subversion/include -I./subversion -I/opt/local/include/apr-1   -I/opt/local/include/apr-1 -I/opt/local/include -I/opt/local/include/db46 -I/opt/local/include/neon -I/opt/local/include  -o subversion/libsvn_fs_fs/lock.lo -c subversion/libsvn_fs_fs/lock.c
./build/transform_sql.sh subversion/libsvn_fs_fs/rep-cache-db.sql < subversion/libsvn_fs_fs/rep-cache-db.sql > ./subversion/libsvn_fs_fs/rep-cache-db.h
/bin/sh /opt/local/var/macports/build/_opt_local_var
_macports_sources_rsync.macports.org_release_ports_devel_subversion/work/subversion-1.6.2/libtool --tag=CC --silent --mode=compile /usr/bin/gcc-4.0 -I/opt/local/include   -DDARWIN -DSIGPROCMASK_SETS_THREAD_MASK -no-cpp-precomp  -I/opt/local/include/apr-1   -I/opt/local/include/apr-1 -I/opt/local/include  -O2     -I./subversion/include -I./subversion -I/opt/local/include/apr-1   -I/opt/local/include/apr-1 -I/opt/local/include -I/opt/local/include/db46 -I/opt/local/include/neon -I/opt/local/include  -o subv
ersion/libsvn_fs_fs/rep-cache.lo -c subversion/libsvn_fs_fs/rep-cache.c
/bin/sh /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_subversion/work/subversion-1.6.2/libtool --tag=CC --silent --mode=compile /usr/bin/gcc-4.0 -I/opt/local/include   -DDARWIN -DSIGPROCMASK_SETS_THREAD_MASK -no-cpp-precomp  -I/opt/local/include/apr-1   -I/opt/local/include/apr-1 -I/opt/local/include  -O2     -I./subversion/include -I./subversion -I/opt/local/include/apr-1   -I/op
t/local/include/apr-1 -I/opt/local/include -I/opt/local/include/db46 -I/opt/local/include/neon -I/opt/local/include  -o subversion/libsvn_fs_fs/tree.lo -c subversion/libsvn_fs_fs/tree.c
/bin/sh /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_subversion/work/subversion-1.6.2/libtool --tag=CC --silent --mode=compile /usr/bin/gcc-4.0 -I/opt/local/include   -DDARWIN -DSIGPROCMASK_SETS_THREAD_MASK -no-cpp-precomp  -I/opt/local/include/apr-1   -I/opt/local/include/apr-1 -I/opt/local/include  -O2     -I./subversion/include -I./subversion -I/opt/local/include/apr-1   -I/opt/local/include/apr-1 -I/opt/local/include -I/opt/local/include/db46 -I/opt/local/include/neon -I/opt/local/include  -o subversion/libsvn_fs_util/fs-util.lo -c subversion/libsvn_fs_util/fs-util.c
cd subversion/libsvn_fs_util && /bin/sh /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_subversion/work/subversion-1.6.2/libtool --tag=CC --silent --mode=link /usr/bin/gcc-4.0  -O2     -L/opt/local/lib    -L/opt/local/lib/db46 -L/opt/local/lib -L/opt/local/lib/db46 -L/opt/local/lib  -rpath /opt/local/lib -o libsvn_fs_util-1.la  fs-util.lo ../../subversion/libsvn_subr/libsvn_subr-1.la /opt/local/lib/libaprutil-1.la  -liconv /opt/local/lib/libapr-1.la -lpthread -lintl  -framework Security -framework CoreFoundation -framework CoreServices
warning: no debug map in executable (-arch ppc)
cd subversion/libsvn_fs_fs && /bin/sh /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_subversion/work/subversion-1.6.2/libtool --tag=CC --silent --mode=link /usr/bin/gcc-4.0  -O2     -L/opt/local/lib    -L/opt/local/lib/db46 -L/opt/local/lib -L/opt/local/lib/db46 -L/opt/local/lib  -rpath /opt/local/lib -o libsvn_fs_fs-1.la  caching.lo dag.lo err.lo fs.lo fs_fs.lo id.lo key-gen.lo lock.lo rep-cache.lo tree.lo ../../subversion/libsvn_delta/libsvn_delta-1.la ../../subversion/libsvn_subr/libsvn_subr-1.la /opt/local/lib/libaprutil-1.la  -liconv /opt/local/lib/libapr-1.la -lpthread ../../subversion/libsvn_fs_util/libsvn_fs_util-1.la -lintl  -framework Security -framework CoreFoundation -framework CoreServices
ld: Undefined symbols:
_svn_error__malfunction referenced from libsvn expected to be defined in libsvn
_svn_checksum_ctx_create referenced from libsvn expected to be defined in libsvn
_svn_checksum_final referenced from libsvn expected to be defined in libsvn
_svn_checksum_update referenced from libsvn expected to be defined in libsvn
/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/libtool: internal link edit command failed
make: *** [subversion/libsvn_fs_fs/libsvn_fs_fs-1.la] Error 1
Error: Unable to upgrade port: 1

Change History (2)

comment:1 Changed 11 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to dluke@…

comment:2 Changed 11 years ago by danielluke (Daniel J. Luke)

Resolution: duplicate
Status: newclosed

duplicate of #18937

Workaround is to deactivate or uninstall the old version of subversion before attempting to build the new version.

Note: See TracTickets for help on using tickets.