Opened 12 years ago

Closed 12 years ago

#19977 closed defect (fixed)

Configure of mkvtoolnix fails under boost 1.39

Reported by: gbooker@… Owned by: ruud@…
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: Cc: sanchom (Sancho McCann), nox@…
Port: mkvtoolnix boost

Description

I don't know whether this is the fault of mkvtoolnix or boost, but I suspect the latter.

When I was upgrading ports, mkvtoolnix failed to configure with the following error:

...
checking for magic_open in -lmagic... no
checking for boostlib >= 1.32.0... yes
checking whether the Boost::Regex library is available... yes
checking for main in -lboost_regex-mt... no
checking for main in -lboost_regex-boost_regex-mt... no
configure: error: Could not link against boost_regex-boost_regex-mt !

I saw that i had libboost_regex-xgcc40-mt-boost_regex-mt in /opt/local/lib, but not libboost_regex-mt-boost_regex-mt (minus the xgcc40). I created a symlink, and now mkvtools builds just fine.

Should boost be creating a symlink or should mkvtoolnix have a smarter configure?

Change History (6)

comment:1 Changed 12 years ago by mf2k (Frank Schima)

Cc: sanchom@… added
Owner: changed from macports-tickets@… to ruud@…
Port: mkvtoolnix boost added

comment:2 Changed 12 years ago by ruud@…

This is caused by the rename of libboost_regex-mt.dylib to libboost_regex-xgcc40-mt.dylib. Does the boost-maintainer know how this should be fixed?

comment:3 in reply to:  2 Changed 12 years ago by sanchom (Sancho McCann)

I'm no longer the maintainer, but we used to create symlinks named like "libboost_regex-mt.dylib" that pointed to the compiler-version-named instances of the libraries. I'd suggest to continue doing this.

Replying to ruud@…:

This is caused by the rename of libboost_regex-mt.dylib to libboost_regex-xgcc40-mt.dylib. Does the boost-maintainer know how this should be fixed?

comment:4 Changed 12 years ago by mf2k (Frank Schima)

Cc: nox@… added

Ccing boost's maintainer. This is similar to #20001.

comment:5 Changed 12 years ago by gbooker@…

I removed my symlinks and tried boost 1.39.0_2. This can be closed as fixed now. Thanks.

comment:6 Changed 12 years ago by nox@…

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.