Opened 12 years ago

Closed 12 years ago

#19982 closed defect (duplicate)

cdparanoia fails to build

Reported by: steven@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: Cc:
Port: cdparanoia

Description (last modified by blb@…)

--->  Building cdparanoia
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_audio_cdparanoia/work/cdparanoia-III-10.2" && make all " returned error 2
Command output:                 -o cdparanoia -lcdda_interface -lcdda_paranoia -lm
Undefined symbols:
  "_cdda_version", referenced from:
      _main in main.o
      _main in main.o
      _main in main.o
  "_paranoia_cachemodel_size", referenced from:
      _analyze_cache in cachetest.o
  "_paranoia_version", referenced from:
      _main in main.o
      _main in main.o
      _main in main.o
      _analyze_cache in cachetest.o
  "_cdda_read_timed", referenced from:
      _time_drive in cachetest.o
      _analyze_cache in cachetest.o
      _analyze_cache in cachetest.o
      _analyze_cache in cachetest.o
      _analyze_cache in cachetest.o
      _analyze_cache in cachetest.o
      _analyze_cache in cachetest.o
      _analyze_cache in cachetest.o
      _analyze_cache in cachetest.o
      _analyze_cache in cachetest.o
      _analyze_cache in cachetest.o
      _analyze_cache in cachetest.o
ld: symbol(s) not found
collect2: ld returned 1 exit status
make[1]: *** [cdparanoia] Error 1
make: *** [all] Error 2

Change History (3)

comment:1 Changed 12 years ago by blb@…

Description: modified (diff)
Keywords: cdparanoia removed
Port: cdparanoia added

Is this an upgrade for cdparanoia? If so, sounds like a dup of #19831.

comment:2 Changed 12 years ago by steven@…

Yes it is an upgrade. My search didn't seem to turn up similar results so I posted this. You can mark it as duplicate of the mentioned ticket.

comment:3 Changed 12 years ago by mf2k (Frank Schima)

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.