Opened 12 years ago

Closed 12 years ago

#19985 closed defect (duplicate)

ghc 6.10.3 cannot exec '/opt/local/bin/i686-apple-darwin8-gcc-4. 0.1'

Reported by: gonhidi@… Owned by: gwright@…
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: ghc 6.10.3 Tiger 10.4.11 /opt/local/bin/i686-apple-darwin8-gcc-4. 0.1 Cc: ryandesign (Ryan Schmidt)
Port: ghc

Description

When building ghc 6.10.3_1 on MacOSX 10.4.11 (XCode 2.5 installed) I get the following error:

Preprocessing library hpc-0.5.0.3...
gcc: installation problem, cannot exec '/opt/local/bin/i686-apple-darwin8-gcc-4.0.1': No such file or directory
compiling dist-bootstrapping/build/Trace/Hpc/Reflect_hsc_make.c failed
command was: /opt/local/bin/gcc -c -I/opt/local/include -D__GLASGOW_HASKELL__=606 -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_ghc/work/ghc-bootstrap/lib/ghc-6.6/include -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_po
rts_lang_ghc/work/ghc-bootstrap/lib/ghc-6.6/include dist-bootstrapping/build/Trace/Hpc/Reflect_hsc_make.c -o dist-bootstrapping/build/Trace/Hpc/Reflect_hsc_make.o
make[1]: *** [bootstrapping.conf] Error 1
make: *** [stage1] Error 2

Warning: the following items did not execute (for ghc): org.macports.activate org.macports.build org.macports.destroot org.macports.archive org.macports.install
Error: Status 1 encountered during processing.

Workaround: Soft-linking /opt/local/bin/i686-apple-darwin8-gcc-4.0.1 to /usr/bin/i686-apple-darwin8-gcc-4.0.1 seems to help get around this issue (but is not really a workaround for me because I later stumble upon a -lgmp issue such as (identical to?) the one noted on ticket #17321).

Attachments (1)

ghc-build-i686-trouble.txt (66.5 KB) - added by gonhidi@… 12 years ago.
Install log (debug enabled)

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by gonhidi@…

Attachment: ghc-build-i686-trouble.txt added

Install log (debug enabled)

comment:1 in reply to:  description ; Changed 12 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Owner: changed from macports-tickets@… to gwright@…

Replying to gonhidi@…:

gcc: installation problem, cannot exec '/opt/local/bin/i686-apple-darwin8-gcc-4.0.1': No such file or directory

Workaround: Soft-linking /opt/local/bin/i686-apple-darwin8-gcc-4.0.1 to /usr/bin/i686-apple-darwin8-gcc-4.0.1 seems to help get around this issue

Have you used gcc_select to select another version of gcc, e.g. one you installed with MacPorts? If so, then you are being affected by #19856.

(but is not really a workaround for me because I later stumble upon a -lgmp issue such as (identical to?) the one noted on ticket #17321).

Actually #19747.

comment:2 in reply to:  1 Changed 12 years ago by gonhidi@…

Replying to ryandesign@…:

Replying to gonhidi@…:

gcc: installation problem, cannot exec '/opt/local/bin/i686-apple-darwin8-gcc-4.0.1': No such file or directory

Workaround: Soft-linking /opt/local/bin/i686-apple-darwin8-gcc-4.0.1 to /usr/bin/i686-apple-darwin8-gcc-4.0.1 seems to help get around this issue

Have you used gcc_select to select another version of gcc, e.g. one you installed with MacPorts? If so, then you are being affected by #19856.

I hadn't realized that it wasn't enough to gcc_select gcc40 to ‘undo’ the use of gcc_select, so yes, I have been bitten by that one.

(but is not really a workaround for me because I later stumble upon a -lgmp issue such as (identical to?) the one noted on ticket #17321).

Actually #19747.

Damm! I don't know how I missed that one.

Sorry for the inconvenience and thank your for the prompt and kind help.

comment:3 Changed 12 years ago by gwright@…

Resolution: duplicate
Status: newclosed

Main issue is a duplicate of #19856. The "-lgmp" issue is the now resolved #19747.

Note: See TracTickets for help on using tickets.