Opened 12 years ago

Closed 12 years ago

#19986 closed defect (fixed)

libopenraw-0.0.8 Configure error - Could not find Boost headers version >= 1.33.0

Reported by: hanche Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: Cc: nox@…
Port: libopenraw boost

Description (last modified by mf2k (Frank Schima))

Configuring libopenraw ended in failure:

checking for Boost headers version >= 1.33.0... no[[BR]]
configure: error: Could not find Boost headers version >= 1.33.0

However, boost version 1.39.0_0 is installed and active. It was installed shortly before. This is all in a freshly installed macports (from dmg, hence freshly selfupdated) as a result of running “port install gimp2”.

(As a sidenote, configure is great when it works, but when it fails, I always end up tearing my hair out.)

Change History (11)

comment:1 Changed 12 years ago by hanche

Oops, I missed the “version” popup. “port version” returns 1.710, not 1.7.1.

comment:2 in reply to:  description ; Changed 12 years ago by hanche

I ran across the same problem while trying to install inkscape. The problem seems to be with boost, and this time I found a workaround:

# cd /opt/local/include
# ln -s boost-1_39/boost .

Now at least inkscape's configure is happy, but I don't know if this is the right workaround.

So: shift the blame from libopenraw to boost.

comment:3 in reply to:  2 ; Changed 12 years ago by hanche

My workaround didn't help for libopenraw. That is, the configure script for libopenraw got a bit further, but it got stuck at

checking for the Boost unit_test_framework library... no
configure: error: Could not find the flags to link with Boost unit_test_framework

comment:4 in reply to:  3 Changed 12 years ago by hanche

From looking a bit harder, I think I understand the issue now, though I don't know how it comes about or how to resolve it: Looking in config.log (for libopenraw) I find

ld: library not found for -lboost_unit_test_framework-gcc40-mt-1_39

But the boost package provides the library under the name libboost_unit_test_framework-xgcc40-mt-1_39.dylib instead (note the x in xgcc40).

comment:5 Changed 12 years ago by mf2k (Frank Schima)

Description: modified (diff)
Owner: changed from macports-tickets@… to devans@…
Port: libopenraw added
Summary: libopenraw-0.0.8 Configure error - Cound not find Boos headers version >= 1.33.0libopenraw-0.0.8 Configure error - Cound not find Boost headers version >= 1.33.0

What is the output of the following?

port installed boost

comment:6 in reply to:  5 ; Changed 12 years ago by hanche

Replying to macsforever2000@…:

What is the output of the following?

port installed boost
The following ports are currently installed:
  boost @1.39.0_0 (active)

comment:7 in reply to:  6 Changed 12 years ago by hanche

I went into the libopenraw work directory, changed the one occurence of "gcc40" in configure to "xgcc40", then ran

port install libopenraw

Worked like a charm. Heh.

comment:8 Changed 12 years ago by dbevans (David B. Evans)

Cc: nox@… added
Keywords: boost added
Status: newassigned

This appears to be a result of the recent upgrade of boost to 1.39.0. See #20012 also. So the question is whether the problem is with boost not providing the correct library names or whether this is intentional and ports dependent on boost need to be modified to use the new naming. Will check some other ports to see what they are doing (inkscape, ardour2) and see if a pattern emerges.

Ccing maintainer of boost for his comments as well.

comment:9 Changed 12 years ago by dbevans (David B. Evans)

Summary: libopenraw-0.0.8 Configure error - Cound not find Boost headers version >= 1.33.0libopenraw-0.0.8 Configure error - Could not find Boost headers version >= 1.33.0

comment:10 Changed 12 years ago by dbevans (David B. Evans)

An update to boost that may be pertinent was just committed in r52605 so please upgrade boost and see if this makes any difference. Thanks.

comment:11 Changed 12 years ago by nox@…

Keywords: boost removed
Port: boost added
Resolution: fixed
Status: assignedclosed

This problem is fixed by r52605.

Note: See TracTickets for help on using tickets.