Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#19990 closed defect (worksforme)

cmake crashes due to missing libidn

Reported by: illogic-al@… Owned by: macports-tickets@…
Priority: High Milestone:
Component: ports Version: 1.7.1
Keywords: libidn cmake crash missing dependency Cc: cssdev
Port: cmake libidn

Description (last modified by illogic-al@…)

Cmake port is missing a libidn dependency which leads to it crashing. To reproduce, install macports 1.7.1, port sync, and give the foll. command sudo port install amarok-devel

Should also work if you just deactivate libidn and install a port which requires cmake to build. or just run cmake from the command line. Which will both take less time than the above command.

Crash output:

/opt/local] % sudo port install amarok-devel               20:54
--->  Configuring automoc
Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_automoc/work/build" && cmake -DCMAKE_INSTALL_PREFIX=/opt/local -DCMAKE_VERBOSE_MAKEFILE=ON -DCMAKE_COLOR_MAKEFILE=ON -DCMAKE_BUILD_TYPE=Release -DCMAKE_BUILD_WITH_INSTALL_RPATH=ON -DCMAKE_SYSTEM_PREFIX_PATH="/opt/local;/usr" -DQT_QMAKE_EXECUTABLE=/opt/local/libexec/qt4-mac/bin/qmake -Wno-dev -DCMAKE_OSX_SYSROOT=/Developer/SDKs/MacOSX10.5.sdk ../automoc4-0.9.88 -DQT_QMAKE_EXECUTABLE=/opt/local/libexec/qt4-mac/bin/qmake -DCMAKE_OSX_ARCHITECTURES="ppc;i386" " returned error 133
Command output: dyld: Library not loaded: /opt/local/lib/libidn.11.dylib
  Referenced from: /opt/local/bin/cmake
  Reason: image not found
sh: line 1: 95947 Trace/BPT trap          cmake -DCMAKE_INSTALL_PREFIX=/opt/local -DCMAKE_VERBOSE_MAKEFILE=ON -DCMAKE_COLOR_MAKEFILE=ON -DCMAKE_BUILD_TYPE=Release -DCMAKE_BUILD_WITH_INSTALL_RPATH=ON -DCMAKE_SYSTEM_PREFIX_PATH="/opt/local;/usr" -DQT_QMAKE_EXECUTABLE=/opt/local/libexec/qt4-mac/bin/qmake -Wno-dev -DCMAKE_OSX_SYSROOT=/Developer/SDKs/MacOSX10.5.sdk ../automoc4-0.9.88 -DQT_QMAKE_EXECUTABLE=/opt/local/libexec/qt4-mac/bin/qmake -DCMAKE_OSX_ARCHITECTURES="ppc;i386"

Error: The following dependencies failed to build: automoc kdebase4-runtime kdelibs4 aspell texinfo lzmautils aspell-dict-en bzip2 cyrus-sasl2 enchant glib2 hunspell flex giflib jasper libart_lgpl libidn openexr ilmbase pcre shared-mime-info intltool gnome-common p5-xml-parser libxml2 soprano clucene redland curl db46 libxslt raptor rasqal strigi kdepimlibs4 akonadi boost boost-jam gpgme gnupg libgpg-error pth libical openldap db44 qimageblitz liblastfm fftw-3-single fftw-3 libsamplerate libsndfile flac libogg libvorbis ruby mysql5-devel qtscriptgenerator taglib-devel taglib-extras
Error: Status 1 encountered during processing.

Change History (4)

comment:1 Changed 12 years ago by illogic-al@…

Description: modified (diff)

comment:2 Changed 12 years ago by illogic-al@…

btw, this is weird because cmake shouldn't depend on anything.

comment:3 Changed 12 years ago by illogic-al@…

Resolution: worksforme
Status: newclosed

OK. so I uninstalled then installed cmake and then it just worked. And libidn is still uninstalled. Didn't port sync or do any updates in between. Weird. File under #heisenbug and close.

comment:4 Changed 12 years ago by blb@…

Cc: css@… added

Could be a case of opportunistic linking, when building cmake it sees libidn so links to it; perhaps cmake has some way of telling it to ignore libidn when installed?

Note: See TracTickets for help on using tickets.