Opened 12 years ago

Last modified 2 years ago

#19999 new defect

nss: signtool library search path busted

Reported by: quigley@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: nss

Description

Running signtool, I get this:

$ nss-signtool -d certdb
signtool: function failed: Failure to load dynamic library.
	Unknown error: -2804

If I set DYLD_LIBRARY_PATH manually, things seem to work:

$ DYLD_LIBRARY_PATH=/opt/local/lib/nss nss-signtool -d ../certdb -L

S Certificates
- ------------
(...output here...)

This is with an up-to-date ports tree; signtool reports itself as:

Signing Tool 3.12.0.3 -a signing tool for jar files

Change History (7)

comment:1 Changed 12 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to jeremyhu@…
Port: nss added

comment:2 Changed 11 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Status: newassigned

Can you attach a certdb for me to try? I don't see this.

comment:3 Changed 10 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Yeah the problem is that it's just using dlopen() without specifying the path... You should use DYLD_FALLBACK_LIBRARY_PATH instead.

comment:4 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: invalid
Status: assignedclosed

comment:5 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: invalid
Status: closedreopened

comment:6 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Owner: changed from jeremyhu@… to macports-tickets@…
Status: reopenednew

comment:7 Changed 2 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign added

I would like to determine if this is still a problem, and if so fix it, however when I try to reproduce it, I get a different error:

$ signtool -d certdb
signtool: function failed: SEC_ERROR_BAD_DATABASE: security library: bad database.

What is certdb? Is that a file or directory I'm supposed to already have? If so, how would I get it?

Note: See TracTickets for help on using tickets.