Opened 11 years ago

Closed 11 years ago

#20015 closed enhancement (fixed)

scponly 4.6 variant required to enable scp support

Reported by: dan@… Owned by: mf2k (Frank Schima)
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: variant scp compat enable lost connection Cc:
Port: scponly

Description

A new variant is required to allow scp. This is off by default as of version 4.2 and requires a configure time argument to enable it.

From the scponly website:

scponly was changed (in version 4.2) to not allow scp by default. To enable scponly run configure with the --enable-scp-compat flag, and then reinstall scponly using the "make; make install" process.

Attachments (1)

Portfile-scpCompat.diff (397 bytes) - added by dan@… 11 years ago.
scpCompat variant which enables scp support

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by dan@…

Attachment: Portfile-scpCompat.diff added

scpCompat variant which enables scp support

comment:1 Changed 11 years ago by dan@…

Added a patch to the Portfile. Never done this before so I hope I got it right.

comment:2 Changed 11 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to macsforever2000@…
Status: newassigned

comment:3 Changed 11 years ago by mf2k (Frank Schima)

Keywords: compat added; scponly cpmpat removed
Resolution: fixed
Status: assignedclosed

Committed revision r53534. Thanks!

Note: See TracTickets for help on using tickets.