Opened 12 years ago

Closed 12 years ago

#20054 closed defect (invalid)

qt4-mac 4.5.1: +universal build fails on Tiger (ppc)

Reported by: cgtobi@… Owned by: erickt@…
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: Cc: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez), clubjuggler@…, ryandesign (Ryan Schmidt), thedoobs@…
Port: qt4-mac

Description

/usr/bin/g++-4.0 -headerpad_max_install_names -arch i386 -arch ppc -Wl,-syslibroot,/Developer/SDKs/MacOSX10.4u.sdk -bundle -o libqmng_debug.bundle .obj/debug-shared/main.o .obj/debug-shared/qmnghandler.o  -F/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_qt4-mac/work/qt-mac-opensource-src-4.5.1/lib -L/opt/local/lib -L/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_qt4-mac/work/qt-mac-opensource-src-4.5.1/lib -lmng -framework QtGui -L/opt/local/lib -L/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_qt4-mac/work/qt-mac-opensource-src-4.5.1/lib -F/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_qt4-mac/work/qt-mac-opensource-src-4.5.1/lib -framework Carbon -framework AppKit -lpng -framework QtCore -lz -lm -framework ApplicationServices 
/usr/libexec/gcc/i686-apple-darwin8/4.0.1/ld: for architecture i386
/usr/libexec/gcc/i686-apple-darwin8/4.0.1/ld: warning can't open dynamic library: /Developer/SDKs/MacOSX10.4u.sdk/opt/local/lib/libjpeg.62.dylib referenced from: /opt/local/lib/libmng.dylib (checking for undefined symbols may be affected) (No such file or directory, errno = 2)
/usr/libexec/gcc/i686-apple-darwin8/4.0.1/ld: Undefined symbols:
_jpeg_CreateDecompress referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_destroy_compress referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_destroy_decompress referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_finish_decompress referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_finish_output referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_has_multiple_scans referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_input_complete referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_read_header referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_read_scanlines referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_resync_to_restart referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_start_decompress referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_start_output referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_std_error referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
collect2: ld returned 1 exit status
/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld: for architecture ppc
/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld: warning can't open dynamic library: /Developer/SDKs/MacOSX10.4u.sdk/opt/local/lib/libjpeg.62.dylib referenced from: /opt/local/lib/libmng.dylib (checking for undefined symbols may be affected) (No such file or directory, errno = 2)
/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld: warning can't open dynamic library: /Developer/SDKs/MacOSX10.4u.sdk/opt/local/lib/liblcms.1.dylib referenced from: /opt/local/lib/libmng.dylib (checking for undefined symbols may be affected) (No such file or directory, errno = 2)
/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld: Undefined symbols:
_cmsBuildGamma referenced from libmng expected to be defined in /opt/local/lib/liblcms.1.dylib
_cmsCloseProfile referenced from libmng expected to be defined in /opt/local/lib/liblcms.1.dylib
_cmsCreateRGBProfile referenced from libmng expected to be defined in /opt/local/lib/liblcms.1.dylib
_cmsCreateTransform referenced from libmng expected to be defined in /opt/local/lib/liblcms.1.dylib
_cmsDeleteTransform referenced from libmng expected to be defined in /opt/local/lib/liblcms.1.dylib
_cmsDoTransform referenced from libmng expected to be defined in /opt/local/lib/liblcms.1.dylib
_cmsErrorAction referenced from libmng expected to be defined in /opt/local/lib/liblcms.1.dylib
_cmsFreeGamma referenced from libmng expected to be defined in /opt/local/lib/liblcms.1.dylib
_cmsOpenProfileFromFile referenced from libmng expected to be defined in /opt/local/lib/liblcms.1.dylib
_cmsOpenProfileFromMem referenced from libmng expected to be defined in /opt/local/lib/liblcms.1.dylib
_cmsWhitePointFromTemp referenced from libmng expected to be defined in /opt/local/lib/liblcms.1.dylib
_jpeg_CreateDecompress referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_destroy_compress referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_destroy_decompress referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_finish_decompress referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_finish_output referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_has_multiple_scans referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_input_complete referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_read_header referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_read_scanlines referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_resync_to_restart referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_start_decompress referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_start_output referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_std_error referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
collect2: ld returned 1 exit status
lipo: can't open input file: /var/tmp//ccb22bJ1.out (No such file or directory)
make[4]: *** [../../../../plugins/imageformats/libqmng_debug.bundle] Error 1
make[3]: *** [debug-all] Error 2
make[2]: *** [sub-mng-make_default] Error 2
make[1]: *** [sub-imageformats-make_default] Error 2
make: *** [sub-plugins-make_default-ordered] Error 2
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_qt4-mac/work/qt-mac-opensource-src-4.5.1" && make first " returned error 2
Command output: _cmsCloseProfile referenced from libmng expected to be defined in /opt/local/lib/liblcms.1.dylib
_cmsCreateRGBProfile referenced from libmng expected to be defined in /opt/local/lib/liblcms.1.dylib
_cmsCreateTransform referenced from libmng expected to be defined in /opt/local/lib/liblcms.1.dylib
_cmsDeleteTransform referenced from libmng expected to be defined in /opt/local/lib/liblcms.1.dylib
_cmsDoTransform referenced from libmng expected to be defined in /opt/local/lib/liblcms.1.dylib
_cmsErrorAction referenced from libmng expected to be defined in /opt/local/lib/liblcms.1.dylib
_cmsFreeGamma referenced from libmng expected to be defined in /opt/local/lib/liblcms.1.dylib
_cmsOpenProfileFromFile referenced from libmng expected to be defined in /opt/local/lib/liblcms.1.dylib
_cmsOpenProfileFromMem referenced from libmng expected to be defined in /opt/local/lib/liblcms.1.dylib
_cmsWhitePointFromTemp referenced from libmng expected to be defined in /opt/local/lib/liblcms.1.dylib
_jpeg_CreateDecompress referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_destroy_compress referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_destroy_decompress referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_finish_decompress referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_finish_output referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_has_multiple_scans referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_input_complete referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_read_header referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_read_scanlines referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_resync_to_restart referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_start_decompress referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_start_output referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
_jpeg_std_error referenced from libmng expected to be defined in /opt/local/lib/libjpeg.62.dylib
collect2: ld returned 1 exit status
lipo: can't open input file: /var/tmp//ccb22bJ1.out (No such file or directory)
make[4]: *** [../../../../plugins/imageformats/libqmng_debug.bundle] Error 1
make[3]: *** [debug-all] Error 2
make[2]: *** [sub-mng-make_default] Error 2
make[1]: *** [sub-imageformats-make_default] Error 2
make: *** [sub-plugins-make_default-ordered] Error 2

Warning: the following items did not execute (for qt4-mac): org.macports.activate org.macports.build org.macports.destroot org.macports.install
Error: Status 1 encountered during processing.

Change History (6)

comment:1 Changed 12 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Cc: mcalhoun@… added

Cc Me!

comment:2 Changed 12 years ago by mf2k (Frank Schima)

Cc: clubjuggler@… added
Owner: changed from macports-tickets@… to erickt@…

comment:3 Changed 12 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Summary: qt4-mac-4.5.1 build fails on Tiger (ppc)qt4-mac 4.5.1: +universal build fails on Tiger (ppc)

Do you really need to build with the +universal variant? It works fine without it.

This "/Developer/SDKs/MacOSX10.4u.sdk/opt/local/lib/libjpeg.62.dylib" nonsense (a MacPorts path within an SDK path, which one only observes on Tiger) has in my experience been caused by a missing -l flag, in this case it would be a missing -ljpeg flag. Perhaps adding that to build.env would help. I have not tested yet because qt4-mac takes so long to build and I have had no interest in a universal version of it thus far.

Note the current version of qt4-mac is 4.5.2 so you should "sudo port sync" to get it.

comment:4 Changed 12 years ago by thedoobs@…

Cc: thedoobs@… added

Cc Me!

comment:5 Changed 12 years ago by mf2k (Frank Schima)

Is this still a problem with 4.5.3?

comment:6 Changed 12 years ago by mf2k (Frank Schima)

Resolution: invalid
Status: newclosed

Closing due to lack of response. Also we don't support Tiger anyway. If this is still a problem, do not build universal.

Note: See TracTickets for help on using tickets.