Opened 10 years ago

Closed 10 years ago

#20208 closed defect (fixed)

policykit fails configure during install of firefox-x11 [ was firefox, orbit2 ]

Reported by: aszy@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: firefox-x11 Cc:
Port: policykit

Description

Followed the last commands as instructed. Still fails to build / install. Last words from process were the following : ... checking for intltool >= 0.36.0... 0.35.5 found configure: error: Your intltool is too old. You need intltool 0.36.0 or later.

Error: The following dependencies failed to build: xulrunner gconf policykit heimdal libcanberra gstreamer flex gzip nspr nss xorg-libXt xorg-libsm xorg-libice Error: Status 1 encountered during processing. ... entire verbose dump attached. Al

Attachments (1)

Next Try.rtf (17.7 KB) - added by aszy@… 10 years ago.

Download all attachments as: .zip

Change History (2)

Changed 10 years ago by aszy@…

Attachment: Next Try.rtf added

comment:1 Changed 10 years ago by dbevans (David B. Evans)

Keywords: firefox-x11 added
Port: policykit added
Resolution: fixed
Status: newclosed
Summary: Failure to Install firefox-x11 [ was firefox, orbit2 ]policykit fails configure during install of firefox-x11 [ was firefox, orbit2 ]

The port failing is policykit. Current MacPorts version of intltool is 0.40.6 but policykit is missing this port as a build dependency.

Fixed in r53526. Thanks for your report.

As before wait an hour (for ports server to update) then

sudo port selfupdate
sudo port clean --work policykit
sudo port install firefox-x11
Note: See TracTickets for help on using tickets.