Opened 10 years ago

Closed 10 years ago

#20305 closed update (fixed)

py25-pyqt4 Update to 4.5.2

Reported by: mf2k (Frank Schima) Owned by: nerdling (Jeremy L)
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: Cc:
Port: py25-pyqt4 py26-pyqt4

Description

py25-pyqt4 and py26-pyqt4 need to be updated to 4.5.2

Attachments (1)

Portfile-py25-pyqt4.diff (844 bytes) - added by mf2k (Frank Schima) 10 years ago.
This attached simple patch does not compile for me.

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by mf2k (Frank Schima)

Attachment: Portfile-py25-pyqt4.diff added

This attached simple patch does not compile for me.

comment:1 Changed 10 years ago by mf2k (Frank Schima)

Here's the error I see:

--->  Building py25-pyqt4
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_svn.macports.org_trunk_dports_python_py25-pyqt4/work/PyQt-mac-gpl-4.5.2" && make all " returned error 2
Command output: ./pyrcc4 -py2 -o ../examples/draganddrop/fridgemagnets/fridgemagnets_rc.py ../examples/draganddrop/fridgemagnets/fridgemagnets.qrc
./pyrcc4 -py2 -o ../examples/draganddrop/puzzle/puzzle_rc.py ../examples/draganddrop/puzzle/puzzle.qrc
./pyrcc4 -py2 -o ../examples/graphicsview/collidingmice/mice_rc.py ../examples/graphicsview/collidingmice/mice.qrc
./pyrcc4 -py2 -o ../examples/graphicsview/diagramscene/diagramscene_rc.py ../examples/graphicsview/diagramscene/diagramscene.qrc
./pyrcc4 -py2 -o ../examples/graphicsview/dragdroprobot/dragdroprobot_rc.py ../examples/graphicsview/dragdroprobot/dragdroprobot.qrc
./pyrcc4 -py2 -o ../examples/graphicsview/padnavigator/padnavigator_rc.py ../examples/graphicsview/padnavigator/padnavigator.qrc
./pyrcc4 -py2 -o ../examples/itemviews/chart/chart_rc.py ../examples/itemviews/chart/chart.qrc
./pyrcc4 -py2 -o ../examples/itemviews/editabletreemodel/editabletreemodel_rc.py ../examples/itemviews/editabletreemodel/editabletreemodel.qrc
./pyrcc4 -py2 -o ../examples/itemviews/pixelator/pixelator_rc.py ../examples/itemviews/pixelator/pixelator.qrc
./pyrcc4 -py2 -o ../examples/itemviews/puzzle/puzzle_rc.py ../examples/itemviews/puzzle/puzzle.qrc
./pyrcc4 -py2 -o ../examples/itemviews/simpletreemodel/simpletreemodel_rc.py ../examples/itemviews/simpletreemodel/simpletreemodel.qrc
./pyrcc4 -py2 -o ../examples/mainwindows/application/application_rc.py ../examples/mainwindows/application/application.qrc
./pyrcc4 -py2 -o ../examples/mainwindows/dockwidgets/dockwidgets_rc.py ../examples/mainwindows/dockwidgets/dockwidgets.qrc
./pyrcc4 -py2 -o ../examples/mainwindows/mdi/mdi_rc.py ../examples/mainwindows/mdi/mdi.qrc
./pyrcc4 -py2 -o ../examples/mainwindows/sdi/sdi_rc.py ../examples/mainwindows/sdi/sdi.qrc
./pyrcc4 -py2 -o ../examples/network/ftp/ftp_rc.py ../examples/network/ftp/ftp.qrc
./pyrcc4 -py2 -o ../examples/opengl/textures/textures_rc.py ../examples/opengl/textures/textures.qrc
./pyrcc4 -py2 -o ../examples/painting/basicdrawing/basicdrawing_rc.py ../examples/painting/basicdrawing/basicdrawing.qrc
./pyrcc4 -py2 -o ../examples/painting/svgviewer/svgviewer_rc.py ../examples/painting/svgviewer/svgviewer.qrc
./pyrcc4 -py2 -o ../examples/tools/i18n/i18n_rc.py ../examples/tools/i18n/i18n.qrc
./pyrcc4 -py2 -o ../examples/widgets/tooltips/tooltips_rc.py ../examples/widgets/tooltips/tooltips.qrc
/usr/bin/g++-4.0 -c -pipe -Os -arch i386 -Wall -W -fPIC -DPYTHON_LIB=\"Python.framework/Versions/2.5/Python\" -DQT_NO_DEBUG -DQT_PLUGIN -DQT_SCRIPT_LIB -DQT_XML_LIB -DQT_GUI_LIB -DQT_CORE_LIB -DQDESIGNER_EXPORT_WIDGETS -DQT_SHARED -I/opt/local/libexec/qt4-mac/mkspecs/macx-g++ -I. -I/opt/local/libexec/qt4-mac/lib/QtDesigner.framework/Versions/4/Headers -I/opt/local/libexec/qt4-mac/include/QtDesigner -I/opt/local/libexec/qt4-mac/lib/QtCore.framework/Versions/4/Headers -I/opt/local/libexec/qt4-mac/include/QtCore -I/opt/local/libexec/qt4-mac/lib/QtGui.framework/Versions/4/Headers -I/opt/local/libexec/qt4-mac/include/QtGui -I/opt/local/libexec/qt4-mac/lib/QtXml.framework/Versions/4/Headers -I/opt/local/libexec/qt4-mac/include/QtXml -I/opt/local/libexec/qt4-mac/lib/QtScript.framework/Versions/4/Headers -I/opt/local/libexec/qt4-mac/include/QtScript -I/opt/local/libexec/qt4-mac/include -I/opt/local/include/python2.5 -I. -F/opt/local/libexec/qt4-mac/lib -o pluginloader.o pluginloader.cpp
/opt/local/libexec/qt4-mac/bin/moc -DPYTHON_LIB=\"Python.framework/Versions/2.5/Python\" -DQT_NO_DEBUG -DQT_PLUGIN -DQT_SCRIPT_LIB -DQT_XML_LIB -DQT_GUI_LIB -DQT_CORE_LIB -DQDESIGNER_EXPORT_WIDGETS -DQT_SHARED -I/opt/local/libexec/qt4-mac/mkspecs/macx-g++ -I. -I/opt/local/libexec/qt4-mac/lib/QtDesigner.framework/Versions/4/Headers -I/opt/local/libexec/qt4-mac/include/QtDesigner -I/opt/local/libexec/qt4-mac/lib/QtCore.framework/Versions/4/Headers -I/opt/local/libexec/qt4-mac/include/QtCore -I/opt/local/libexec/qt4-mac/lib/QtGui.framework/Versions/4/Headers -I/opt/local/libexec/qt4-mac/include/QtGui -I/opt/local/libexec/qt4-mac/lib/QtXml.framework/Versions/4/Headers -I/opt/local/libexec/qt4-mac/include/QtXml -I/opt/local/libexec/qt4-mac/lib/QtScript.framework/Versions/4/Headers -I/opt/local/libexec/qt4-mac/include/QtScript -I/opt/local/libexec/qt4-mac/include -I/opt/local/include/python2.5 -I. -F/opt/local/libexec/qt4-mac/lib -D__APPLE__ -D__GNUC__ pluginloader.h -o moc_pluginloader.cpp
/usr/bin/g++-4.0 -c -pipe -Os -arch i386 -Wall -W -fPIC -DPYTHON_LIB=\"Python.framework/Versions/2.5/Python\" -DQT_NO_DEBUG -DQT_PLUGIN -DQT_SCRIPT_LIB -DQT_XML_LIB -DQT_GUI_LIB -DQT_CORE_LIB -DQDESIGNER_EXPORT_WIDGETS -DQT_SHARED -I/opt/local/libexec/qt4-mac/mkspecs/macx-g++ -I. -I/opt/local/libexec/qt4-mac/lib/QtDesigner.framework/Versions/4/Headers -I/opt/local/libexec/qt4-mac/include/QtDesigner -I/opt/local/libexec/qt4-mac/lib/QtCore.framework/Versions/4/Headers -I/opt/local/libexec/qt4-mac/include/QtCore -I/opt/local/libexec/qt4-mac/lib/QtGui.framework/Versions/4/Headers -I/opt/local/libexec/qt4-mac/include/QtGui -I/opt/local/libexec/qt4-mac/lib/QtXml.framework/Versions/4/Headers -I/opt/local/libexec/qt4-mac/include/QtXml -I/opt/local/libexec/qt4-mac/lib/QtScript.framework/Versions/4/Headers -I/opt/local/libexec/qt4-mac/include/QtScript -I/opt/local/libexec/qt4-mac/include -I/opt/local/include/python2.5 -I. -F/opt/local/libexec/qt4-mac/lib -o moc_pluginloader.o moc_pluginloader.cpp
rm -f libpythonplugin.bundle
/usr/bin/g++-4.0 -headerpad_max_install_names -arch i386 -bundle -o libpythonplugin.bundle pluginloader.o moc_pluginloader.o  -F/opt/local/libexec/qt4-mac/lib -L/opt/local/libexec/qt4-mac/lib -framework Python -L/opt/local/libexec/qt4-mac/lib -F/opt/local/libexec/qt4-mac/lib -framework QtDesigner -framework QtScript -framework QtXml -framework QtGui -framework Carbon -framework AppKit -lpng -framework QtCore -lz -lm -framework ApplicationServices 
ld: library not found for -lpng
collect2: ld returned 1 exit status
make[1]: *** [libpythonplugin.bundle] Error 1
make: *** [all] Error 2

Error: Unable to upgrade port: 1

comment:2 Changed 10 years ago by nerdling (Jeremy L)

Owner: changed from saispo@… to snc@…
Status: newassigned

comment:3 Changed 10 years ago by nerdling (Jeremy L)

Error: Command output: Error: This version of PyQt and the Desktop edition of Qt have incompatible licenses.

I see a configure flag: --confirm-license. Should this be removed?

comment:4 Changed 10 years ago by mf2k (Frank Schima)

The -lpng error appears to be related to the changes made to the qt4-mac portfile (#20241).

comment:5 Changed 10 years ago by mf2k (Frank Schima)

Resolution: fixed
Status: assignedclosed

py25-pyqt4 committed in r54190. py26-pyqt4 is already at 4.5.2.

Note: See TracTickets for help on using tickets.