Opened 10 years ago

Closed 10 years ago

#20328 closed defect (fixed)

memtester should use ${configure.cc}

Reported by: ryandesign (Ryan Schmidt) Owned by: scott@…
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: Cc:
Port: memtester

Description

When I have the script from UsingTheRightCompiler installed, I see that memtester is not using the right compiler:

$ port install memtester
--->  Fetching memtester
--->  Attempting to fetch memtester-4.0.8.tar.gz from http://pyropus.ca/software/memtester//old-versions
--->  Verifying checksum(s) for memtester
--->  Extracting memtester
--->  Configuring memtester
--->  Building memtester
Error: Target org.macports.build returned: shell command " cd "/mp/var/macports/build/_Users_rschmidt_macports_dports_sysutils_memtester/work/memtester-4.0.8" && nice -n 10 make all " returned error 2
Command output: ( cat warn-auto.sh; \
echo CC=\'`head -1 conf-cc`\'; \
echo LD=\'`head -1 conf-ld`\' \
) > auto-ccld.sh
cat auto-ccld.sh make-compile.sh > make-compile
chmod 755 make-compile
cat auto-ccld.sh find-systype.sh > find-systype
chmod 755 find-systype
./find-systype > systype
( cat warn-auto.sh; ./make-compile "`cat systype`" ) > \
compile
chmod 755 compile
./compile memtester.c
cc -O2 -DPOSIX -c -c memtester.c
cc: Error: You should be using ${configure.cc}
See http://trac.macports.org/wiki/UsingTheRightCompiler
make: *** [memtester.o] Error 1

Error: Status 1 encountered during processing.

This is not surprising since it isn't using a configure script. The patch to fix this is attached.

Attachments (1)

memtester.diff (408 bytes) - added by ryandesign (Ryan Schmidt) 10 years ago.

Download all attachments as: .zip

Change History (2)

Changed 10 years ago by ryandesign (Ryan Schmidt)

Attachment: memtester.diff added

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

Committed in r54250 (maintainer timeout).

Note: See TracTickets for help on using tickets.