Opened 10 years ago

Closed 8 years ago

#20347 closed defect (fixed)

imapsync: Mail::IMAPClient version check is wrong and prevents use

Reported by: ryandesign (Ryan Schmidt) Owned by: mww@…
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: Cc: dyoken@…
Port: imapsync

Description

imapsync complains that it doesn't have the right version of Mail::IMAPClient, but it does.

This was reported on the mailing list by David Yoken where the example

imapsync --host1 imap.gmail.com --user1 ***@gmail.com --password1 *** --ssl1 --host2 192.168.38.10 --user2 *** --password2 *** --ssl2

was given with the result

imapsync needs perl lib Mail::IMAPClient release 2.2.9, or 3.0.19 or superior 

p5-mail-imapclient is already a dependency of imapsync and is at version 3.19 so this should be satisfactory.

The problem is in the imapsync script itself. In the check_lib_version() function it uses the $allow3xx variable to determine if imapclient version 3.x should be allowed, but the variable has not been initialized by that point. The attached patch fixes this. This should be reported upstream as well.

Attachments (1)

imapsync.diff (1.3 KB) - added by ryandesign (Ryan Schmidt) 10 years ago.

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by ryandesign (Ryan Schmidt)

Attachment: imapsync.diff added

comment:1 Changed 8 years ago by jmroot (Joshua Root)

Is this still relevant with 1.315?

comment:2 Changed 8 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

This was fixed upstream in version 1.286 released 2009-07-24. MacPorts had version 1.285 at the time this ticket was filed.

Note: See TracTickets for help on using tickets.