Opened 10 years ago

Closed 10 years ago

#20382 closed defect (fixed)

tiff: The domain/default pair of (/Developer/Applications/Xcode.app/Contents/Info, CFBundleShortVersionString) does not exist

Reported by: dmz@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: Cc: waqar@…
Port: tiff

Description

When attempting to build libtiff, I get:

Error: Target org.macports.extract returned: 2009-07-21 00:20:20.337 defaults[6278:807] 
The domain/default pair of (/Developer/Applications/Xcode.app/Contents/Info, CFBundleShortVersionString) does not exist
Warning: the following items did not execute (for tiff): org.macports.activate org.macports.extract org.macports.patch org.macports.configure org.macports.build org.macports.destroot org.macports.install
Error: Status 1 encountered during processing.

I am running a freshly installed Xcode 3.1.3, with the Developer Tools apps on another partition (/Volumes/Anlashok/Developer/Applications/Xcode.app is the path to Xcode.app), and I have verified that xcode-select returns the correct path (/Volumes/Anlashok/Developer).

Change History (7)

comment:1 Changed 10 years ago by blb@…

The problem is that some ports (like tiff here) want to check to make sure you have a recent enough Xcode install by checking the version in its plist file. It obviously fails when Xcode is not installed in /Developer.

Perhaps if these ports instead made use of xcode-select:

set current_xcodeversion [exec defaults read [exec xcode-select -print-path]/Applications/Xcode.app/Contents/Info CFBundleShortVersionString]

Though that then brings up the question of which Xcode versions have xcode-select available?

comment:2 Changed 10 years ago by tobypeterson

We really shouldn't put these kinds of checks in, users should know to have the most recent version of Xcode.

comment:3 Changed 10 years ago by jmroot (Joshua Root)

Port: tiff added

Trunk has a developer_dir setting, but 1.7 is simply not going to be fully functional with Xcode installed somewhere other than /Developer. I agree that individual ports shouldn't be doing checks like this; if anything, base should complain about known-bad Xcode versions.

comment:4 Changed 10 years ago by tobypeterson

Removed the check in r54124, filed #20389

comment:5 Changed 10 years ago by tobypeterson

Resolution: fixed
Status: newclosed

comment:6 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: waqar@… added
Resolution: fixed
Status: closedreopened
Summary: tiff port fails to build with extract errortiff: The domain/default pair of (/Developer/Applications/Xcode.app/Contents/Info, CFBundleShortVersionString) does not exist

I reverted r54124 in r54132 and opened a discussion about this on macports-dev.

Tiger does not have xcode-select, but on Tiger Xcode cannot be installed into a different location. We really need to implement a proper Xcode version check in base and thereby fix #12794. At the very least, base needs to record the current Xcode version in a variable; we could still leave it to ports to check that variable.

comment:7 Changed 10 years ago by tobypeterson

Resolution: fixed
Status: reopenedclosed

The check is inside a os.major == 9 block, so I just changed it to run xcode-select.

closing

Note: See TracTickets for help on using tickets.