Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#20417 closed defect (worksforme)

gnupg2 2.0.12_1 build failure

Reported by: kthenriksson@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: Cc:
Port: gnupg2

Description

The gnupg2 port should depend on libusb-compat (not libusb) or it will fail to build.

Change History (4)

comment:1 Changed 10 years ago by tobypeterson

Debug log, Xcode version, Mac OS X version...

brett@ explicitly set it to use libusb 1.x, see r54150 - I assume it worked for him.

comment:2 Changed 10 years ago by tobypeterson

Resolution: worksforme
Status: newclosed

Just tested this myself - it builds fine. Given that there's no actual evidence of a failure here, closing ticket.

comment:3 Changed 10 years ago by tobypeterson

Oh, I see - it's not detecting libusb. Still not a build failure - accurate problem descriptions would help. Anyway, fixed in r54266

comment:4 Changed 10 years ago by kthenriksson@…

My apologies for the terse description, this was indeed a build failure due to a missing usb.h file, which is not provided by libusb but by libusb-compat. Thanks for fixing it.

Note: See TracTickets for help on using tickets.