Opened 11 years ago

Closed 11 years ago

#20537 closed defect (fixed)

libarchive: please remove the dependency on lzmautils

Reported by: vinc17@… Owned by: tobypeterson
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: Cc:
Port: libarchive

Description

It seems that the dependency on lzmautils is not necessary (lzma support being provided by liblzma). Moreover lzmautils is more or less obsolete and this port blocks the installation of xz-devel.

Change History (4)

comment:1 Changed 11 years ago by vinc17@…

Summary: please remove the dependency on lzmautilslibarchive: please remove the dependency on lzmautils

comment:2 Changed 11 years ago by tobypeterson

As far as I can tell, liblzmadec is LZMA, liblzma is LZMA2, so it does provide additional functionality. I haven't really found a definitive answer about this though. As for file conflicts - sounds like lzmautils should be removed (if xz really does obsolete it), or else it should be modified not to conflict.

comment:3 Changed 11 years ago by vinc17@…

Doesn't liblzma support both LZMA and LZMA2? When I build the liblzma library, I get in the config.log:

configure:2485: checking which encoders to build
configure:2601: result: lzma1 lzma2 delta x86 powerpc ia64 arm armthumb sparc
configure:2605: checking which decoders to build
configure:2726: result: lzma1 lzma2 delta x86 powerpc ia64 arm armthumb sparc

comment:4 Changed 11 years ago by tobypeterson

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.