Opened 13 years ago

Closed 13 years ago

#20558 closed defect (invalid)

py26-setuptools destroot failure

Reported by: doctor@… Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: Cc:
Port: py26-setuptools

Description (last modified by skymoo (Adam Mercer))

$ sudo port -d install py26-setuptools
Password:
DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/python/py26-setuptools
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/python/py26-setuptools
DEBUG: setting option os.universal_supported to yes
DEBUG: org.macports.load registered provides 'load', a pre-existing procedure. Target override will not be provided
DEBUG: org.macports.distfiles registered provides 'distfiles', a pre-existing procedure. Target override will not be provided
DEBUG: Using group file /opt/local/var/macports/sources/rsync.macports.org/release/ports/_resources/port1.0/group/python26-1.0.tcl
DEBUG: not using configure, so not adding the default universal variant
DEBUG: Requested variant powerpc is not provided by port py26-setuptools.
DEBUG: Requested variant darwin is not provided by port py26-setuptools.
DEBUG: Requested variant macosx is not provided by port py26-setuptools.
DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/lang/python26
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/lang/python26
DEBUG: setting option os.universal_supported to yes
DEBUG: org.macports.load registered provides 'load', a pre-existing procedure. Target override will not be provided
DEBUG: org.macports.distfiles registered provides 'distfiles', a pre-existing procedure. Target override will not be provided
DEBUG: Using group file /opt/local/var/macports/sources/rsync.macports.org/release/ports/_resources/port1.0/group/select-1.0.tcl
DEBUG: universal variant already exists, so not adding the default one
DEBUG: Requested variant powerpc is not provided by port python26.
DEBUG: Requested variant macosx is not provided by port python26.
DEBUG: Executing variant darwin provides darwin
DEBUG: Searching for dependency: python26
DEBUG: Found Dependency: receipt exists for python26
DEBUG: Executing org.macports.main (py26-setuptools)
DEBUG: Skipping completed org.macports.fetch (py26-setuptools)
DEBUG: Skipping completed org.macports.checksum (py26-setuptools)
DEBUG: Skipping completed org.macports.extract (py26-setuptools)
DEBUG: Skipping completed org.macports.patch (py26-setuptools)
DEBUG: Skipping completed org.macports.configure (py26-setuptools)
DEBUG: Skipping completed org.macports.build (py26-setuptools)
--->  Staging py26-setuptools into destroot
. missing (directory not created: File exists)
./Applications missing (directory not created: File exists)
./Developer missing (directory not created: File exists)
./Library missing (directory not created: File exists)
DEBUG: Executing proc-pre-org.macports.destroot-destroot-0
DEBUG: Executing org.macports.destroot (py26-setuptools)
DEBUG: Environment: MACOSX_DEPLOYMENT_TARGET='10.4'
DEBUG: Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py26-setuptools/work/setuptools-0.6c9" && /opt/local/Library/Frameworks/Python.framework/Versions/2.6/bin/python2.6 setup.py --no-user-cfg install --prefix=/opt/local/Library/Frameworks/Python.framework/Versions/2.6 --root=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py26-setuptools/work/destroot'
/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/Pyrex/Compiler/Errors.py:17: DeprecationWarning: BaseException.message has been deprecated as of Python 2.6
  self.message = message
running install
running build
running build_py
running install_lib
running install_egg_info
running egg_info
writing setuptools.egg-info/PKG-INFO
writing top-level names to setuptools.egg-info/top_level.txt
writing dependency_links to setuptools.egg-info/dependency_links.txt
writing entry points to setuptools.egg-info/entry_points.txt
reading manifest file 'setuptools.egg-info/SOURCES.txt'
writing manifest file 'setuptools.egg-info/SOURCES.txt'
removing '/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py26-setuptools/work/destroot/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/setuptools-0.6c9-py2.6.egg-info' (and everything under it)
Copying setuptools.egg-info to /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py26-setuptools/work/destroot/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/setuptools-0.6c9-py2.6.egg-info
running install_scripts
Traceback (most recent call last):
  File "setup.py", line 94, in <module>
    scripts = scripts,
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/distutils/core.py", line 152, in setup
    dist.run_commands()
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/distutils/dist.py", line 987, in run_commands
    self.run_command(cmd)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/distutils/dist.py", line 1007, in run_command
    cmd_obj.run()
  File "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py26-setuptools/work/setuptools-0.6c9/setuptools/command/install.py", line 56, in run
    return _install.run(self)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/distutils/command/install.py", line 589, in run
    self.run_command(cmd_name)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/distutils/cmd.py", line 333, in run_command
    self.distribution.run_command(command)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/distutils/dist.py", line 1005, in run_command
    cmd_obj = self.get_command_obj(command)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/distutils/dist.py", line 881, in get_command_obj
    klass = self.get_command_class(command)
  File "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py26-setuptools/work/setuptools-0.6c9/setuptools/dist.py", line 354, in get_command_class
    self.cmdclass[command] = cmdclass = ep.load()
  File "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py26-setuptools/work/setuptools-0.6c9/pkg_resources.py", line 1913, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
  File "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py26-setuptools/work/setuptools-0.6c9/setuptools/command/install_scripts.py", line 3, in <module>
    from easy_install import get_script_args, sys_executable, chmod
  File "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py26-setuptools/work/setuptools-0.6c9/setuptools/command/easy_install.py", line 12, in <module>
    import sys, os.path, zipimport, shutil, tempfile, zipfile, re, stat, random
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/tempfile.py", line 34, in <module>
    from random import Random as _Random
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/random.py", line 873, in <module>
    _inst = Random()
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/random.py", line 96, in __init__
    self.seed(x)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/random.py", line 115, in seed
    super(Random, self).seed(a)
SystemError: error return without exception set
Error: Target org.macports.destroot returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py26-setuptools/work/setuptools-0.6c9" && /opt/local/Library/Frameworks/Python.framework/Versions/2.6/bin/python2.6 setup.py --no-user-cfg install --prefix=/opt/local/Library/Frameworks/Python.framework/Versions/2.6 --root=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py26-setuptools/work/destroot " returned error 1
Command output:     self.run_command(cmd)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/distutils/dist.py", line 1007, in run_command
    cmd_obj.run()
  File "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py26-setuptools/work/setuptools-0.6c9/setuptools/command/install.py", line 56, in run
    return _install.run(self)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/distutils/command/install.py", line 589, in run
    self.run_command(cmd_name)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/distutils/cmd.py", line 333, in run_command
    self.distribution.run_command(command)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/distutils/dist.py", line 1005, in run_command
    cmd_obj = self.get_command_obj(command)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/distutils/dist.py", line 881, in get_command_obj
    klass = self.get_command_class(command)
  File "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py26-setuptools/work/setuptools-0.6c9/setuptools/dist.py", line 354, in get_command_class
    self.cmdclass[command] = cmdclass = ep.load()
  File "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py26-setuptools/work/setuptools-0.6c9/pkg_resources.py", line 1913, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
  File "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py26-setuptools/work/setuptools-0.6c9/setuptools/command/install_scripts.py", line 3, in <module>
    from easy_install import get_script_args, sys_executable, chmod
  File "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py26-setuptools/work/setuptools-0.6c9/setuptools/command/easy_install.py", line 12, in <module>
    import sys, os.path, zipimport, shutil, tempfile, zipfile, re, stat, random
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/tempfile.py", line 34, in <module>
    from random import Random as _Random
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/random.py", line 873, in <module>
    _inst = Random()
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/random.py", line 96, in __init__
    self.seed(x)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/random.py", line 115, in seed
    super(Random, self).seed(a)
SystemError: error return without exception set

Warning: the following items did not execute (for py26-setuptools): org.macports.activate org.macports.destroot org.macports.install
Error: Status 1 encountered during processing.

Change History (4)

comment:1 Changed 13 years ago by skymoo (Adam Mercer)

Description: modified (diff)
Owner: changed from macports-tickets@… to mcalhoun@…
Port: py26-setuptools added

comment:2 Changed 13 years ago by ryandesign (Ryan Schmidt)

MacPorts, python26 and py26-setuptools have all been updated since this ticket was filed. Do you still see the problem with current versions? Please "sudo port selfupdate" and try again and let us know the result.

comment:3 Changed 13 years ago by jmroot (Joshua Root)

Summary: py26-setuptoolspy26-setuptools destroot failure

comment:4 Changed 13 years ago by jmroot (Joshua Root)

Resolution: invalid
Status: newclosed

Another user's experience indicates that this is caused by an old version of Xcode. Upgrade to a supported version.

Note: See TracTickets for help on using tickets.