Opened 11 years ago

Closed 11 years ago

#20573 closed enhancement (fixed)

py26-mapnik: remove cairo dependency

Reported by: ryandesign (Ryan Schmidt) Owned by: dbsgeo@…
Priority: Normal Milestone:
Component: ports Version: 1.7.1
Keywords: Cc:
Port: py26-mapnik

Description

Could you remove the cairo dependency from py26-mapnik? It's not necessary because the other dependencies cairomm and py26-cairo both already depend on cairo. And the way the dependency is currently declared ("port:cairo"), the port cairo-devel cannot be used to satisfy the dependency, which is a problem I would like to correct.

If you have no objection, I can commit the attached patch.

Attachments (2)

py26-mapnik.diff (505 bytes) - added by ryandesign (Ryan Schmidt) 11 years ago.
py26-mapnik-cairomm-devel.diff (575 bytes) - added by ryandesign (Ryan Schmidt) 11 years ago.

Download all attachments as: .zip

Change History (6)

Changed 11 years ago by ryandesign (Ryan Schmidt)

Attachment: py26-mapnik.diff added

comment:1 Changed 11 years ago by dbsgeo@…

Awesome, that sounds good. I've actually been excited to see those exact changes like you've just made in r55010 to allow for building against pixman/cairo/cairomm-devel. I've recently been doing that to try to track down the cause of this one: http://trac.mapnik.org/ticket/387

So, whatever patch you think wise I'm supportive.

comment:2 Changed 11 years ago by ryandesign (Ryan Schmidt)

I committed this patch in r55026. But to support using cairomm-devel we should also do this -- ok?

Changed 11 years ago by ryandesign (Ryan Schmidt)

comment:3 Changed 11 years ago by dbsgeo@…

great, looks good. I'm not a committer so go for it!

thanks!

comment:4 Changed 11 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

Done in r55031.

Note: See TracTickets for help on using tickets.