New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #20820 (closed defect: worksforme)

Opened 5 years ago

Last modified 4 years ago

py25-twisted fails to build on 10.6

Reported by: matuzalem@… Owned by: stechert@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: snowleopard Cc: akitada@…, hawkins22@…, hanysb@…, rodti@…, detone@…, fr0stman@…, brewerleece@…, snc@…
Port: py25-twisted

Description

Building py25-twisted fails with error

Attachments

hella-fail.txt (1.6 KB) - added by matuzalem@… 5 years ago.
python25-SL-fix.diff (4.9 KB) - added by agb-macports@… 5 years ago.
python25-apple-headers.diff (6.2 KB) - added by agb-macports@… 5 years ago.
Diff of Apple and Macports Python 2.5.4 headers

Change History

Changed 5 years ago by matuzalem@…

comment:1 Changed 5 years ago by macsforever2000@…

  • Cc akitada@… added
  • Summary changed from Hellanzb fails to build on 10.6 to py25-twisted fails to build on 10.6
  • Keywords snowleopard added
  • Version 1.7.1 deleted
  • Owner changed from macports-tickets@… to stechert@…
  • Port set to py25-twisted

comment:2 Changed 5 years ago by toby@…

Carbonfail.

comment:3 Changed 5 years ago by jmr@…

Probably closely related to #18449.

comment:4 Changed 5 years ago by hawkins22@…

  • Cc hawkins22@… added

Cc Me!

comment:5 Changed 5 years ago by hanysb@…

  • Cc hanysb@… added

Cc Me!

comment:6 Changed 5 years ago by rodti@…

  • Cc rodti@… added

Cc Me!

comment:7 in reply to: ↑ description Changed 5 years ago by agb-macports@…

Looks like it depends on the Quicktime 7 headers. Could someone try installing Quicktime 7 from their Snow Leopard DVD to see if that allows twisted to build properly? I'll report back once I get to the office, (my SL disc is hiding there.)

comment:8 Changed 5 years ago by matuzalem@…

I had Quicktime 7 already Installed when I was trying to build.

comment:9 Changed 5 years ago by hanysb@…

I installed Quicktime 7 from the Snow Leopard DVD as suggested and tried to build twisted but no such luck here either.

comment:10 Changed 5 years ago by detone@…

  • Cc detone@… added

Cc Me!

comment:11 Changed 5 years ago by toby@…

  • Cc fr0stman@… added

comment:12 follow-ups: ↓ 14 ↓ 17 Changed 5 years ago by macports@…

It's not Quicktime it depends on, but Qt. Personally not sure what Qt is for, but it's some linux related framework. I only use python-twisted for hellanzb, I commented the Qt imports, after which it will build.

Not a solution for people needing Qt support though.

comment:13 Changed 5 years ago by hanysb@…

Qt doesn't build via macports (see #20435 & #20937) and the installation fails when trying to install it via mpkg after downloading from official site (http://qt.nokia.com/downloads/mac-os-cpp).

comment:14 in reply to: ↑ 12 ; follow-up: ↓ 15 Changed 5 years ago by hanysb@…

Replying to macports@…:

It's not Quicktime it depends on, but Qt. Personally not sure what Qt is for, but it's some linux related framework. I only use python-twisted for hellanzb, I commented the Qt imports, after which it will build.

Not a solution for people needing Qt support though.

Where do you comment out Qt?

comment:15 in reply to: ↑ 14 ; follow-up: ↓ 16 Changed 5 years ago by macports@…

Replying to hanysb@…:

Replying to macports@…:

It's not Quicktime it depends on, but Qt. Personally not sure what Qt is for, but it's some linux related framework. I only use python-twisted for hellanzb, I commented the Qt imports, after which it will build.

Not a solution for people needing Qt support though.

Where do you comment out Qt?

The Qt imports are in /opt/local/include/python2.5/pymactoolbox.h line 137 to 148

comment:16 in reply to: ↑ 15 Changed 5 years ago by r.ligteringen@…

Replying to macports@…:

Replying to hanysb@…:

Replying to macports@…:

It's not Quicktime it depends on, but Qt. Personally not sure what Qt is for, but it's some linux related framework. I only use python-twisted for hellanzb, I commented the Qt imports, after which it will build.

Not a solution for people needing Qt support though.

Where do you comment out Qt?

The Qt imports are in /opt/local/include/python2.5/pymactoolbox.h line 137 to 148

Tried compiling with Qt lines marked out -> no succeed.

comment:17 in reply to: ↑ 12 ; follow-up: ↓ 18 Changed 5 years ago by agb-macports@…

Replying to macports@…:

It's not Quicktime it depends on, but Qt. Personally not sure what Qt is for, but it's some linux related framework. I only use python-twisted for hellanzb, I commented the Qt imports, after which it will build.

Not a solution for people needing Qt support though.

In this case Qt is simply an acryonym for Quicktime, you'll see other references in there, Qd == Quickdraw (another Apple technology)

As far as I can see the problem is due to the fact that the Quicktime API will not be ported to 64bit, period. Apple has worked around this in their own python versions by encasing all non-64bit related foo in #ifndef LP64

I'll upload a patch to the port that makes it build for me, along with a full diff of the macports python 2.5 headers against the apple python 2.5 headers.

python25 revision is arbitrarily set to 6.1 to minimize conflict between my local overlay the official ports.

Changed 5 years ago by agb-macports@…

Changed 5 years ago by agb-macports@…

Diff of Apple and Macports Python 2.5.4 headers

comment:18 in reply to: ↑ 17 ; follow-up: ↓ 21 Changed 5 years ago by ryandesign@…

Replying to agb-macports@…:

python25 revision is arbitrarily set to 6.1 to minimize conflict between my local overlay the official ports.

The revision field must be an integer.

comment:19 Changed 5 years ago by brewerleece@…

  • Cc brewerleece@… added

Cc Me!

comment:20 Changed 5 years ago by procopio@…

Commenting the lines on "/opt/local/include/python2.5/pymactoolbox.h line 137 to 148" solved my hellanzb build issues.

comment:21 in reply to: ↑ 18 Changed 5 years ago by agb-macports@…

Replying to ryandesign@…:

Replying to agb-macports@…:

python25 revision is arbitrarily set to 6.1 to minimize conflict between my local overlay the official ports.

The revision field must be an integer.

I never intended to indicate my revision solution was correct, it was something I did quickly to prevent conflict and it didn't appear to break anything.

$ port installed python25
The following ports are currently installed:
  python25 @2.5.4_6+darwin_10+macosx
  python25 @2.5.4_6.1+darwin_10+macosx (active)

I expected that the maintainer would properly bump the package to revision 7 when committing to svn. Sorry for any confusion.

comment:22 Changed 5 years ago by blb@…

I'm not sure how well this may ever work, but can everyone use py26-twisted instead, it seems to build just fine on 10.6? Any ports which are blocked due to depending on py25-twisted should have new tickets for them requesting a move to python 2.6.

comment:23 Changed 4 years ago by mail08@…

You can wait for Developer or use this Workaround:

Switch back to Leopard and compile Hellanzb via Mac Port.

Save the opt Folder! Install Snow Leopard and copy the opt folder into root.

Set the Path in .profile like # MacPorts Installer addition on 2009-08-09_at_18:42:58: adding an appropriate PATH variable for use with MacPorts. export PATH=/opt/local/bin:/opt/local/sbin:$PATH # Finished adapting your PATH environment variable for use with MacPorts.

# MacPorts Installer addition on 2009-08-09_at_18:42:58: adding an appropriate MANPATH variable for use with MacPorts. export MANPATH=/opt/local/share/man:$MANPATH # Finished adapting your MANPATH environment variable for use with MacPorts.

You are done !

comment:24 Changed 4 years ago by matuzalem@…

You could also say, I ain't waiting for no one and take matters into your hands: macosxhints

I built and installed hella & dependencies against the SL build of python2.5

Also you could just go meh, and use : .sabnzbd instead

hellanzb is no longer under development, So you could be waiting for an infinite loop.

comment:25 Changed 4 years ago by snc@…

  • Cc snc@… added

Cc Me!

comment:26 Changed 4 years ago by akitada@…

  • Status changed from new to closed
  • Resolution set to worksforme

looks like the problem has gone and now it just works.

Note: See TracTickets for help on using tickets.