Opened 11 years ago

Closed 10 years ago

#20924 closed defect (fixed)

OS X 10.6 with +no_x11 +quartz: Pango-WARNING **: shaping failure, expect ugly output

Reported by: macports@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 1.8.0
Keywords: 10.6 snowleopard Cc: tim.stoop@…, icemac (Michael Howitz), macports@…, thimo@…, dominique.marie@…, email@…, royliu@…, MacPorts@…, unavowed@…, farcaller@…, yacoob@…, zimmermann@…, johnrosshunt@…, jvliwanag@…, mamoll (Mark Moll), jemaltz@…, mike@…, dbevans (David B. Evans), macports.org@…, michaelld (Michael Dickens), joe@…
Port: pango

Description

$ gtk-demo 

(gtk-demo:90990): Pango-WARNING **: shaping failure, expect ugly output. shape-engine='BasicEngineFc', font='Lucida Grande Medium 12', text='Application main window'

(gtk-demo:90990): Pango-WARNING **: shaping failure, expect ugly output. shape-engine='BasicEngineFc', font='Bitstream Vera Sans 18', text='Application main window'

The result is demo1.png. The same goes for pidgin (that I was trying to build). To rule out a mixture of -no_x11 and +no_x11 ports I created a fresh macports install with a variants.conf containing:

+universal +no_x11 +quartz

(+universal is needed because of #20284)

Note that pango-view cannot be used for testing because ImageMagick is built without X11 support in this scenario.

Attachments (4)

demo1.png (28.8 KB) - added by macports@… 11 years ago.
demo1.png
pango-update-to-1.28.1.patch (5.2 KB) - added by mike@… 10 years ago.
Patch pango port to build 1.28.1; fixes ticket #20924
patch-pango-1.28.1-introspection.diff (5.4 KB) - added by dbevans (David B. Evans) 10 years ago.
Upgrade to 2.28.1 including +introspection variant
patch-pango-1.28.1-introspection-revised.diff (3.0 KB) - added by dbevans (David B. Evans) 10 years ago.
Revised patch file

Download all attachments as: .zip

Change History (60)

Changed 11 years ago by macports@…

Attachment: demo1.png added

demo1.png

comment:1 Changed 11 years ago by jmroot (Joshua Root)

Keywords: snowleopard added
Owner: changed from macports-tickets@… to ryandesign@…

This may be the same as or closely related to #17049.

comment:2 Changed 11 years ago by macports@…

It might be. I don't understand all the technical lingo in that bug. The version I have installed is:

$ sudo port installed pango
The following ports are currently installed:
  pango @1.24.5_0+macosx+no_x11+quartz+universal (active)

comment:3 Changed 11 years ago by tim.stoop@…

I've tried the latest Pango as mentioned in #17049, but now I'm not even getting a demo screen anymore. I've rebuild gtk2 after installing the newer Pango (from the Portfile by vitaly@).

comment:4 Changed 11 years ago by tim.stoop@…

Cc: tim.stoop@… added

Cc Me!

comment:5 Changed 11 years ago by macports@…

This bug still occurs with the latest ports without the +universal:

$ port installed | egrep 'pango|cairo|gtk2'
  cairo @1.8.8_0+macosx+no_x11+quartz (active)
  gtk2 @2.18.2_0+no_x11+quartz (active)
  pango @1.24.5_0+macosx+no_x11+quartz (active)

comment:6 Changed 11 years ago by icemac (Michael Howitz)

Cc: mh@… added

Cc Me!

comment:7 Changed 11 years ago by macports@…

Cc: macports@… added

Cc Me!

comment:8 Changed 11 years ago by thimo@…

Cc: thimo@… added

Cc Me!

comment:9 Changed 11 years ago by dominique.marie@…

Cc: dominique.marie@… added

Cc Me!

comment:10 Changed 11 years ago by email@…

Cc: email@… added

Cc Me!

comment:11 Changed 11 years ago by royliu@…

Cc: royliu@… added

Cc Me!

comment:12 Changed 11 years ago by michael@…

Cc: michael@… added

Cc Me!

comment:13 Changed 11 years ago by MacPorts@…

Cc: MacPorts@… added

Cc Me!

comment:14 Changed 11 years ago by unavowed@…

Cc: unavowed@… added

Cc Me!

comment:15 Changed 11 years ago by farcaller@…

Cc: farcaller@… added

Cc Me!

comment:16 Changed 11 years ago by ryandesign (Ryan Schmidt)

Has duplicate #23028.

I don't really know what to do about this problem. I don't use pango's quartz or no_x11 variants, nor gtk2. I suggest you test whether pango 1.26.x would fix this problem. The reason pango has not been updated to this version is explained in #21624. If pango 1.26.x fixes the problem, test if the issue described in #21624 still exists; if so, encourage the developers of pango to fix it. If 1.26.x does not fix the shaping failure, report that problem to the developers of pango.

comment:17 Changed 11 years ago by yacoob@…

Cc: yacoob@… added

Cc Me!

comment:18 Changed 11 years ago by yacoob@…

Just to clarify here: pango version 1.26.2 doesn't fix the problem, shaping failures still are present.

comment:19 Changed 11 years ago by zimmermann@…

Cc: zimmermann@… added

Cc Me!

comment:20 Changed 11 years ago by johnrosshunt@…

Cc: johnrosshunt@… added

Cc Me!

comment:21 Changed 11 years ago by attila.tajti@…

Cc: attila.tajti@… added

Cc Me!

comment:22 in reply to:  description ; Changed 11 years ago by nolith@…

This Portfile worked for me: http://trac.macports.org/attachment/ticket/17049/Portfile

$ port installed | egrep 'cairo|pango|gtk2'
  cairo @1.8.8_0+macosx+no_x11+quartz (active)
  gtk2 @2.18.6_0+no_x11+quartz (active)
  pango @1.24.5_0+macosx+no_x11+quartz
  pango @1.26.0_0+macosx+no_x11+quartz (active)
  py26-cairo @1.8.8_0 (active)

comment:23 Changed 11 years ago by farcaller@…

I second this, given Portfile works ok here.

comment:24 Changed 11 years ago by johnrosshunt@…

I'll third it. The Portfile works for me as well.

comment:25 Changed 11 years ago by ryandesign (Ryan Schmidt)

Cc: nolith@… added

And are the three of you claiming that using that pango 1.26.0 portfile, you do not experience the slowdowns reported in #21624 (which is the reason why we have not updated to 1.26.x so far)?

comment:26 Changed 11 years ago by farcaller@…

Yes, cannot reproduce that any more ant that's pretty strange. However gtk-demo and wireshark work ok and I have no signs of #21624.

comment:27 Changed 11 years ago by johnrosshunt@…

I haven't noticed the problems from #21624 but I've noticed two other bugs. Menu shortcut labels (e.g. Ctrl+S, Alt+Q, etc.) are distorted and right clicks aren't working. I have no idea if this is GTK or Pango related, or both.

comment:28 Changed 11 years ago by tim.stoop@…

I can confirm this works for me too, without any slowdowns. I do not however use liferea or rrdtool, I use gtimelog. Shortcuts work for me too, as does right clicking.

comment:29 Changed 11 years ago by attila.tajti@…

Cc: attila.tajti@… removed

Cc Me!

comment:30 Changed 11 years ago by jvliwanag@…

Cc: jvliwanag@… added

Cc Me!

comment:31 Changed 11 years ago by mamoll (Mark Moll)

Cc: mmoll@… added

Cc Me!

comment:32 Changed 11 years ago by jemaltz@…

Cc: jemaltz@… added

Cc Me!

comment:33 in reply to:  22 Changed 11 years ago by philip.chimento@…

Replying to nolith@…:

This Portfile worked for me: http://trac.macports.org/attachment/ticket/17049/Portfile

That portfile didn't work for me, I got

Error: Unable to open port: Error evaluating variants

comment:34 Changed 11 years ago by jmroot (Joshua Root)

Someone was saying on IRC that pango 1.28 seems to be OK.

comment:35 Changed 11 years ago by thmx.2k7@…

pango-devel @1.27.1_0 works fine for me

comment:36 Changed 10 years ago by mike@…

I had to modify the Portfile at http://trac.macports.org/attachment/ticket/17049/Portfile to support the "macosx" variant. Once I did that, I was able to build pango 1.26.0 on Snow Leopard (10.6.4) and GTK2/Quartz applications displayed fonts properly. This is an important bug fix. Is there something holding up the new pango package?

comment:37 in reply to:  36 Changed 10 years ago by ryandesign (Ryan Schmidt)

Replying to mike@…:

Is there something holding up the new pango package?

Mostly just apathy. If someone will provide a patch that will update the pango port to the latest version and incorporate any relevant changes from the pango-devel port I'll probably commit it.

comment:38 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: mike@… added

Mike, see my comment above.

Changed 10 years ago by mike@…

Patch pango port to build 1.28.1; fixes ticket #20924

comment:39 Changed 10 years ago by dbevans (David B. Evans)

Cc: devans@… added

I'd like to add support for this update request for the following reasons:

  • pango 1.28.1 is the current version distributed with the GNOME 2.30.2 release
  • current version of pango (1.24.5) does not support GObject introspection while 1.28.1 does. This is a gating item for enabling introspection in gtk2 and its dependents

To this end, in the attached patch file I have added to mike's contributions the following:

  • disable introspection by default to avoid autoconfiguration if port gobject-introspection is installed
  • add +introspection variant to enable introspection

This builds for me on SL x86_64 and Leopard ppc non-universal with and without the +introspection variant and builds universal in all cases except +introspection where it fails in the introspection process -- hence the variant approach. Perhaps some one else can figure out how to fix this one case.

Changed 10 years ago by dbevans (David B. Evans)

Upgrade to 2.28.1 including +introspection variant

comment:40 Changed 10 years ago by macports.org@…

Cc: macports.org@… added

Cc Me!

comment:41 Changed 10 years ago by dbevans (David B. Evans)

I've just confirmed that gimp2 @2.6.10_3+no_x11+quartz using pango @1.24.5_0+no_x11+quartz shows the same problem, that is, gimp2 emits the following warnings

gimp:18410): Pango-WARNING **: shaping failure, expect ugly output. shape-engine='BasicEngineFc', font='Lucida Grande Medium 9.9990234375', text='Plug-In Interpreters'

(gimp:18410): Pango-WARNING **: shaping failure, expect ugly output. shape-engine='BasicEngineFc', font='Lucida Grande Medium 12', text='Looking for data files'

and characters in the startup screen and other windows display as open boxes only (ugly).

Upgrading to 1.28.1 fixes the problem.

Mac OS 10.6.4 x86_64

comment:42 Changed 10 years ago by michaelld (Michael Dickens)

Cc: michaelld@… added

Cc Me!

comment:43 Changed 10 years ago by raimue (Rainer Müller)

Do not delete the epoch option from the Portfile. This setting should never be removed anymore after it has been added.

comment:44 Changed 10 years ago by nolith@…

Cc: nolith@… removed

Cc Me!

comment:45 Changed 10 years ago by joe@…

Cc: joe@… added

Cc Me!

comment:46 Changed 10 years ago by macports@…

I can confirm that upgrading to 1.28.1 using the patch from devans solves this issue. Thanks! What needs to be done for this to be added to the central repository?

comment:47 Changed 10 years ago by dbevans (David B. Evans)

Here's an update to the latest patch that removes some -devel-isms (e.g. my_name) and removes the +introspection variant for now since it breaks the universal build.

Changed 10 years ago by dbevans (David B. Evans)

Revised patch file

comment:48 Changed 10 years ago by johnrosshunt@…

I can confirm that the patch-pango-1.28.1-introspection-revised.diff patch works for me as well.

comment:49 Changed 10 years ago by dbevans (David B. Evans)

Patch to upgrade to latest pango 1.28.3 attached to #26697.

comment:50 Changed 10 years ago by macports@…

Thanks for the update. What needs to be done for this to be added to the central repository?

comment:51 Changed 10 years ago by dbevans (David B. Evans)

Maintainer needs to review and push to svn.

comment:52 Changed 10 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: newclosed

r72474 (maintainer timeout)

comment:53 Changed 10 years ago by maltee@…

Resolution: fixed
Status: closedreopened

The problem still exists with pango 1.28.4 gtk-quartz is unusable.

comment:54 in reply to:  53 Changed 10 years ago by maltee@…

Replying to maltee@…:

The problem still exists with pango 1.28.4 gtk-quartz is unusable.

This was not my problem. My problem was, that pango was not automatically installed with +quartz (or not reinstalled after cairo was installed with +quartz). Please close this bug again, sorry for false alarm!

comment:55 Changed 10 years ago by michael@…

Cc: michael@… removed

Cc Me!

comment:56 Changed 10 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.