Opened 12 years ago

Closed 11 years ago

#20997 closed defect (duplicate)

gtk+-2.16.6 build fails with "gtk-update-icon-cache: The generated cache was invalid."

Reported by: andersm (Anders Montonen) Owned by: nox@…
Priority: Normal Milestone:
Component: ports Version: 1.8.0
Keywords: Cc: de5ton56@…, aigeruth@…, mklein-de (Michael Klein), michael-macports@…, ryandesign (Ryan Schmidt)
Port: gtk2

Description

Building gtk+-2.16.5 under OS X 10.5.8 PPC fails with the error "gtk-update-icon-cache: The generated cache was invalid."

Full build log:

--->  Computing dependencies for gtk2
--->  Fetching gtk2
--->  Attempting to fetch gtk+-2.16.5.tar.bz2 from http://ftp.acc.umu.se/pub/GNOME/sources/gtk+/2.16/
--->  Verifying checksum(s) for gtk2
--->  Extracting gtk2
--->  Applying patches to gtk2
--->  Configuring gtk2
--->  Building gtk2
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_gtk2/work/gtk+-2.16.5" && /usr/bin/make -j2 all " returned error 2
Command output: 	   && rm -f text-x-generic.png				\
	   && ln -s gtk-file.png text-x-generic.png			\
	) done								\
	&& touch stamp-icons
echo "#ifndef GTK_DISABLE_DEPRECATED" > xgen-gmh				\
        && glib-genmarshal --prefix=gtk_marshal ./gtkmarshal.list --header >> xgen-gmh \
	&& echo "#endif /* GTK_DISABLE_DEPRECATED */" >> xgen-gmh \
	&& (cmp -s xgen-gmh gtkmarshal.h || cp xgen-gmh gtkmarshal.h) \
	&& rm -f xgen-gmh \
	&& echo timestamp > stamp-gtkmarshal.h
( cd . && glib-mkenums --template gtktypebuiltins.h.template \
		gtk.h gtkaboutdialog.h gtkaccelgroup.h gtkaccellabel.h gtkaccelmap.h gtkaccessible.h gtkaction.h gtkactiongroup.h gtkactivatable.h gtkadjustment.h gtkalignment.h gtkarrow.h gtkaspectframe.h gtkassistant.h gtkbbox.h gtkbin.h gtkbindings.h gtkbox.h gtkbuilder.h gtkbuildable.h gtkbutton.h gtkcalendar.h gtkcelleditable.h gtkcelllayout.h gtkcellrenderer.h gtkcellrendereraccel.h gtkcellrenderercombo.h gtkcellrendererpixbuf.h gtkcellrendererprogress.h gtkcellrendererspin.h gtkcellrenderertext.h gtkcellrenderertoggle.h gtkcellview.h gtkcheckbutton.h gtkcheckmenuitem.h gtkclipboard.h gtkcolorbutton.h gtkcolorsel.h gtkcolorseldialog.h gtkcombobox.h gtkcomboboxentry.h gtkcontainer.h gtkcurve.h gtkdebug.h gtkdialog.h gtkdnd.h gtkdrawingarea.h gtkeditable.h gtkentry.h gtkentrycompletion.h gtkenums.h gtkeventbox.h gtkexpander.h gtkfilechooser.h gtkfilechooserbutton.h gtkfilechooserdialog.h gtkfilechooserwidget.h gtkfilefilter.h gtkfixed.h gtkfontbutton.h gtkfontsel.h gtkframe.h gtkgamma.h gtkgc.h gtkhandlebox.h gtkhbbox.h gtkhbox.h gtkhpaned.h gtkhruler.h gtkhscale.h gtkhscrollbar.h gtkhseparator.h gtkhsv.h gtkiconfactory.h gtkicontheme.h gtkiconview.h gtkimage.h gtkimagemenuitem.h gtkimcontext.h gtkimcontextsimple.h gtkimmodule.h gtkimmulticontext.h gtkinputdialog.h gtkinvisible.h gtkitem.h gtklabel.h gtklayout.h gtklinkbutton.h gtkliststore.h gtkmain.h gtkmenu.h gtkmenubar.h gtkmenuitem.h gtkmenushell.h gtkmenutoolbutton.h gtkmessagedialog.h gtkmisc.h gtkmodules.h gtkmountoperation.h gtknotebook.h gtkobject.h gtkorientable.h gtkpagesetup.h gtkpaned.h gtkpapersize.h gtkplug.h gtkprintcontext.h gtkprintoperation.h gtkprintoperationpreview.h gtkprintsettings.h gtkprivate.h gtkprogressbar.h gtkradioaction.h gtkradiobutton.h gtkradiomenuitem.h gtkradiotoolbutton.h gtkrange.h gtkrc.h gtkrecentaction.h gtkrecentchooser.h gtkrecentchooserdialog.h gtkrecentchoosermenu.h gtkrecentchooserwidget.h gtkrecentfilter.h gtkrecentmanager.h gtkruler.h gtkscale.h gtkscalebutton.h gtkscrollbar.h gtkscrolledwindow.h gtkselection.h gtkseparator.h gtkseparatormenuitem.h gtkseparatortoolitem.h gtkshow.h gtksettings.h gtksizegroup.h gtksocket.h gtkspinbutton.h gtkstatusbar.h gtkstatusicon.h gtkstock.h gtkstyle.h gtktable.h gtktearoffmenuitem.h gtktestutils.h gtktextbuffer.h gtktextbufferrichtext.h gtktextchild.h gtktextdisplay.h gtktextiter.h gtktextmark.h gtktexttag.h gtktexttagtable.h gtktextview.h gtktoggleaction.h gtktogglebutton.h gtktoggletoolbutton.h gtktoolbar.h gtktoolbutton.h gtktoolitem.h gtktoolshell.h gtktooltip.h gtktreednd.h gtktreemodel.h gtktreemodelfilter.h gtktreemodelsort.h gtktreeselection.h gtktreesortable.h gtktreestore.h gtktreeview.h gtktreeviewcolumn.h gtktypeutils.h gtkuimanager.h gtkvbbox.h gtkvbox.h gtkviewport.h gtkvolumebutton.h gtkvpaned.h gtkvruler.h gtkvscale.h gtkvscrollbar.h gtkvseparator.h gtkwidget.h gtkwindow.h gtktext.h gtktree.h gtktreeitem.h gtkclist.h gtkcombo.h gtkctree.h gtkfilesel.h gtkitemfactory.h gtklist.h gtklistitem.h gtkoldeditable.h gtkoptionmenu.h gtkpixmap.h gtkpreview.h gtkprogress.h gtksignal.h gtktipsquery.h gtktooltips.h ) >> xgen-gtbh \
	&& (cmp -s xgen-gtbh gtktypebuiltins.h || cp xgen-gtbh gtktypebuiltins.h ) \
	&& rm -f xgen-gtbh \
	&& echo timestamp > stamp-gtktypebuiltins.h
/usr/bin/make  gtk-update-icon-cache
if /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I. -I.. -DG_LOG_DOMAIN=\"Gtk\" -DGTK_LIBDIR=\"/opt/local/lib\" -DGTK_DATADIR=\"/opt/local/share\" -DGTK_DATA_PREFIX=\"/opt/local\" -DGTK_SYSCONFDIR=\"/opt/local/etc\" -DGTK_VERSION=\"2.16.5\" -DGTK_BINARY_VERSION=\"2.10.0\" -DGTK_HOST=\"powerpc-apple-darwin9.8.0\" -DGTK_COMPILATION -DGTK_PRINT_BACKENDS=\"file,cups\" -DGTK_PRINT_PREVIEW_COMMAND=\""evince --unlink-tempfile --preview --print-settings %s %f"\" -I.. -I../gtk -I.. -I../gdk -I../gdk -I../gdk-pixbuf -I../gdk-pixbuf -DGDK_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED -DGTK_FILE_SYSTEM_ENABLE_UNSUPPORTED -DGTK_PRINT_BACKEND_ENABLE_UNSUPPORTED -DG_DISABLE_CAST_CHECKS -D_REENTRANT -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include -I/opt/local/include/pango-1.0 -I/opt/local/include/cairo -I/opt/local/include/pixman-1 -I/opt/local/include/freetype2 -I/opt/local/include/libpng12 -I/opt/local/include/atk-1.0         -I/opt/local/include -DX_LOCALE -DG_DISABLE_SINGLE_INCLUDES -DATK_DISABLE_SINGLE_INCLUDES -DGDK_PIXBUF_DISABLE_SINGLE_INCLUDES -DGTK_DISABLE_SINGLE_INCLUDES -I/opt/local/include    -DGDK_PIXBUF_DISABLE_DEPRECATED -O2 -fstrict-aliasing -arch ppc -Wall -MT updateiconcache.o -MD -MP -MF ".deps/updateiconcache.Tpo" \
	  -c -o updateiconcache.o `test -f 'updateiconcache.c' || echo './'`updateiconcache.c; \
	then mv -f ".deps/updateiconcache.Tpo" ".deps/updateiconcache.Po"; \
	else rm -f ".deps/updateiconcache.Tpo"; exit 1; \
	fi
/bin/sh ../libtool --mode=link /usr/bin/gcc-4.0  -DGDK_PIXBUF_DISABLE_DEPRECATED -O2 -fstrict-aliasing -arch ppc -Wall  -L/opt/local/lib -o gtk-update-icon-cache  updateiconcache.o ../gdk-pixbuf/libgdk_pixbuf-2.0.la 
libtool: link: /usr/bin/gcc-4.0 -DGDK_PIXBUF_DISABLE_DEPRECATED -O2 -fstrict-aliasing -arch ppc -Wall -o .libs/gtk-update-icon-cache updateiconcache.o  -L/opt/local/lib ../gdk-pixbuf/.libs/libgdk_pixbuf-2.0.dylib /opt/local/lib/libgio-2.0.dylib /opt/local/lib/libgobject-2.0.dylib /opt/local/lib/libgmodule-2.0.dylib /opt/local/lib/libglib-2.0.dylib /opt/local/lib/libintl.dylib -lc /opt/local/lib/libiconv.dylib -lm -framework Carbon
GDK_PIXBUF_MODULE_FILE=../gdk-pixbuf/gdk-pixbuf.loaders ./gtk-update-icon-cache --force --ignore-theme-index		\
	   --source builtin_icons stock-icons > gtkbuiltincache.h.tmp &&        \
	mv gtkbuiltincache.h.tmp gtkbuiltincache.h
gtk-update-icon-cache: The generated cache was invalid.
make[2]: *** [gtkbuiltincache.h] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Attachments (1)

gtk2 2.16.6 debug build fail.txt (516.0 KB) - added by naturaltwig@… 12 years ago.

Download all attachments as: .zip

Change History (22)

comment:1 Changed 12 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to nox@…
Port: gtk2 added

comment:2 Changed 12 years ago by nox@…

Does it still fail with gtk2 2.16.6?

comment:3 in reply to:  2 Changed 12 years ago by aigeruth@…

Replying to nox@…:

Does it still fail with gtk2 2.16.6?

Yes.

Changed 12 years ago by naturaltwig@…

comment:4 Changed 12 years ago by nerdling (Jeremy Lavergne)

Summary: gtk+-2.16.5 build fails with "gtk-update-icon-cache: The generated cache was invalid."gtk+-2.16.6 build fails with "gtk-update-icon-cache: The generated cache was invalid."

comment:5 Changed 12 years ago by de5ton56@…

Cc: de5ton56@… added

Cc Me!

comment:6 Changed 12 years ago by aigeruth@…

Cc: aigeruth@… added

Cc Me!

comment:7 Changed 12 years ago by mklein-de (Michael Klein)

Same here, turns out that glib2's configure script thinks I'm building a universal binary because it sees "-arch=ppc" in $CFLAGS or something like that.

Workaround: set build_arch to an empty string in macports.conf and rebuild glib2. This keeps the port environment from adding -arch=ppc to $CFLAGS

$ grep build_arch /opt/local/etc/macports/macports.conf
#build_arch			i386
build_arch

comment:8 Changed 12 years ago by mklein-de (Michael Klein)

Cc: michael.klein@… added

Cc Me!

comment:9 Changed 12 years ago by naturaltwig@…

i'm running a ppc os x 10.5.8 mac. build_arch was not originally listed in my macports.conf file, and setting it to an empty string didn't cause gtk2 to build. i also temporarily renamed macports.conf.default incase that file is also used, but it still didn't work.

comment:10 Changed 12 years ago by de5ton56@…

Thanks.

It works on my ppc os x 10.5.8 mac.

btw, should i delete the amended line in macports.conf file or just leave it there?

Appreciate it!

Thanks Deston

comment:11 in reply to:  9 ; Changed 12 years ago by mklein-de (Michael Klein)

Replying to naturaltwig@…:

i'm running a ppc os x 10.5.8 mac. build_arch was not originally listed in my macports.conf file, and setting it to an empty string didn't cause gtk2 to build.

Did you rebuild glib2 after changing macports.conf?

What's the output of grep G_BYTE_ORDER /opt/local/lib/glib-2.0/include/glibconfig.h? If must be G_BIG_ENDIAN on PPC.

comment:12 in reply to:  10 Changed 12 years ago by mklein-de (Michael Klein)

btw, should i delete the amended line in macports.conf file or just leave it there?

Should not make a big difference IMHO. It should not harm other ports, but it's somewhat undocumented behaviour, I guess.

If you're in doubt, you might also rebuild any other ports that depend on glib2 (e.g. atk, pango). Don't know if any of these use G_BYTE_ORDER from glibconfig.h.

comment:13 Changed 12 years ago by nox@…

So there is nothing wrong with the gtk2 Portfile itself?

comment:14 in reply to:  13 Changed 12 years ago by mklein-de (Michael Klein)

Replying to nox@…:

So there is nothing wrong with the gtk2 Portfile itself?

correct.

comment:15 Changed 12 years ago by nox@…

Resolution: worksforme
Status: newclosed

comment:16 in reply to:  11 Changed 12 years ago by naturaltwig@…

Replying to michael.klein@…:

Did you rebuild glib2 after changing macports.conf?

What's the output of grep G_BYTE_ORDER /opt/local/lib/glib-2.0/include/glibconfig.h? If must be G_BIG_ENDIAN on PPC.

rebuilt glib2 and now it works.

the output of that line was originally: #define G_BYTE_ORDER G_LITTLE_ENDIAN and now after rebuilding it's: #define G_BYTE_ORDER G_BIG_ENDIAN

thanks.

comment:17 Changed 11 years ago by michael-macports@…

Cc: michael-macports@… added

Cc Me!

comment:18 Changed 11 years ago by jmroot (Joshua Root)

Worksforme? Seems more like a dupe of #20372.

comment:19 in reply to:  18 Changed 11 years ago by LantzR@…

While I agree that the problem seems to be #20372 this workaround worked for me.

I'm on running OsX 10.4.11 on PPC. I have kept the default for universal builds.

Note that both glib2 and gtk2 were built and working last month, something changed somewhere.

I had rebuilt glib2 on Sept 12th, then failed as described here a two days later

grep G_BYTE_ORDER /opt/local/lib/glib-2.0/include/glibconfig.h 
#define G_BYTE_ORDER G_LITTLE_ENDIAN

michael.klein@… wrote:

Workaround: set build_arch to an empty string in macports.conf and rebuild glib2. This keeps the port environment from adding -arch=ppc to $CFLAGS

$ grep build_arch /opt/local/etc/macports/macports.conf
#build_arch			i386
build_arch

For me the undocumented build_arch did not exist in macports.conf so I just added the empty one.

Uninstalled glib2 and it's dependents, installed glib2 then gtk2.

Looking good.

Thanks

comment:20 Changed 11 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Resolution: worksforme
Status: closedreopened

comment:21 Changed 11 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: reopenedclosed
Note: See TracTickets for help on using tickets.