Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#21036 closed defect (fixed)

htop 0.8.3_0 malloc error in 64-bit

Reported by: insyte@… Owned by: nerdling (Jeremy L)
Priority: Normal Milestone:
Component: ports Version: 1.8.0
Keywords: LP64 Cc:
Port: htop

Description

I just updgraded a clean 10.5 install (no ports) to 10.6. Installed Mac Ports and installed htop. Build appeared to go fine but the executable immediately exits on startup with this error:

$ htop
htop(31269) malloc: *** error for object 0x100cf0: pointer being freed was not allocated
*** set a breakpoint in malloc_error_break to debug
Abort trap

Change History (4)

comment:1 Changed 10 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to snc@…

comment:2 Changed 10 years ago by tobypeterson

Probably upstream issue - but if it's 100% reproducible it shouldn't be hard to track down.

comment:3 Changed 10 years ago by tobypeterson

Resolution: fixed
Status: newclosed

Wasn't getting the prototype for strdup, causes issues on 64-bit. Problem caused because "String.h" was hiding <string.h> on case-insensitive filesystem.

r56880

comment:4 Changed 10 years ago by tobypeterson

Keywords: LP64 added
Summary: htop 0.8.3_0 malloc error on Snow Leopardhtop 0.8.3_0 malloc error in 64-bit
Note: See TracTickets for help on using tickets.