Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#21062 closed defect (invalid)

Snow Leopard, fresh install, can't install any ports

Reported by: sgardne@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.8.0
Keywords: install error make wireshark nmap Cc:
Port:

Description

I just installed Snow Leopard fresh from scratch. I downloaded the latest Xcode and Macports, installed both, however I can't seem to install any ports I've tried. Installing Wireshark yields:

$ sudo port install wireshark
--->  Computing dependencies for wiresharkError: Unable to execute port: can't read "build.cmd": Failed to locate 'make' in path: '/opt/local/bin:/opt/local/sbin:/bin:/sbin:/usr/bin:/usr/sbin' or at its MacPorts configuration time location, did you move it?

If it's not in the path, I have no idea where to look. My path is:

$ echo $PATH
/opt/local/bin:/opt/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin

Attempting to install nmap yields a bit more error text:

--->  Computing dependencies for nmap
--->  Configuring libpcap
Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_libpcap/work/libpcap-1.0.0" && ./configure --prefix=/opt/local --enable-ipv6 " returned error 77
Command output: checking build system type... i686-apple-darwin10.0.0
checking host system type... i686-apple-darwin10.0.0
checking target system type... i686-apple-darwin10.0.0
checking for gcc... /usr/bin/gcc-4.2
checking for C compiler default output file name... 
configure: error: C compiler cannot create executables
See `config.log' for more details.

Error: The following dependencies failed to build: libpcap openssl zlib pcre bzip2 ncurses ncursesw readline
Error: Status 1 encountered during processing.

X11 is definitely installed as well as Xcode

$ which xterm
/usr/X11/bin/xterm

Any help would be greatly appreciated.

Change History (4)

comment:1 Changed 10 years ago by tobypeterson

Resolution: invalid
Status: newclosed

You didn't check the "UNIX dev tools" option in the Xcode installer. This is clearly spelled out in the MacPorts installation instructions.

comment:2 Changed 10 years ago by sgardne@…

Okay, I thought that might be the case, but the option is greyed out in the installer. Any idea why that would be the case on a fresh install?

comment:3 Changed 10 years ago by sgardne@…

Okay well I figured it out for anyone who cares... the Xcode installer that you download from Apple does not install the Unix development package. You have to use the one included on the Snow Leopard disk.

comment:4 Changed 10 years ago by hc5duke@…

Thanks. I ran into this exact problem. Too bad I didn't read this last Friday, I wouldn't have had to reinstall Leopard and Snow Leopard two times each to figure out exactly what was causing this issue.

Note: See TracTickets for help on using tickets.