Opened 11 years ago

Closed 10 years ago

#21178 closed defect (worksforme)

hg add is broken

Reported by: yaseppochi (Stephen J. Turnbull) Owned by: deric@…
Priority: Normal Milestone:
Component: ports Version: 1.8.99
Keywords: Cc:
Port: mercurial

Description

"hg add" is supposed to add all unversioned files that are not in .hgignore. It doesn't add anything:

wideload:/tmp 23:42$ mkdir a
wideload:/tmp 23:42$ cd a
wideload:/tmp/a 23:42$ echo foo > foo
wideload:/tmp/a 23:42$ LC_CTYPE=C hg init
wideload:/tmp/a 23:43$ LC_CTYPE=C hg add 
wideload:/tmp/a 23:43$ LC_CTYPE=C hg status
wideload:/tmp/a 23:43$ LC_CTYPE=C hg add foo
wideload:/tmp/a 23:43$ LC_CTYPE=C hg status 
A foo

(The funky locale stuff is due to bug #20730.)

Mac OS X 10.5.8 "Leopard"
MacBook Pro (Intel Core Duo)
MacPorts from svn (up to date at r57210; port last built and installed about 2009/09/02)
mercurial @1.3.1_0 (active)

Change History (3)

comment:1 Changed 11 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to deric@…

comment:2 Changed 11 years ago by tobypeterson

Sounds like an upstream bug to me...

comment:3 Changed 10 years ago by deric@…

Resolution: worksforme
Status: newclosed

Can't reproduce on current 1.6.4

Note: See TracTickets for help on using tickets.