Opened 11 years ago

Closed 11 years ago

#21182 closed defect (duplicate)

p5-io-compress-zlib and p5-io-compress conflict

Reported by: skymoo (Adam Mercer) Owned by: narf_tm@…
Priority: Normal Milestone:
Component: ports Version: 1.8.0
Keywords: Cc: jdfrens@…
Port: p5-io-compress-zlib, p5-io-compress

Description

Getting the following conflict when trying to install p5-io-compress @2.021_1 when p5-io-compress-zlib @2.015_0 is already installed:

--->  Activating p5-io-compress @2.021_1
Error: Unable to execute port: Image error: /opt/local/lib/perl5/vendor_perl/5.8.9/IO/Compress/Adapter/Deflate.pm is being used by the active p5-io-compress-zlib port.  Please deactivate this port first, or use 'port -f activate p5-io-compress' to force the activation.

Change History (5)

comment:1 Changed 11 years ago by jdfrens@…

Cc: jdfrens@… added

Cc Me!

comment:2 Changed 11 years ago by blb@…

Does the fix from #21167 also help here?

comment:3 Changed 11 years ago by narf_tm@…

Resolution: fixed
Status: newclosed

p5-io-compress-zlib is no longer used. Please uninstall it and update p5-compress-zlib before installing the new p5-io-compress and it will install fine.

comment:4 Changed 11 years ago by skymoo (Adam Mercer)

Resolution: fixed
Status: closedreopened

Still getting a similar problem, updated my ports tree, uninstalled p5-io-compress-zlib, ensured I was running the latest version of p5-compress-zlib (even though it hasn't been updated in over 12 months) then p5-io-compress fails to activate:

--->  Activating p5-io-compress @2.021_2
Error: Target org.macports.activate returned: Image error: /opt/local/lib/perl5/vendor_perl/5.8.9/auto/Compress/Zlib/autosplit.ix is being used by the active p5-compress-zlib port.  Please deactivate this port first, or use 'port -f activate p5-io-compress' to force the activation.

comment:5 Changed 11 years ago by skymoo (Adam Mercer)

Resolution: duplicate
Status: reopenedclosed

This seems to be #21167

Note: See TracTickets for help on using tickets.