Opened 10 years ago

Closed 10 years ago

#21320 closed defect (fixed)

python_select not working due to absolute $frameworks_dir path

Reported by: smibrahim@… Owned by: raimue (Rainer Müller)
Priority: Normal Milestone:
Component: ports Version: 1.8.0
Keywords: Cc: skymoo (Adam Mercer), faisal.moledina@…, ronhuang@…
Port: python_select

Description

here is the error log

lavlus-MacBook-Pro:~ ibrahim$ sudo port upgrade outdated
--->  Computing dependencies for python25
--->  Fetching python25
--->  Verifying checksum(s) for python25
--->  Extracting python25
--->  Applying patches to python25
--->  Configuring python25
--->  Building python25
--->  Staging python25 into destroot
--->  Deactivating python25 @2.5.4_6+darwin_10+macosx
--->  Computing dependencies for python25
--->  Installing python25 @2.5.4_7+darwin_10+macosx
--->  Activating python25 @2.5.4_7+darwin_10+macosx

To fully complete your installation and make python 2.5 the default, please run

	sudo port install python_select  
	sudo python_select python25

--->  Cleaning python25
lavlus-MacBook-Pro:~ ibrahim$ sudo port install python_select
Password:
--->  Computing dependencies for python_select
--->  Fetching python_select
--->  Attempting to fetch select-0.2.1.tar.gz from http://arn.se.distfiles.macports.org/python_select
--->  Verifying checksum(s) for python_select
--->  Extracting python_select
--->  Configuring python_select
--->  Building python_select
--->  Staging python_select into destroot
--->  Installing python_select @0.2.1_1+darwin_10
--->  Activating python_select @0.2.1_1+darwin_10
--->  Cleaning python_select
lavlus-MacBook-Pro:~ ibrahim$ sudo python_select python25
Selecting version "python25" for python
ln: /opt/local//opt/local/Library/Frameworks/Python.framework/Versions/Current: No such file or directory
ln: /opt/local//opt/local/Library/Frameworks/Python.framework/Headers: No such file or directory
ln: /opt/local//opt/local/Library/Frameworks/Python.framework/Resources: No such file or directory
ln: /opt/local//opt/local/Library/Frameworks/Python.framework/Python: No such file or directory
there were 4 errors selecting version "python25"!
lavlus-MacBook-Pro:~ ibrahim$ sudo python_select python25

Attachments (1)

select-absolute-target.diff (1.1 KB) - added by jmroot (Joshua Root) 10 years ago.
proposed fix

Download all attachments as: .zip

Change History (10)

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to raimue@…
Port: python_select added

Changed 10 years ago by jmroot (Joshua Root)

Attachment: select-absolute-target.diff added

proposed fix

comment:2 Changed 10 years ago by tobypeterson

this is a duplicate of #20285

comment:3 in reply to:  2 Changed 10 years ago by jmroot (Joshua Root)

Replying to toby@…:

this is a duplicate of #20285

It really isn't. I would actually call #20285 a duplicate of #18449 (the select file wasn't right for a non-framework build).

comment:4 Changed 10 years ago by jmroot (Joshua Root)

Summary: python_select not working on snowleopardpython_select not working due to absolute $frameworks_dir path

comment:5 Changed 10 years ago by skymoo (Adam Mercer)

Cc: ram@… added

Cc Me!

comment:6 Changed 10 years ago by faisal.moledina@…

Cc: faisal.moledina@… added

Cc Me!

comment:7 Changed 10 years ago by ronhuang@…

Cc: ronhuang@… added

Cc Me!

comment:8 Changed 10 years ago by raimue (Rainer Müller)

Status: newassigned

comment:9 Changed 10 years ago by raimue (Rainer Müller)

Resolution: fixed
Status: assignedclosed

Fixed in r57572.

Sorry that I actually broke more than I fixed with the first version. I did not test it properly before committing the changes to the base file.

Note: See TracTickets for help on using tickets.