Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#21331 closed defect (fixed)

x264: gcc-4.2: -E, -S, -save-temps and -M options are not allowed with multiple -arch flags

Reported by: ryandesign (Ryan Schmidt) Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 1.8.0
Keywords: snow-leopard Cc:
Port: x264

Description

On Mac OS X 10.6 trying to install x264 @20090810_2 I see:

gcc-4.2: -E, -S, -save-temps and -M options are not allowed with multiple -arch flags

I am building x264 universal for x86_64/i386. x264 @20090810_1 installed in this way with no problems.

Attachments (2)

x264.txt (49.0 KB) - added by ryandesign (Ryan Schmidt) 7 years ago.
patch-x264-sl-universal.diff (558 bytes) - added by dbevans (David B. Evans) 7 years ago.
Proposed patch for Portfile

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by ryandesign (Ryan Schmidt)

comment:1 Changed 7 years ago by dbevans (David B. Evans)

  • Status changed from new to assigned

Attached is a patch that may help at the expense of no asm optimizations when building +universal.

The problem is that asm optimizations build OK for x86_i386 but not for i386 when using gcc-4.2. Although it is reported that i386 should work if gcc-4.0 is used on snow leopard.

Let me know if this allows you to build and any further suggestions on how to deal with this situation in a universal setting.

Changed 7 years ago by dbevans (David B. Evans)

Proposed patch for Portfile

comment:2 Changed 7 years ago by ryandesign (Ryan Schmidt)

Thanks, universal now builds.

Maybe there's a way to use the muniversal portgroup that you're already using to enable asm only for x86_64?

comment:3 follow-up: Changed 7 years ago by dbevans (David B. Evans)

  • Keywords snow-leopard added
  • Resolution set to fixed
  • Status changed from assigned to closed

OK, patch committed in r57653. Thanks for the suggestion, will look into it.

comment:4 in reply to: ↑ 3 Changed 7 years ago by bgrupe@…

Replying to devans@…:

OK, patch committed in r57653. Thanks for the suggestion, will look into it.

I am trying to build x264 on SL with +universal and I am still seeing this issue even though x264s configure says asm: no.

What could be the problem here?

Note: See TracTickets for help on using tickets.