Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#21338 closed defect (duplicate)

gimp2 2.6.7 fails to compile (SL)

Reported by: bgrupe27 Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 1.8.0
Keywords: Cc: jdswinbank (John Swinbank), mrawde@…, tehcog (tehcog), julien.lusson@…, steve_macdougall@…, imgroxx@…, dkeverne@…, francesco086@…, vitaly@…, xgutter@…
Port: gimp2

Description

Hi, now that gegl compiles under SL, I tried to compile gimp. It fails with the following message:

Making all in libgimpbase
/bin/sh ../libtool --tag=CC   --mode=compile /usr/bin/gcc-4.2 -DHAVE_CONFIG_H -I. -I.. -I.. -D_REENTRANT -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include    -I/opt/local/include -DPREFIX=\""/opt/local"\" -DGIMPDIR=\"".gimp-2.6"\" -DDATADIR=\""/opt/local/share/gimp/2.0"\" -DLOCALEDIR=\""/opt/local/share/locale"\" -DPLUGINDIR=\""/opt/local/lib/gimp/2.0"\" -DSYSCONFDIR=\""/opt/local/etc/gimp/2.0"\" -DGIMP_PACKAGE=\""gimp"\" -DGIMP_DATA_VERSION=\"2.0\" -DGIMP_SYSCONF_VERSION=\"2.0\" -DGIMP_PLUGIN_VERSION=\"2.0\" -DG_LOG_DOMAIN=\"LibGimpBase\" -I/opt/local/include -DGIMP_DISABLE_DEPRECATED -DGDK_MULTIHEAD_SAFE -DGTK_MULTIHEAD_SAFE  -O2 -arch x86_64 -Wall -Wdeclaration-after-statement -Wmissing-prototypes -Wmissing-declarations -Winit-self -Wpointer-arith -Wold-style-definition -MT gimpcpuaccel.lo -MD -MP -MF .deps/gimpcpuaccel.Tpo -c -o gimpcpuaccel.lo gimpcpuaccel.c
/bin/sh ../libtool --tag=CC   --mode=compile /usr/bin/gcc-4.2 -DHAVE_CONFIG_H -I. -I.. -I.. -D_REENTRANT -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include    -I/opt/local/include -DPREFIX=\""/opt/local"\" -DGIMPDIR=\"".gimp-2.6"\" -DDATADIR=\""/opt/local/share/gimp/2.0"\" -DLOCALEDIR=\""/opt/local/share/locale"\" -DPLUGINDIR=\""/opt/local/lib/gimp/2.0"\" -DSYSCONFDIR=\""/opt/local/etc/gimp/2.0"\" -DGIMP_PACKAGE=\""gimp"\" -DGIMP_DATA_VERSION=\"2.0\" -DGIMP_SYSCONF_VERSION=\"2.0\" -DGIMP_PLUGIN_VERSION=\"2.0\" -DG_LOG_DOMAIN=\"LibGimpBase\" -I/opt/local/include -DGIMP_DISABLE_DEPRECATED -DGDK_MULTIHEAD_SAFE -DGTK_MULTIHEAD_SAFE  -O2 -arch x86_64 -Wall -Wdeclaration-after-statement -Wmissing-prototypes -Wmissing-declarations -Winit-self -Wpointer-arith -Wold-style-definition -MT gimpenv.lo -MD -MP -MF .deps/gimpenv.Tpo -c -o gimpenv.lo gimpenv.c
libtool: compile:  /usr/bin/gcc-4.2 -DHAVE_CONFIG_H -I. -I.. -I.. -D_REENTRANT -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include -I/opt/local/include -DPREFIX=\"/opt/local\" -DGIMPDIR=\".gimp-2.6\" -DDATADIR=\"/opt/local/share/gimp/2.0\" -DLOCALEDIR=\"/opt/local/share/locale\" -DPLUGINDIR=\"/opt/local/lib/gimp/2.0\" -DSYSCONFDIR=\"/opt/local/etc/gimp/2.0\" -DGIMP_PACKAGE=\"gimp\" -DGIMP_DATA_VERSION=\"2.0\" -DGIMP_SYSCONF_VERSION=\"2.0\" -DGIMP_PLUGIN_VERSION=\"2.0\" -DG_LOG_DOMAIN=\"LibGimpBase\" -I/opt/local/include -DGIMP_DISABLE_DEPRECATED -DGDK_MULTIHEAD_SAFE -DGTK_MULTIHEAD_SAFE -O2 -arch x86_64 -Wall -Wdeclaration-after-statement -Wmissing-prototypes -Wmissing-declarations -Winit-self -Wpointer-arith -Wold-style-definition -MT gimpenv.lo -MD -MP -MF .deps/gimpenv.Tpo -c gimpenv.c  -fno-common -DPIC -o .libs/gimpenv.o
libtool: compile:  /usr/bin/gcc-4.2 -DHAVE_CONFIG_H -I. -I.. -I.. -D_REENTRANT -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include -I/opt/local/include -DPREFIX=\"/opt/local\" -DGIMPDIR=\".gimp-2.6\" -DDATADIR=\"/opt/local/share/gimp/2.0\" -DLOCALEDIR=\"/opt/local/share/locale\" -DPLUGINDIR=\"/opt/local/lib/gimp/2.0\" -DSYSCONFDIR=\"/opt/local/etc/gimp/2.0\" -DGIMP_PACKAGE=\"gimp\" -DGIMP_DATA_VERSION=\"2.0\" -DGIMP_SYSCONF_VERSION=\"2.0\" -DGIMP_PLUGIN_VERSION=\"2.0\" -DG_LOG_DOMAIN=\"LibGimpBase\" -I/opt/local/include -DGIMP_DISABLE_DEPRECATED -DGDK_MULTIHEAD_SAFE -DGTK_MULTIHEAD_SAFE -O2 -arch x86_64 -Wall -Wdeclaration-after-statement -Wmissing-prototypes -Wmissing-declarations -Winit-self -Wpointer-arith -Wold-style-definition -MT gimpcpuaccel.lo -MD -MP -MF .deps/gimpcpuaccel.Tpo -c gimpcpuaccel.c  -fno-common -DPIC -o .libs/gimpcpuaccel.o
/var/tmp//ccWFY6VU.s:125:suffix or operands invalid for `pushf'
/var/tmp//ccWFY6VU.s:126:suffix or operands invalid for `pushf'
/var/tmp//ccWFY6VU.s:127:suffix or operands invalid for `pop'
/var/tmp//ccWFY6VU.s:130:suffix or operands invalid for `push'
/var/tmp//ccWFY6VU.s:131:suffix or operands invalid for `popf'
/var/tmp//ccWFY6VU.s:132:suffix or operands invalid for `pushf'
/var/tmp//ccWFY6VU.s:133:suffix or operands invalid for `pop'
/var/tmp//ccWFY6VU.s:134:suffix or operands invalid for `popf'
make[2]: *** [gimpcpuaccel.lo] Error 1
make[2]: *** Waiting for unfinished jobs....
mv -f .deps/gimpenv.Tpo .deps/gimpenv.Plo
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Change History (18)

comment:1 Changed 12 years ago by dbevans (David B. Evans)

Owner: changed from macports-tickets@… to devans@…
Status: newassigned

Are you building i386 or x86_64 or universal?

comment:2 in reply to:  1 Changed 12 years ago by bgrupe27

Replying to devans@…:

Are you building i386 or x86_64 or universal?

I'm building x86_64

comment:3 Changed 12 years ago by jdswinbank (John Swinbank)

Cc: swinbank@… added

Cc Me!

comment:4 Changed 12 years ago by mrawde@…

Cc: mrawde@… added

Cc Me!

comment:5 Changed 12 years ago by tehcog (tehcog)

Cc: brewerleece@… added

Cc Me!

comment:6 Changed 12 years ago by julien.lusson@…

Cc: julien.lusson@… added

Cc Me!

comment:7 Changed 12 years ago by steve_macdougall@…

Cc: steve_macdougall@… added

Cc Me!

comment:8 Changed 12 years ago by andree.jacobson@…

I have the same problem. Building ports from scratch on Snow Leopard.

comment:9 Changed 12 years ago by imgroxx@…

Cc: imgroxx@… added

Cc Me!

comment:10 Changed 12 years ago by xgutter@…

Cc: xgutter@… added

Cc Me!

comment:11 Changed 12 years ago by dkeverne@…

Cc: dkeverne@… added

Cc Me!

comment:12 Changed 12 years ago by francesco086@…

Cc: francesco086@… added

Cc Me!

comment:13 Changed 12 years ago by dkeverne@…

I've got a lot further by editing config.h and turning off ARCH_X86 and turning on ARCH_X86_64. Not sure where configure is deciding it shouldn't be 64bit.

It then fails a lot later on

Making all in twain
/bin/sh ../../libtool --tag=CC   --mode=link /usr/bin/gcc-4.2  -O2 -arch x86_64 -Wall -Wdeclaration-after-statement -Wmissing-prototypes -Wmissing-declarations -Winit-self -Wpointer-arith -Wold-style-definition -framework Carbon -framework TWAIN -L/opt/local/lib -o twain tw_func.o tw_util.o twain.o tw_mac.o ../../libgimp/libgimp-2.0.la ../../libgimpcolor/libgimpcolor-2.0.la ../../libgimpbase/libgimpbase-2.0.la -L/opt/local/lib -lgobject-2.0 -lgthread-2.0 -lglib-2.0 -lintl -liconv    -lintl   
libtool: link: /usr/bin/gcc-4.2 -O2 -arch x86_64 -Wall -Wdeclaration-after-statement -Wmissing-prototypes -Wmissing-declarations -Winit-self -Wpointer-arith -Wold-style-definition -o .libs/twain tw_func.o tw_util.o twain.o tw_mac.o  -framework TWAIN -L/opt/local/lib ../../libgimp/.libs/libgimp-2.0.dylib /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_gimp2/work/gimp-2.6.7/libgimpconfig/.libs/libgimpconfig-2.0.dylib /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_gimp2/work/gimp-2.6.7/libgimpmath/.libs/libgimpmath-2.0.dylib /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_gimp2/work/gimp-2.6.7/libgimpcolor/.libs/libgimpcolor-2.0.dylib /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_gimp2/work/gimp-2.6.7/libgimpbase/.libs/libgimpbase-2.0.dylib ../../libgimpcolor/.libs/libgimpcolor-2.0.dylib -lm ../../libgimpbase/.libs/libgimpbase-2.0.dylib /opt/local/lib/libgobject-2.0.dylib /opt/local/lib/libgthread-2.0.dylib /opt/local/lib/libglib-2.0.dylib /opt/local/lib/libintl.dylib /opt/local/lib/libiconv.dylib -lc -framework Carbon
Undefined symbols:
  "_EndQDContextForApplicationDockTile", referenced from:
      _twainMain in tw_mac.o
  "_BeginQDContextForApplicationDockTile", referenced from:
      _twainMain in tw_mac.o
  "_SetApplicationDockTileImage", referenced from:
      _twainMain in tw_mac.o
ld: symbol(s) not found
collect2: ld returned 1 exit status

Might try deselecting twain from configure and see if I can get past this later.

Regards, Darren

comment:14 Changed 12 years ago by vitaly@…

Cc: vitaly@… added

Cc Me!

comment:15 Changed 12 years ago by vitaly@…

This defect is dupe for #21011

comment:16 Changed 11 years ago by raimue (Rainer Müller)

Resolution: duplicate
Status: assignedclosed

Duplicate of #21011 which has patches.

comment:17 Changed 11 years ago by xgutter@…

Cc: xgutter@… removed

Cc Me!

comment:18 Changed 11 years ago by xgutter@…

Cc: xgutter@… added

Cc Me!

Note: See TracTickets for help on using tickets.