Opened 10 years ago

Closed 6 years ago

#21530 closed enhancement (fixed)

wxWidgets-devel and py26-wxpython universal portfiles

Reported by: Veence (Vincent) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: wxWidgets wxpython universal Cc: sgaede@…, software@…, jochen@…, lstoll@…, ndg.shopping@…, tzonghao@…, ajb78@…, jameskyle@…, domiman@…, jjstickel@…, michaelld (Michael Dickens), mkr@…, mojca (Mojca Miklavec)
Port: wxwidgets-devel, py26-wxpython

Description

The following Portfiles allow one to build universal (and cocoa-based) versions of Wxwidgets 2.9.0 and the respective py26-wxwidgets (which is based on the svn head version).

I am sorry I do not propose patched Portfiles, but since I've made extensive changes, I am not sure patches would be meaningful. Ideally, existing Portfiles and the ones I append should be somehow merged, since I am unsure my Portfiles will allow to build anything else but universal variants. Also, I feel that the py26-wxwidgets, relying on svn, should be placed in a special port rather than being merged into py26-wxwidgets, which is already lagging one or two releases. Finally, I've not yet tested the result, but since wxcocoa is claimed to be at an alpha stage, I am unsure those Portfiles will be useful to anybody else than me.

Apologies for letting other do the dirty job of (maybe) merging and committing. I just hope those files will be somehow helpful keeping MacPorts up to date with wxWidgets and its python counterpart.

Attachments (9)

Portfile (2.1 KB) - added by Veence (Vincent) 10 years ago.
Portfile for "py26-wxpython-devel"
patch-propgrid_wrap.diff (345 bytes) - added by Veence (Vincent) 10 years ago.
Patch #1 for "py26-wxpython-devel"
patch-setup_py.diff (695 bytes) - added by Veence (Vincent) 10 years ago.
Patch #2 for "py26-wxpython-devel"
Portfile.2 (4.8 KB) - added by Veence (Vincent) 10 years ago.
patch_bk_make_pch.diff (354 bytes) - added by Veence (Vincent) 10 years ago.
Patch #1 for wxwidgets-devel
patch_setup_h (460 bytes) - added by Veence (Vincent) 10 years ago.
patch #2 for wxwidgets-devel
patch_textctrl_mm.diff (1.6 KB) - added by Veence (Vincent) 10 years ago.
patch #3 for wxwidgets-devel
Portfile.3 (2.1 KB) - added by Veence (Vincent) 10 years ago.
New Portfile for "py26-wxpython-devel"
patch-config_py.diff (1.1 KB) - added by Veence (Vincent) 10 years ago.
Additional patch for py26-wxpython-devel

Download all attachments as: .zip

Change History (40)

Changed 10 years ago by Veence (Vincent)

Attachment: Portfile added

Portfile for "py26-wxpython-devel"

Changed 10 years ago by Veence (Vincent)

Attachment: patch-propgrid_wrap.diff added

Patch #1 for "py26-wxpython-devel"

Changed 10 years ago by Veence (Vincent)

Attachment: patch-setup_py.diff added

Patch #2 for "py26-wxpython-devel"

Changed 10 years ago by Veence (Vincent)

Attachment: Portfile.2 added

Changed 10 years ago by Veence (Vincent)

Attachment: patch_bk_make_pch.diff added

Patch #1 for wxwidgets-devel

Changed 10 years ago by Veence (Vincent)

Attachment: patch_setup_h added

patch #2 for wxwidgets-devel

Changed 10 years ago by Veence (Vincent)

Attachment: patch_textctrl_mm.diff added

patch #3 for wxwidgets-devel

comment:1 Changed 10 years ago by Veence (Vincent)

Portfile.2 is the Portfile for wxwidgets-devel universal

comment:2 Changed 10 years ago by Veence (Vincent)

The line:

append  bopts                           "--install-headers=${prefix}/include "

in the Portfile for py26-wxpython is wrong. It incorrectly install headers in ${prefix}/include instead of ${prefix}/include/wx-devel, the path used by wxwidgets-devel. So it should read:

append  bopts                           "--install-headers=${prefix}/include/wx-devel "

instead.

comment:3 Changed 10 years ago by Veence (Vincent)

The portfile for py26-wxwidgets-devel was particularly ugly. I join a new, more aesthetic and much more understandable one. It also solves an issue that was present in the former version: the *.h files install directory is wrong, even with the --install-headers patch, because config.py overrides the default behavior. The portfiles solves this thanks to an additional patch. I will report this bug upstream.

Finally, sorry for being (too much) verbose.

Changed 10 years ago by Veence (Vincent)

Attachment: Portfile.3 added

New Portfile for "py26-wxpython-devel"

Changed 10 years ago by Veence (Vincent)

Attachment: patch-config_py.diff added

Additional patch for py26-wxpython-devel

comment:4 Changed 10 years ago by sgaede@…

Cc: sgaede@… added

Cc Me!

comment:5 in reply to:  1 Changed 10 years ago by sgaede@…

Replying to vince@…:

Portfile.2 is the Portfile for wxwidgets-devel universal

I'm trying to build wxWidgets-devel using the new Portfile, but I'm new at this, and need help, I did a port extract wxWidgets-devel / then manually replaced the Portfile with Portfile.2 and renamed it / created a files subdirectory (graphics/wxWidgets-delev/files) and put the three patch files there.

Can someone point me to a howto?

Thanks

comment:6 Changed 10 years ago by software@…

Cc: software@… added

Cc Me!

comment:7 Changed 10 years ago by jochen@…

Cc: jochen@… added

Cc Me!

comment:8 Changed 10 years ago by jjstickel@…

Cc: jjstickel@… added

Cc Me!

comment:9 Changed 10 years ago by koverholt@…

Cc: koverholt@… added

Cc Me!

comment:10 Changed 10 years ago by lstoll@…

Cc: lstoll@… added

Cc Me!

comment:11 Changed 10 years ago by ndg.shopping@…

Are there any news on this? I am really waiting for the wxWidgets and the problem is too dificult for me to handle it alone ;/

comment:12 Changed 10 years ago by ndg.shopping@…

Cc: ndg.shopping@… added

Cc Me!

comment:13 Changed 10 years ago by tzonghao@…

Cc: tzonghao@… added

Cc Me!

comment:14 Changed 10 years ago by ajb78@…

Cc: ajb78@… added

Cc Me!

comment:15 Changed 10 years ago by jmroot (Joshua Root)

Cc: jameskyle@… added

comment:16 Changed 10 years ago by domiman@…

Cc: domiman@… added

Cc Me!

comment:17 Changed 10 years ago by domiman@…

Cc: domiman@… removed

Cc Me!

comment:18 Changed 10 years ago by domiman@…

Cc: domiman@… added

Cc Me!

comment:19 Changed 10 years ago by jjstickel@…

Cc: jjstickel@… removed

Cc Me!

comment:20 Changed 10 years ago by jjstickel@…

Cc: jjstickel@… added

Cc Me!

comment:21 Changed 10 years ago by jjstickel@…

I am trying to install these 64 bit, cocoa portfiles on 10.6. wxWidgets-devel installs fine, but I am getting errors with the provided py26-wxwidgets-devel portfile. First, the h-propgrid_wrap.diff patch did not apply cleanly. I suspect this is due to further changes to the svn sources, and so I hacked the portfile to not apply it. Then I get this error:

In file included from src/helpers.cpp:16:
include/wx/wxPython/wxPython_int.h:49:24: error: wx/infobar.h: No such file or directory
src/helpers.cpp: In member function 'void wxPyApp::_BootstrapApp()':
<snip>

Any suggestions about how to fix this? Another patch or updated portfile?

Thanks, Jonathan

comment:22 Changed 10 years ago by michaelld (Michael Dickens)

Cc: michaelld@… added

Cc Me!

comment:23 in reply to:  21 Changed 10 years ago by jjstickel@…

Replying to jjstickel@…:

I am trying to install these 64 bit, cocoa portfiles on 10.6. wxWidgets-devel installs fine, but I am getting errors with the provided py26-wxwidgets-devel portfile.

...

OK, after some poking around it seems that wxpython-devel (svn) will not compile against wxwidgets-2.9.0 anymore. The latest development sources of wxwidgets (svn) are now needed (not too surprising). Anyone keeping up on the status of these projects? Do you know of any planned releases of development snapshots so that we do not have to rely on the ever-changing svn sources? Would it be possible to create snapshots and put them on a macports server?

Thanks, Jonathan

comment:24 Changed 10 years ago by jjstickel@…

For a workaround not requiring the use of development sources, see ticket #24350.

comment:25 in reply to:  24 ; Changed 9 years ago by ruud@…

Replying to jjstickel@…:

For a workaround not requiring the use of development sources, see ticket #24350.

Since that ticket is closed, can this ticket be closed as well?

comment:26 in reply to:  25 Changed 9 years ago by jjstickel@…

Replying to ruud@…:

Replying to jjstickel@…:

For a workaround not requiring the use of development sources, see ticket #24350.

Since that ticket is closed, can this ticket be closed as well?

This ticket is about cocoa-supported wxwidgets and wxpython. I would say it is appropriate to keep it open until wxpython upstream makes a release that supports cocoa.

comment:27 Changed 9 years ago by mkr@…

Cc: mkr@… added

Cc Me!

comment:28 Changed 7 years ago by mojca (Mojca Miklavec)

I'm going through old wxpython tickets and believe this one can be closed now? Or is there anything here that hasn't yet been included in MacPorts trunk?

comment:29 Changed 7 years ago by mojca (Mojca Miklavec)

Cc: mojca@… added

Cc Me!

comment:30 Changed 7 years ago by koverholt@…

Cc: koverholt@… removed

Cc Me!

comment:31 Changed 6 years ago by mojca (Mojca Miklavec)

Resolution: fixed
Status: newclosed
Version: 1.8.0

The wxPython 2.9 ports now support Cocoa, so I'm closing the ticket even if I didn't take a closer look at all the patches that were written 4 years ago. If there is anything missing in the wxPython ports that are currently in MacPorts, please don't hesitate to ask.

Note: See TracTickets for help on using tickets.