New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #2168 (closed defect: duplicate)

Opened 10 years ago

Last modified 9 years ago

NEW: DarwinPortVersion-1.0

Reported by: skuld@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: skuld@…
Port:

Description

DarwinPortVersion-1.0

the portfile can be found here: http://www.goddess-gate.com/devel/darwinportversion/Portfile

Description: This program list new version of installed ports, after the user had updated the port tree and regenerated the PortIndex file.

Homepage: http://www.goddess-gate.com/devel/darwinportversion

Change History

comment:1 Changed 10 years ago by skuld@…

The Portfile is now for DarwinPortVersion 1.1

comment:2 Changed 10 years ago by olegb@…

a quick look at your port (and script) reveals that if the user uses a non default ${prefix} then it all falls to the ground - or am i mistaking ?

we dont force anyone to use ${prefix} = /opt/local

comment:3 Changed 9 years ago by skuld@…

  • Cc skuld@… added

comment:4 Changed 9 years ago by skuld@…

I'm sorry for replying late, I didn't receive any notification of your answer.

I've just updated the Portfile to version 1.2, with a new -p option to specify the prefix.

comment:5 Changed 9 years ago by jberry@…

Great idea, and long overdue. I submitted a patch (bug #2450) that adds a new target to the port command to provide similar functionality. That _might_ be a faster option ;)

comment:6 Changed 9 years ago by skuld@…

Good idea. I don't have enough TCL knowledge to do it myself, that's why I did this bash script.

comment:7 Changed 9 years ago by snu@…

  • Status changed from new to closed
  • Resolution set to duplicate

Equivalent functionality provided by bug 2450 according to comments above. Feel free to reopen if that is not the case.

* This bug has been marked as a duplicate of 2450 *

Note: See TracTickets for help on using tickets.