Opened 11 years ago

Closed 11 years ago

#21685 closed defect (fixed)

Installer hangs on 10.6 without Developer Tools

Reported by: ivan.savov@… Owned by: macports-tickets@…
Priority: Normal Milestone: MacPorts 1.9.0
Component: base Version: 1.8.0
Keywords: Cc: ivan.savov@…, ryandesign (Ryan Schmidt)
Port:

Description

I downloaded the MacPorts-1.8.1.pkg and it runs for a stood for a long time on the Running Scripts.

I am not sure which script this means, but I only saw after that I need to have Developer Tools installed from https://connect.apple.com/

I don't want to load the neighbour's wifi with a 900Mb download, but will try it tomorrow from school.

Should there be a prerequisite check in the installer?

Change History (4)

comment:1 Changed 11 years ago by ivan.savov@…

Cc: ivan.savov@… added

Cc Me!

comment:2 Changed 11 years ago by blb@…

One of the steps it does is to run a selfupdate, which will grab all the Portfiles needed and hence need network access. If your access is slow, that will be the cause of a slow install. You can check /var/log/install.log to see exactly what it was doing (I believe there's also an option within Installer to view this log).

comment:3 Changed 11 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Keywords: removed

Our InstallationCheck script does not appear to check that Xcode is installed. We should definitely add this. We could even check that the version of Xcode is sufficient. This would prevent problems with nonexistent Xcode installations, with old Xcode versions people haven't upgraded in awhile, and old Xcode versions that people haven't updated for the version of Mac OS X they just updated to.

comment:4 Changed 11 years ago by jmroot (Joshua Root)

Keywords: installer removed
Milestone: MacPorts 1.9.0
Resolution: fixed
Status: newclosed

Still not convinced that lack of Xcode could have caused the installer to hang, but we're checking for Xcode as of r68593.

Note: See TracTickets for help on using tickets.