Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#21936 closed defect (fixed)

liblastfm fails to build on Snow Leopard

Reported by: sharky@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.8.1
Keywords: Cc: ewal@…, eatdespain@…, andrea@…, lhunath@…, mark.gaylard@…, m.doppler@…, macports@…
Port: liblastfm

Description (last modified by mf2k (Frank Schima))

liblastfm fails with the following errors when building on Snow Leopard:

/opt/local/libexec/qt4-mac/include/QtCore/qglobal.h:311:6: warning: #warning "Support for this version of Mac OS X is still preliminary"
/usr/bin/g++-4.2 -c -pipe -fno-operator-names -O2 -arch x86_64 -I/opt/local/include -fvisibility-inlines-hidden -fvisibility=hidden -arch x86_64 -Xarch_x86_64 -mmacosx-version-min=10.5 -Wall -W -fPIC -DQT_NO_DEBUG -DQT_XML_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/opt/local/libexec/qt4-mac/mkspecs/macx-g++ -I. -I/opt/local/libexec/qt4-mac/lib/QtCore.framework/Versions/4/Headers -I/opt/local/libexec/qt4-mac/include/QtCore -I/opt/local/libexec/qt4-mac/lib/QtNetwork.framework/Versions/4/Headers -I/opt/local/libexec/qt4-mac/include/QtNetwork -I/opt/local/libexec/qt4-mac/lib/QtXml.framework/Versions/4/Headers -I/opt/local/libexec/qt4-mac/include/QtXml -I/opt/local/libexec/qt4-mac/include -I../_include -I_build -F/opt/local/libexec/qt4-mac/lib -o _build/moc_Audioscrobbler.o _build/moc_Audioscrobbler.cpp
In file included from /opt/local/libexec/qt4-mac/lib/QtCore.framework/Versions/4/Headers/QtGlobal:1,
                 from ../_include/lastfm/global.h:24,
                 from _build/../scrobble/Audioscrobbler.h:23,
                 from _build/moc_Audioscrobbler.cpp:10:
/opt/local/libexec/qt4-mac/lib/QtCore.framework/Versions/4/Headers/qglobal.h:311:6: warning: #warning "Support for this version of Mac OS X is still preliminary"
core/misc.cpp: In function 'QDir dataDotDot()':
core/misc.cpp:69: error: cannot convert 'long int*' to 'SInt32*' for argument '5' to 'OSErr FindFolder(FSVolumeRefNum, OSType, Boolean, FSVolumeRefNum*, SInt32*)'
core/misc.cpp:78: error: '::FSMakeFSSpec' has not been declared
core/misc.cpp:82: error: '::FSpMakeFSRef' has not been declared

Attachments (1)

patch-src-core-misc.cpp.patch (1.1 KB) - added by m.doppler@… 11 years ago.
patch for liblastfm leopard compatiblity

Download all attachments as: .zip

Change History (19)

comment:1 Changed 11 years ago by mf2k (Frank Schima)

Description: modified (diff)

comment:2 Changed 11 years ago by ewal@…

Same issue here... Wondering how long it will take me to finally get all the deps for amarok compiling ;-) Been compiling and recompiling for 3 weeks now :)

comment:3 Changed 11 years ago by ewal@…

Cc: ewal@… added

Cc Me!

comment:4 Changed 11 years ago by eatdespain@…

Cc: eatdespain@… added

Cc Me!

comment:5 Changed 11 years ago by macports@…

Cc: macports@… added

Cc Me!

comment:6 Changed 11 years ago by andrea@…

Cc: andrea@… added

Cc Me!

comment:7 Changed 11 years ago by nerdling (Jeremy Lavergne)

Cc: lhunath@… added

Duplicate: #21974.

comment:8 Changed 11 years ago by mark.gaylard@…

Cc: mark.gaylard@… added

Cc Me!

Changed 11 years ago by m.doppler@…

patch for liblastfm leopard compatiblity

comment:9 Changed 11 years ago by m.doppler@…

The patch I just attached fixes the compile problem for me. I replaced the deprecated api calls by corresponding current api calls.

Note that I have only tested the patch to compile and not whether it works as expected, yet.

comment:10 Changed 11 years ago by m.doppler@…

Cc: m.doppler@… added

Cc Me!

comment:11 Changed 11 years ago by macports@…

Cc: macports@… removed

Cc Me!

comment:12 Changed 11 years ago by macports@…

Cc: macports@… added

Cc Me!

comment:13 in reply to:  9 ; Changed 11 years ago by macports@…

Replying to m.doppler@…:

The patch I just attached fixes the compile problem for me. I replaced the deprecated api calls by corresponding current api calls.

Note that I have only tested the patch to compile and not whether it works as expected, yet.

Is there documentation on how to use this patch? I'd like to help test. --Dean

comment:14 in reply to:  13 Changed 11 years ago by bkn@…

Replying to macports@…:

Replying to m.doppler@…:

The patch I just attached fixes the compile problem for me. I replaced the deprecated api calls by corresponding current api calls.

Note that I have only tested the patch to compile and not whether it works as expected, yet.

Is there documentation on how to use this patch? I'd like to help test.

change directory to the source directory of liblastfm you should see it near the beginning of the error output on the compile error (on my machine it was /Users/opt/local/var/macports/build/_Users_opt_local_var_macports_sources_rsync.macports.org_release_ports_audio_liblastfm/work/liblastfm-0.3.0)

The execute: patch -p0 < /path/to/patch-src-core-misc.cpp.patch

note: you may need to be root, depending on your macports setup.

comment:15 Changed 11 years ago by ewal@…

I can confirm that the patch fixes the compile. I'm continuing compiling amarok now; let's see if it works!

comment:16 Changed 11 years ago by sharky@…

Resolution: fixed
Status: newclosed

Committed in r59297, thanks for the patch.

comment:17 Changed 11 years ago by macports@…

Thanks for fixing this. Dearly missing amarok since moving from linux to macos.

comment:18 in reply to:  17 Changed 11 years ago by eatdespain@…

Replying to macports@…:

Thanks for fixing this. Dearly missing amarok since moving from linux to macos.

Still a little walk to go...

https://trac.macports.org/ticket/22037

Note: See TracTickets for help on using tickets.