Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#21951 closed defect (worksforme)

gd2: gdlib-config: syntax error near unexpected token `then'

Reported by: ryandesign (Ryan Schmidt) Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 1.8.1
Keywords: Cc:
Port: gd2

Description

$ port installed gd2
The following ports are currently installed:
  gd2 @2.0.35_5+universal (active)
$ gdlib-config
/mp/bin/gdlib-config: line 41: syntax error near unexpected token `then'
/mp/bin/gdlib-config: line 41: `iftest $# -eq 0; then'

Snow Leopard 10.6.1
MacPorts 1.8.1

Change History (5)

comment:1 Changed 11 years ago by blb@…

Possibly a +universal issue:

$ port installed gd2
The following ports are currently installed:
  gd2 @2.0.35_5 (active)
$ gdlib-config
Print information on GD library's version, configuration, and use.
Usage: gdlib-config [options]
...

Oddly, the bit at line 41 here is

if test $# -eq 0; then

Not sure why yours lost a space there.

comment:2 Changed 11 years ago by ryandesign (Ryan Schmidt)

Every line of my gdlib-config lost its first space, wherever in the line it occurred. That was installed Sept 5. I'm unable to reproduce the issue installing it today.

comment:3 Changed 11 years ago by blb@…

Heh, that's a new one on me...sounds like some reinplace/regex s// gone horribly wrong. FWIW, mine was Sept 16...but that was due to 10.6 upgrade.

comment:4 Changed 11 years ago by ryandesign (Ryan Schmidt)

Resolution: worksforme
Status: newclosed

I wanted to see if I could come up with an explanation for why this occurred, but gdlib-config is generated by config.status which is generated by configure and it's a bit much for me to unravel.

comment:5 Changed 10 years ago by ryandesign (Ryan Schmidt)

Somebody else now experiences this issue; it has been refiled as #25946.

Note: See TracTickets for help on using tickets.