Opened 8 years ago

Closed 7 years ago

#22144 closed defect (fixed)

"staging amarok into destroot" fails.

Reported by: blamefrost@… Owned by: illogic-al@…
Priority: Normal Milestone:
Component: ports Version: 1.8.1
Keywords: Cc: tonyp23@…, eatdespain@…, nudecamp@…, a.vincelli@…, jp@…, jairo.serrano@…, gentoolicious@…, marix@…, choeger@…, thomas.weiss@…, michaelld (Michael Dickens)
Port: amarok

Description

The command below fails, because this directory doesn't exist:

/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_amarok/work/destroot/opt/local/bin/amarok.app

I don't know whether this is because the build fails to create this directory, or whether the post-destroot mv command contains errors. Either way, amarok fails to install.

Full error message:

--->  Staging amarok into destroot
Error: Target org.macports.destroot returned: shell command "mv /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_amarok/work/destroot/opt/local/bin/amarok.app/Contents/Resources/* /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_amarok/work/destroot/Applications/MacPorts/KDE4/Amarok.app/Contents/Resources/" returned error 1
Command output: mv: rename /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_amarok/work/destroot/opt/local/bin/amarok.app/Contents/Resources/* to /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_amarok/work/destroot/Applications/MacPorts/KDE4/Amarok.app/Contents/Resources/*: No such file or directory

I'm using Mac OS X 10.6.1 and gcc 4.2.1

Attachments (1)

humongous_ls_output.txt (61.6 KB) - added by blamefrost@… 8 years ago.
output of ls -aR /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_amarok/work/destroot/opt/local/*

Download all attachments as: .zip

Change History (33)

comment:1 Changed 8 years ago by mf2k (Frank Schima)

  • Owner changed from macports-tickets@… to illogic-al@…
  • Port amarok added

comment:2 Changed 8 years ago by tonyp23@…

  • Cc tonyp23@… added

Cc Me!

comment:3 Changed 8 years ago by shikhar@…

  • Cc shikhar@… added

Cc Me!

comment:4 Changed 8 years ago by shikhar@…

  • Cc shikhar@… removed

Cc Me!

comment:5 follow-up: Changed 8 years ago by eatdespain@…

  • Cc eatdespain@… added

Cc Me!

comment:6 in reply to: ↑ 5 Changed 8 years ago by eatdespain@…

The same issue here, it fails to generate the application directory with it's contents

I must say I removed all the phonon declarations when compiling qtscriptgenerator (which was previous to Amarok) because the amount of errors I was getting at the time.

Thanks

comment:7 follow-up: Changed 8 years ago by illogic-al@…

Allo! This is interesting. I tested the port myself before updating so I know it works on 10.5, and unless someone has messed with it since then I see no reason why it shouldn't work in 10.6 (if it gets all the way to staging in the destroot). And looking at the portfile, i see that someone has indeed messed w/ it ... I'll look into that.

eatdespain@… on the otherhand has problems beyond this judging by him messing around w/ phonon. I'd suggest he create a ticket with his initial problems listed therein.

how about trying this. sudo port build amarok then once it is finished do 'ls -aR /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_amarok/work/destroot/opt/local/*' and paste the output here.

comment:8 in reply to: ↑ 7 Changed 8 years ago by blamefrost@…

Replying to illogic-al@…:

how about trying this. sudo port build amarok then once it is finished do 'ls -aR /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_amarok/work/destroot/opt/local/*' and paste the output here.

After sudo port build amarok, the

/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_amarok/work/destroot

directory does not exist, so that ls command won't do much good.

$ ls -aR /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_amarok/work/destroot/opt/local/*
zsh: no matches found: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_amarok/work/destroot/opt/local/*

Changed 8 years ago by blamefrost@…

output of ls -aR /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_amarok/work/destroot/opt/local/*

comment:9 Changed 8 years ago by blamefrost@…

I ran the ls command after a sudo port install amarok (where it failed in the staging as expected), and attached the output to this ticket. I didn't really feel like polluting the comment with nine hundred something lines of file listings.

comment:10 follow-up: Changed 8 years ago by tonyp23@…

The portion of the portfile causing problems is this:

post-destroot {
    # Place bundle icons in correct location
	system "mv ${destroot}${prefix}/bin/amarok.app/Contents/Resources/* ${destroot}${applications_dir}/KDE4/Amarok.app/Contents/Resources/"
	system "rm -rf ${destroot}${prefix}/bin"
}

It would seem that this build does not creat the amarok.app directory, and yet the portfile is looking for it.

comment:11 Changed 8 years ago by illogic-al@…

  1. seems that amarok.app isn't built anymore. compiling on 10.4 to confirm.

comment:12 Changed 8 years ago by tonyp23@…

So commenting out the post-destroot section allows amarok to complete successfully. I have no idea if it will have future repercussions, but it is running right now on my system. I'll report back when I've had some time to play around with it a little more.

10.6.1

comment:13 follow-up: Changed 8 years ago by illogic-al@…

If you have an icon for amarok it will have no repercussions at all. It's a purely cosmetic fix.

comment:14 in reply to: ↑ 13 ; follow-up: Changed 8 years ago by blamefrost@…

Replying to illogic-al@…:

If you have an icon for amarok it will have no repercussions at all. It's a purely cosmetic fix.

Some icons for context menus are missing when I try this, for example the icons for adding music to a playlist, editing a playlist, deleting tracks, show active track, local music.

Not that I care much about right now... I now have a working amarok! \o/

comment:15 in reply to: ↑ 14 ; follow-up: Changed 8 years ago by illogic-al@…

Replying to blamefrost@…:

Some icons for context menus are missing when I try this, for example the icons for adding music to a playlist, editing a playlist, deleting tracks, show active track, local music.

Not that I care much about right now... I now have a working amarok! \o/

unrelated. try running kbuildsycoca in the terminal to see if the icons comes back. otherwise, run kdeinit4

comment:16 in reply to: ↑ 15 Changed 8 years ago by blamefrost@…

Replying to illogic-al@…:

Replying to blamefrost@…:

Some icons for context menus are missing when I try this, for example the icons for adding music to a playlist, editing a playlist, deleting tracks, show active track, local music.

Not that I care much about right now... I now have a working amarok! \o/

unrelated. try running kbuildsycoca in the terminal to see if the icons comes back. otherwise, run kdeinit4

That doesn't seem to work for me. I don't see any icons for kded or knotify in the dock either, by the way, but that's definitely unrelated to amarok.

comment:17 Changed 8 years ago by nudecamp@…

  • Cc nudecamp@… added

Cc Me!

comment:18 Changed 8 years ago by a.vincelli@…

  • Cc a.vincelli@… added

Cc Me!

comment:19 Changed 8 years ago by jp@…

  • Cc jp@… added

Cc Me!

comment:20 in reply to: ↑ 10 ; follow-up: Changed 8 years ago by oroboros@…

Replying to tonyp23@…:

The portion of the portfile causing problems is this: post-destroot { ... }

This is indeed the cause. Commented out those lines of the portfile and all is fine. The icons are already in the location that post-destroot is attempting to install them to:

# find build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_amarok/ -name Resources build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_amarokwork/build/src/Amarok.app/Contents/Resources build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_amarokwork/destroot/Applications/MacPorts/KDE4/Amarok.app/Contents/Resources

Looks like the build itself was fixed, so there is no longer the need for that quick-fix in the Portfile.

comment:21 Changed 8 years ago by jairo.serrano@…

  • Cc jairo.serrano@… added

Cc Me!

comment:22 in reply to: ↑ 20 ; follow-up: Changed 8 years ago by 3xtr3m@…

Replying to oroboros@…:

Looks like the build itself was fixed, so there is no longer the need for that quick-fix in the Portfile.

I tried to compile amarok 2.2.0 and it has the same issue....

best regards, mike

comment:23 Changed 8 years ago by gentoolicious@…

I can confirm that the latest version of Amarok is still facing the same issue.

comment:24 Changed 8 years ago by gentoolicious@…

  • Cc gentoolicious@… added

Cc Me!

comment:25 in reply to: ↑ 22 Changed 8 years ago by oroboros@…

Replying to 3xtr3m@…:

I tried to compile amarok 2.2.0 and it has the same issue....

Yup, just tried it on a new Macbook and it still fails in the same place. The portfile has to be fixed.

Edit /opt/local/var/macports/sources/rsync.macports.org/release/ports/kde/amarok/Portfile and change lines 42 and 43 from this:

       system "mv ${destroot}${prefix}/bin/amarok.app/Contents/Resources/* ${destroot}${applications_dir}/KDE4/Amarok.app/Contents/Resources/"
       system "rm -rf ${destroot}${prefix}/bin"

to this:

#       system "mv ${destroot}${prefix}/bin/amarok.app/Contents/Resources/* ${destroot}${applications_dir}/KDE4/Amarok.app/Contents/Resources/"
#       system "rm -rf ${destroot}${prefix}/bin"

Looks like a quick fix to the portfile, since the underlying source distro now creates the application bundle correctly. Let me know if you need a patch.

comment:26 Changed 8 years ago by marix@…

  • Cc marix@… added

Cc Me!

comment:27 Changed 8 years ago by choeger@…

  • Cc choeger@… added

Cc Me!

comment:28 Changed 7 years ago by thomas.weiss@…

  • Cc thomas.weiss@… added

Cc Me!

comment:29 Changed 7 years ago by hal@…

I can confirm that as of today, building the latest version of Amorak through MacPorts still has this problem and I had to comment out the two lines to get it to build successfully.

comment:30 Changed 7 years ago by michaelld (Michael Dickens)

I'm upgrading Amarok to 2.3.1, and will address this ticket's issue if necessary once I get the rest of the build stabilized. I haven't encountered this issue with 2.3.1, so I'm hopeful that the version bump will take care of it.

comment:31 Changed 7 years ago by michaelld (Michael Dickens)

  • Cc michaelld@… added

Cc Me!

comment:32 Changed 7 years ago by michaelld (Michael Dickens)

  • Resolution set to fixed
  • Status changed from new to closed

As of r69497, Amarok is at version 2.3.1; please see ticket #25489 for more info. I don't think this ticket is relevant any longer, so I'm closing it; please verify and reopen if the original topic is still an issue.

Note: See TracTickets for help on using tickets.