Opened 11 years ago

Closed 11 years ago

#22313 closed update (fixed)

osh 20090527 - port update to 20091029

Reported by: jan+mp@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: haspatch maintainer Cc:
Port: osh

Description

This update changes the Portfile to sync the osh port with the latest upstream release. The attached Portfile patch is against shells/osh/Portfile r57375. I have successfully tested this update under MacPorts 1.8.1 on Mac OS X 10.6.1.

A summary of the upstream changes between osh-20090527 and osh-20091029 follows:

This release fixes a compilation problem on AIX caused by not
wrapping WCOREDUMP(s) with #ifdef WCOREDUMP ... #endif. A minor
code cleanup reduces unnecessary code duplication. Package documentation
and example rc files are now installed by default in DOCDIR. MANDIR
now defaults to $(PREFIX)/share/man/man1.

Attachments (1)

Portfile.patch (1.3 KB) - added by jan+mp@… 11 years ago.

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by jan+mp@…

Attachment: Portfile.patch added

comment:1 Changed 11 years ago by jan+mp@…

Cc: jan+mp@… added

Cc Me!

comment:2 Changed 11 years ago by jmroot (Joshua Root)

Cc: jan+mp@… removed
Keywords: haspatch maintainer added; osh update removed
Version: 1.8.1

comment:3 in reply to:  2 Changed 11 years ago by jan+mp@…

Replying to jmr@…:

jmr,

Is there anything else I need to do in order to complete the update process? If so, please do let me know, and I'll take care of it.

Thanks, jan+mp (aka Jeff)

comment:4 Changed 11 years ago by nerdling (Jeremy L)

Resolution: fixed
Status: newclosed

Updated in r60676.

Note: See TracTickets for help on using tickets.