Opened 12 years ago

Last modified 3 months ago

#22393 assigned defect

splint 3.1.2 does not build

Reported by: rgovostes@… Owned by:
Priority: Normal Milestone:
Component: ports Version: 1.8.1
Keywords: Cc: blb@…, ballapete (Peter Dyballa)
Port: splint

Description

Under 10.6, splint 3.1.2 fails with missing files ("signature.tab.c").

The file should be created by bison, per the Makefile:

$(BISON) $(YFLAGS) -p lsl signature.y

If I run this command manually, it works fine, so I'm not sure what the issue is.

Attachments (2)

split-build.txt (959 bytes) - added by rgovostes@… 12 years ago.
patch-src_signature.y.diff (293 bytes) - added by ballapete (Peter Dyballa) 3 months ago.
Patch to fix warning

Download all attachments as: .zip

Change History (11)

Changed 12 years ago by rgovostes@…

Attachment: split-build.txt added

comment:1 Changed 12 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to waqar@…
Port: splint added

Please remember to fill in the port field and cc the maintainer, as per the ticket guidelines.

comment:2 Changed 12 years ago by blb@…

Cc: blb@… added
Resolution: fixed
Status: newclosed

Fails for me as well, but in a definitely different way, so seems like a parallel build issue; disabled such in r60585.

comment:3 Changed 3 months ago by ballapete (Peter Dyballa)

Resolution: fixed
Status: closedreopened

The bug is back on Big Sur, macOS Version 11.2:

Making all in src
make[2]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_splint/splint/work/splint-3.1.2/src'
* Making signature.c
signature.y:59.1-12: warning: deprecated directive: ‘%pure_parser’, use ‘%define api.pure’ [-Wdeprecated]
   59 | %pure_parser
      | ^~~~~~~~~~~~
      | %define api.pure
signature.y: warning: fix-its can be applied.  Rerun with option '--update'. [-Wother]
grep "FLG_" flags.def > Headers/flag_codes.gen
/Library/Developer/CommandLineTools/usr/bin/make
make[3]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_splint/splint/work/splint-3.1.2/src'
Compiling cgrammar.c...
Compiling cscanner.c...
Compiling mtscanner.c...
Compiling mtgrammar.c...
Compiling llgrammar.c...
Compiling signature.c...
signature.c:181:10: fatal error: 'signature.tab.h' file not found
#include "signature.tab.h"
         ^~~~~~~~~~~~~~~~~
1 error generated.
make[3]: *** [signature.o] Error 1
make[3]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_devel_splint/splint/work/splint-3.1.2/src'

The file name signature.o comes from signature.c.

comment:4 Changed 3 months ago by ballapete (Peter Dyballa)

Cc: ballapete added

Changed 3 months ago by ballapete (Peter Dyballa)

Attachment: patch-src_signature.y.diff added

Patch to fix warning

comment:5 Changed 3 months ago by mf2k (Frank Schima)

Owner: waqar@… deleted
Status: reopenedassigned

comment:6 Changed 3 months ago by ballapete (Peter Dyballa)

I installed automake17 and ran configure with the options ACLOCAL=/opt/local/bin/aclocal-17 AUTOMAKE=/opt/local/bin/automake-17 – no change. So I am going to try other versions of automakehttp://splint.org/bugs.html claims that automake makes the difference…

comment:7 in reply to:  6 Changed 3 months ago by ballapete (Peter Dyballa)

I meant autoconf!

comment:8 Changed 3 months ago by ballapete (Peter Dyballa)

With autoconf264 the build process happens to find that C header file:

/Applications/Xcode.app/Contents/Developer/usr/bin/make  all-recursive
Making all in src
Compiling cgrammar.c...
Compiling cscanner.c...
Compiling mtscanner.c...
Compiling mtgrammar.c...
Compiling llgrammar.c...
Compiling signature.c...
Compiling cppmain.c...

but it fails later:

Compiling importNodeList.c...
Compiling tokentable.c...
Compiling scan.c...
In file included from scan.c:49:
Headers/scan.h:11:29: error: unknown type name 'YYSTYPE'
extern unsigned int lsllex (YYSTYPE *p_lval);
                            ^
scan.c:61:22: error: unknown type name 'YYSTYPE'
unsigned int lsllex (YYSTYPE *lval)
                     ^
2 errors generated.
make[2]: *** [scan.o] Error 1

comment:9 Changed 3 months ago by ballapete (Peter Dyballa)

An eMail containing a bug report (to info@…) returned. splint seems to be dead.

Note: See TracTickets for help on using tickets.