Opened 10 years ago

Closed 10 years ago

#22417 closed defect (fixed)

tmux attach occasionally causes server to exit

Reported by: dimavs@… Owned by: tobypeterson
Priority: Normal Milestone:
Component: ports Version: 1.8.1
Keywords: Cc:
Port: tmux

Description

OS X 10.6.2

$ tmux [detached] $ tmux ls 0: 1 windows (created Sun Nov 8 11:53:41 2009) [141x42] $ tmux attach fatal: dispatch_imsg: imsg_read failed

I've tried to build 1.1 from sources and it works fine

Change History (8)

comment:1 Changed 10 years ago by dimavs@…

Cc: dimavs@… added

Cc Me!

comment:2 Changed 10 years ago by dimavs@…

$ tmux
[detached]
$ tmux ls
0: 1 windows (created Sun Nov 8 11:53:41 2009) [141x42]
$ tmux attach
fatal: dispatch_imsg: imsg_read failed

comment:3 Changed 10 years ago by tobypeterson

I've seen this once or twice, but I can't reproduce with any regularity.

comment:4 Changed 10 years ago by dimavs@…

It crashes all the time for me.

Portfile says:
platform darwin 9 {

patchfiles-delete server.c.diff

}

I am not sure, but I think this patch should be disable for Snow Leopard too, everything worked fine for me after I removed it.

comment:5 Changed 10 years ago by jmroot (Joshua Root)

Cc: dimavs@… removed
Keywords: tmux removed
Owner: changed from macports-tickets@… to toby@…
Port: tmux added

comment:6 Changed 10 years ago by tobypeterson

Patch is necessary, without it tmux is pretty useless. It's probably breaking something, will have to investigate further.

comment:7 Changed 10 years ago by tobypeterson

Summary: tmux 1.1 attach crashes servertmux attach occasionally causes server to exit

Not a crash.

comment:8 Changed 10 years ago by tobypeterson

Resolution: fixed
Status: newclosed

closed as of r60347

Note: See TracTickets for help on using tickets.