Opened 11 years ago

Closed 11 years ago

#22452 closed defect (fixed)

libsdl_mixer 1.2.10_0 fails to build on 10.5

Reported by: bug@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.8.1
Keywords: libsdl_mixer Cc: mklein-de (Michael Klein), david.niedzielski@…
Port: libsdl_mixer

Description (last modified by ryandesign (Ryan Schmidt))

$ sudo port install libsdl_mixer

http://pastebin.com/f3ff342b4

$ sudo port -d install libsdl_mixer

http://pastebin.com/md065a6c

Attachments (2)

patch-leopard.diff (643 bytes) - added by mklein-de (Michael Klein) 11 years ago.
patch posted on mailing list
Portfile.diff (659 bytes) - added by mklein-de (Michael Klein) 11 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 11 years ago by david.niedzielski@…

FYI, the problem is described in http://article.gmane.org/gmane.comp.lib.sdl/44798, and a patch is referenced to address compilation on 10.5.

Changed 11 years ago by mklein-de (Michael Klein)

Attachment: patch-leopard.diff added

patch posted on mailing list

Changed 11 years ago by mklein-de (Michael Klein)

Attachment: Portfile.diff added

comment:2 Changed 11 years ago by mklein-de (Michael Klein)

Cc: michael.klein@… added

Cc Me!

comment:3 Changed 11 years ago by david.niedzielski@…

Cc: david.niedzielski@… added

Cc Me!

comment:4 Changed 11 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)

comment:5 Changed 11 years ago by blb@…

Resolution: fixed
Status: newclosed
Summary: libsdl_mixer 1.2.10_0 fails to buildlibsdl_mixer 1.2.10_0 fails to build on 10.5

Fixed in r60401, thanks for the patch.

Note: See TracTickets for help on using tickets.