Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#22619 closed defect (invalid)

Actions following ticket 22612, fresh install on new machine etc.

Reported by: aszy@… Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone:
Component: ports Version: 1.8.1
Keywords: Cc:
Port: xorg-libX11

Description

Per the comment that closed ticket # 22612 , I followed the instructions found at : http://trac.macports.org/wiki/Migration .

port installed > myports.txt
sudo port clean all
sudo port -f uninstall installed

I now have nothing at all that works, as expected all installed apps are gone. I then followed the instructions to install only what i wanted, first being the MacPorts X11 server. I received this: ( showing only the Activatings and the final errors )

--->  Activating expat @2.0.1_0
--->  Activating zlib @1.2.3_3
--->  Activating freetype @2.3.9_1+macosx
--->  Activating gperf @3.0.4_0
--->  Activating libiconv @1.13_0
--->  Activating fontconfig @2.7.3_0+macosx
--->  Activating pkgconfig @0.23_1
--->  Activating groff @1.20.1_1
--->  Activating xorg-bigreqsproto @1.1.0_0
--->  Activating xorg-inputproto @2.0_0
--->  Activating xorg-kbproto @1.0.4_0
--->  Activating xorg-xproto @7.0.16_0
--->  Activating xorg-libXau @1.0.5_0
--->  Activating xorg-libXdmcp @1.0.3_0
--->  Activating xorg-util-macros @1.3.0_0
--->  Activating xorg-xcmiscproto @1.2.0_0
--->  Activating xorg-xextproto @7.1.1_0
--->  Activating xorg-xf86bigfontproto @1.2.0_0
--->  Activating xorg-xtrans @1.2.5_0
--->  Activating ncursesw @5.7_0+darwin_10
--->  Activating ncurses @5.7_0+darwin_10
--->  Activating gettext @0.17_4
--->  Activating perl5.8 @5.8.9_3
--->  Activating perl5 @5.8.9_0
--->  Activating p5-locale-gettext @1.05_0
--->  Activating help2man @1.36.4_1
--->  Activating m4 @1.4.13_0
--->  Activating autoconf @2.64_2
--->  Activating automake @1.11_0
--->  Activating libpixman @0.16.2_0
--->  Activating libtool @2.2.6b_0
--->  Activating glut @3.7_3
--->  Activating makedepend @1.0.2_0
--->  Activating xorg-dri2proto @2.1_0
--->  Activating xorg-glproto @1.4.10_0
--->  Activating xorg-fixesproto @4.1.1_0
--->  Building xorg-libX11
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_xorg-libX11/work/libX11-1.3.2" && /usr/bin/make -j2 all V=1 " returned error 2
Command output: Making all in zh_CN.gbk
make[2]: Nothing to be done for `all'.
Making all in zh_CN.UTF-8
make[2]: Nothing to be done for `all'.
Making all in zh_HK.big5
make[2]: Nothing to be done for `all'.
Making all in zh_HK.big5hkscs
make[2]: Nothing to be done for `all'.
Making all in zh_HK.UTF-8
make[2]: Nothing to be done for `all'.
Making all in zh_TW
make[2]: Nothing to be done for `all'.
Making all in zh_TW.big5
make[2]: Nothing to be done for `all'.
Making all in zh_TW.UTF-8
make[2]: Nothing to be done for `all'.
make[2]: Nothing to be done for `all-am'.
Making all in man
Making all in xkb
make[2]: Nothing to be done for `all'.
make[2]: Nothing to be done for `all-am'.
Making all in specs
Making all in libX11
/opt/local/bin/groff -Tps -e -t -ms -dxV="libX11 1.3.2" -I. ../../specs/macros.t libX11.ms 2> index.libX11.ps.raw > libX11.ps
/opt/local/bin/ps2pdf libX11.ps libX11.pdf
make[2]: /opt/local/bin/ps2pdf: No such file or directory
make[2]: *** [libX11.pdf] Error 1
rm libX11.ps
make[1]: *** [all-recursive] Error 1
make: *** [all-recursive] Error 1

Error: The following dependencies failed to build: mesa xorg-libXfixes xorg-libX11 xorg-libXi xorg-libXext xorg-libXmu xorg-libXt xorg-libsm xorg-libice xinit mkfontdir mkfontscale bzip2 xorg-libfontenc xauth xrdb xset xorg-libXfontcache xorg-fontcacheproto xorg-libXp xorg-printproto xorg-libXxf86misc xorg-xf86miscproto xkeyboard-config intltool gnome-common p5-getopt-long p5-pathtools p5-scalar-list-utils p5-xml-parser xkbcomp xorg-libxkbfile xorg-applewmproto xorg-damageproto xorg-fonts font-adobe-100dpi bdftopcf xorg-libXfont xorg-fontsproto xorg-font-util font-adobe-75dpi font-adobe-utopia-100dpi font-adobe-utopia-75dpi font-adobe-utopia-type1 font-alias font-arabic-misc font-bh-100dpi font-bh-75dpi font-bh-lucidatypewriter-100dpi font-bh-lucidatypewriter-75dpi font-bh-ttf font-bh-type1 font-bitstream-100dpi font-bitstream-75dpi font-bitstream-speedo font-bitstream-type1 font-cronyx-cyrillic font-cursor-misc font-daewoo-misc font-dec-misc font-ibm-type1 font-isas-misc font-jis-misc font-micro-misc font-misc-cyrillic font-misc-ethiopic font-misc-meltho font-misc-misc font-mutt-misc font-schumacher-misc font-screen-cyrillic font-sony-misc font-sun-misc font-winitzki-cyrillic font-xfree86-type1 xorg-encodings xorg-libAppleWM xorg-randrproto xorg-recordproto xorg-renderproto xorg-resourceproto xorg-scrnsaverproto xorg-videoproto xorg-xineramaproto
Error: Status 1 encountered during processing.

I then tried the first item in the failure list, mesa, to try a solo install.

Gulliver:~ aszy$ sudo port install mesa
Password:
--->  Computing dependencies for mesa
--->  Building xorg-libX11
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_xorg-libX11/work/libX11-1.3.2" && /usr/bin/make -j2 all V=1 " returned error 2
Command output: Making all in zh_CN.gbk
make[2]: Nothing to be done for `all'.
Making all in zh_CN.UTF-8
make[2]: Nothing to be done for `all'.
Making all in zh_HK.big5
make[2]: Nothing to be done for `all'.
Making all in zh_HK.big5hkscs
make[2]: Nothing to be done for `all'.
Making all in zh_HK.UTF-8
make[2]: Nothing to be done for `all'.
Making all in zh_TW
make[2]: Nothing to be done for `all'.
Making all in zh_TW.big5
make[2]: Nothing to be done for `all'.
Making all in zh_TW.UTF-8
make[2]: Nothing to be done for `all'.
make[2]: Nothing to be done for `all-am'.
Making all in man
Making all in xkb
make[2]: Nothing to be done for `all'.
make[2]: Nothing to be done for `all-am'.
Making all in specs
Making all in libX11
/opt/local/bin/groff -Tps -e -t -ms -dxV="libX11 1.3.2" -I. ../../specs/macros.t libX11.ms 2> index.libX11.ps.raw > libX11.ps
/opt/local/bin/ps2pdf libX11.ps libX11.pdf
make[2]: /opt/local/bin/ps2pdf: No such file or directory
make[2]: *** [libX11.pdf] Error 1
rm libX11.ps
make[1]: *** [all-recursive] Error 1
make: *** [all-recursive] Error 1

Error: The following dependencies failed to build: xorg-libXfixes xorg-libX11 xorg-libXi xorg-libXext xorg-libXmu xorg-libXt xorg-libsm xorg-libice
Error: Status 1 encountered during processing.

What next good folks?

Attachments (2)

Terminal Saved Output.txt (865.6 KB) - added by aszy@… 12 years ago.
config.log (53.8 KB) - added by aszy@… 12 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 12 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to jeremyhu@…
Port: xorg-libX11 added

comment:2 Changed 12 years ago by jeremyhu (Jeremy Huddleston Sequoia)

/opt/local/bin/ps2pdf: No such file or directory

That's the problem. Please attach the full log where you build xorg-libX11.

sudo port -v clean xorg-libX11
sudo port -v install xorg-libX11

The configure.ac looks right, so it looks like you deleted ps2pdf after configuring libX11:

AC_ARG_VAR([PS2PDF], [Path to a ps2pdf executable])
AC_PATH_PROGS([PS2PDF], [ps2pdf], [none], [$PATH:/usr/gnu/bin])

comment:3 Changed 12 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Also attach the config.log file that is in the srcdir.

Changed 12 years ago by aszy@…

Attachment: Terminal Saved Output.txt added

Changed 12 years ago by aszy@…

Attachment: config.log added

comment:4 in reply to:  3 Changed 12 years ago by aszy@…

Replying to jeremyhu@…:

Also attach the config.log file that is in the srcdir.

I have attached the two log dumps that you have requested. Thank you JMR for telling me that I can attach - I just could not find the buttons. I ran

sudo port -f uninstall installed

and then tried the xorg-server install. At no time did I single out any file for deletion ( e.g. ps2pdf ). At this point, I am just following directions - mostly blindly. Thanks for your patience. Al

comment:5 Changed 12 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: invalid
Status: newclosed

1) that config.log is not for libX11. Attach the config.log for libX11 2) Your terminal output shows a successful install of libX11.

So there's no bug here.

comment:6 in reply to:  5 ; Changed 12 years ago by aszy@…

Replying to jeremyhu@…:

1) that config.log is not for libX11. Attach the config.log for libX11 2) Your terminal output shows a successful install of libX11.

So there's no bug here.

Well, I am going to need a bit of help here.. Where do I find the config.log for libX11? I can "Find" no "config.log" other than the one I have attached. I do not find any item in the Console Logs for libX11 except for the two entries that read :

11/20/09 3:09:52 PM	sudo[79497]	aszy : TTY=ttys000 ; PWD=/Users/aszy ; USER=root ; COMMAND=/opt/local/bin/port -v clean xorg-libX11
11/20/09 3:10:17 PM	sudo[79574]	aszy : TTY=ttys000 ; PWD=/Users/aszy ; USER=root ; COMMAND=/opt/local/bin/port -v install xorg-libX11

In Terminal, I can 'locate' the following:

Last login: Fri Nov 20 16:22:57 on console
Gulliver:~ aszy$ locate config.log
/opt/local/var/db/dports/sources/rsync.rsync.darwinports.org_dpupdate1/base/config.log
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_pkgconfig/work/pkg-config-0.23/config.log
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_pkgconfig/work/pkg-config-0.23/glib-1.2.10/config.log
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_games_fbg/work/fbg-0.9/config.log
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_games_lincity-ng/work/lincity-ng-1.1.0/config.log
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_ghex/work/ghex-2.6.0/config.log
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_gimp2/work/gimp-2.6.6/config.log
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_xsane/work/xsane-0.996/config.log
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py-gobject/work/pygobject-2.18.0/config.log
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py-gtk2/work/pygtk-2.12.1/config.log
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_fox/work/fox-1.6.28/config.log
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_xorg-renderproto/work/renderproto-0.9.3/config.log

The first one being the one I attached. Standing by...

comment:7 in reply to:  6 ; Changed 12 years ago by aszy@…

As the last portion was successful , I decided to try again to

sudo port install xorg-server

Quite a successful run right up until the end.

--->  Activating xorg-libXfixes @4.0.4_0
--->  Activating xorg-libXext @1.1.1_0
--->  Activating xorg-libXi @1.3_0
--->  Activating xorg-libice @1.0.6_0
--->  Activating xorg-libsm @1.1.1_0
--->  Activating xorg-libXt @1.0.7_0
--->  Activating xorg-libXmu @1.0.5_0
--->  Activating mesa @7.6_1+hw_render
--->  Activating bzip2 @1.0.5_3+darwin
--->  Activating xorg-libfontenc @1.0.5_0
--->  Activating mkfontscale @1.0.7_0
--->  Activating mkfontdir @1.0.5_0
--->  Activating xauth @1.0.4_0
--->  Activating xrdb @1.0.6_0
--->  Activating xorg-fontcacheproto @0.1.3_0
--->  Activating xorg-libXfontcache @1.0.5_0
--->  Activating xorg-printproto @1.0.4_0
--->  Activating xorg-libXp @1.0.0_3
--->  Activating xorg-xf86miscproto @0.9.3_0
--->  Activating xorg-libXxf86misc @1.0.2_0
--->  Activating xset @1.1.0_0
--->  Activating xinit @1.2.0_0
--->  Activating gnome-common @2.26.0_0
--->  Activating p5-getopt-long @2.38_0
--->  Activating p5-pathtools @3.30_0
--->  Activating p5-scalar-list-utils @1.21_0
--->  Activating p5-xml-parser @2.36_0
--->  Activating intltool @0.40.6_0
--->  Activating xorg-libxkbfile @1.0.6_0
--->  Activating xkbcomp @1.1.1_0
--->  Activating xkeyboard-config @1.7_0
--->  Activating xorg-applewmproto @1.4.1_0
--->  Activating xorg-damageproto @1.2.0_0
--->  Activating xorg-fontsproto @2.1.0_0
--->  Activating xorg-libXfont @1.4.1_0
--->  Activating bdftopcf @1.0.2_0
--->  Activating xorg-font-util @1.1.1_0
--->  Activating font-adobe-100dpi @1.0.1_0
--->  Activating font-adobe-75dpi @1.0.1_0
--->  Activating font-adobe-utopia-100dpi @1.0.2_0
--->  Activating font-adobe-utopia-75dpi @1.0.2_0
--->  Activating font-adobe-utopia-type1 @1.0.2_0
--->  Activating font-alias @1.0.1_0
--->  Activating font-arabic-misc @1.0.1_0
--->  Activating font-bh-100dpi @1.0.1_0
--->  Activating font-bh-75dpi @1.0.1_0
--->  Activating font-bh-lucidatypewriter-100dpi @1.0.1_0
--->  Activating font-bh-lucidatypewriter-75dpi @1.0.1_0
--->  Activating font-bh-ttf @1.0.1_0
--->  Activating font-bh-type1 @1.0.1_0
--->  Activating font-bitstream-100dpi @1.0.1_0
--->  Activating font-bitstream-75dpi @1.0.1_0
--->  Activating font-bitstream-speedo @1.0.1_0
--->  Activating font-bitstream-type1 @1.0.1_0
--->  Activating font-cronyx-cyrillic @1.0.1_0
--->  Activating font-cursor-misc @1.0.1_0
--->  Activating font-daewoo-misc @1.0.1_0
--->  Activating font-dec-misc @1.0.1_0
--->  Activating font-ibm-type1 @1.0.1_0
--->  Activating font-isas-misc @1.0.1_0
--->  Activating font-jis-misc @1.0.1_0
--->  Activating font-micro-misc @1.0.1_0
--->  Activating font-misc-cyrillic @1.0.1_0
--->  Activating font-misc-ethiopic @1.0.1_0
--->  Activating font-misc-meltho @1.0.1_0
--->  Activating font-misc-misc @1.1.0_0
--->  Activating font-mutt-misc @1.0.1_0
--->  Activating font-schumacher-misc @1.1.0_0
--->  Activating font-screen-cyrillic @1.0.2_0
--->  Activating font-sony-misc @1.0.1_0
--->  Activating font-sun-misc @1.0.1_0
--->  Activating font-winitzki-cyrillic @1.0.1_0
--->  Activating font-xfree86-type1 @1.0.2_0
--->  Activating xorg-encodings @1.0.3_0
--->  Activating xorg-fonts @20090102_1
--->  Activating xorg-libAppleWM @1.4.0_0
--->  Activating xorg-randrproto @1.3.1_0
--->  Activating xorg-recordproto @1.14_0
--->  Activating xorg-renderproto @0.11_0
--->  Activating xorg-resourceproto @1.1.0_0
--->  Activating xorg-scrnsaverproto @1.2.0_0
--->  Activating xorg-videoproto @2.3.0_0
--->  Activating xorg-xineramaproto @1.2_0


--->  Fetching xorg-server
--->  Attempting to fetch xorg-server-1.7.1.901.tar.bz2 from http://xorg.freedesktop.org/archive/individual/xserver/
--->  Verifying checksum(s) for xorg-server
--->  Extracting xorg-server
--->  Applying patches to xorg-server
--->  Configuring xorg-server
Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_xorg-server/work/xorg-server-1.7.1.901" && ./configure --prefix=/opt/local --with-apple-applications-dir=/Applications/MacPorts --with-fontdir=/opt/local/share/fonts --with-launchd-id-prefix=org.macports --without-dtrace " returned error 1
Command output: checking Whether to build pdf documentation... no
checking whether to build Xquartz... yes
checking for DBUS... no
checking for HAL... no
checking for glibc...... no
checking for clock_gettime... no
checking for clock_gettime in -lrt... no
checking for a useful monotonic clock ...... no
checking for XLIB... yes
checking for GL... yes
checking for DRI2PROTO... yes
checking for strcasecmp... yes
checking for strncasecmp... yes
checking for strcasestr... (cached) yes
checking for XDMCP... yes
checking for XdmcpWrap in -lXdmcp... yes
checking for GLIB... no
checking whether the linker supports -wrap... no
checking for SHA1Init in -lmd... no
checking for XSERVERCFLAGS... configure: error: Package requirements (randrproto >= 1.2.99.3 renderproto >= 0.11 fixesproto >= 4.1 damageproto >= 1.1 xcmiscproto >= 1.2.0 xextproto >= 7.0.99.3 xproto >= 7.0.13 xtrans >= 1.2.2 bigreqsproto >= 1.1.0 fontsproto inputproto >= 1.9.99.902 kbproto >= 1.0.3 videoproto scrnsaverproto >= 1.1 resourceproto xineramaproto xkbfile xfont xau pixman-1 >= 0.15.20 xdmcp openssl) were not met:

No package 'openssl' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables XSERVERCFLAGS_CFLAGS
and XSERVERCFLAGS_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


Error: Status 1 encountered during processing.
Gulliver:~ aszy$ 

Looks like it's closer, but no cigar. Al

comment:8 in reply to:  7 Changed 12 years ago by aszy@…

After manually installing openssl

sudo port install openssl

then following up with third try at

sudo port install xorg-server

I now have a visible icon and application in /Application/MacPorts/X11

Next step is quartz-wm. al I am not sure what and why this thread became successful, but if you have an inkling, great!

comment:9 Changed 12 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Well seeing as how this bug was about libX11 not installing, and you were able to install it by doing:

sudo port -v clean xorg-libX11
sudo port -v install xorg-libX11

I don't really see the need to get your config.log

So a 'sudo port -v install openssl' to get openssl...

Note: See TracTickets for help on using tickets.