Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#22626 closed submission (fixed)

mpeg4ip reinstatement to get back mp4creator among others (port included)

Reported by: reid@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: mpeg4ip

Description

When mpeg4ip was turned into a stub, several tools went missing from Macports. Please find attached a port with patches that allow it to compile on Snow Leopard. I've listed myself as maintainer. But, if that's a problem, then (of course) please change that.

I've tested mp4creator on several files and it works as advertised. Please test, comment and commit if appropriate.

Attachments (1)

mpeg4ip.tgz (25.8 KB) - added by reid@… 8 years ago.
re-upload of tgz

Download all attachments as: .zip

Change History (11)

comment:1 Changed 8 years ago by jmroot (Joshua Root)

  • Port mpeg4ip added
  • Type changed from defect to submission
  • Version 1.8.1 deleted

comment:2 Changed 8 years ago by fclaire@…

Thanks for restoring mp4creator. I did a selfupdate but mpeg4ip still doesn't contains mp4creator.

I guess it's possible to install it using the mpeg4ip.tgz you provided as attachment but I don't know how. Could anyone give me a hint ?

comment:3 Changed 8 years ago by reid@…

Download the tgz. Then extract it somewhere. Open a terminal and enter the directory with the Portfile. Then type:

sudo port -v install

That should do it.

comment:4 Changed 8 years ago by fclaire@…

It worked ! Thanks a lot !!

comment:5 Changed 8 years ago by macports@…

Has something happened to the .tgz file attached here? For some reason it's just a HTML file I get as a result whenever I try to download it now. Is mpeg4ip being updated to include mp4creator?

Changed 8 years ago by reid@…

re-upload of tgz

comment:6 Changed 8 years ago by reid@…

Re-upload apparently didn't work even though I tested the file before uploading. I'm at a loss... If I can email it anywhere to get it test/committed, just let me know.

comment:7 Changed 8 years ago by reid@…

tgz has been uploaded here:

http://code.google.com/p/mkvtops3mp4/downloads/list

tgz decompresses as it should.

comment:8 Changed 8 years ago by jmroot (Joshua Root)

The attachment is fine, you're probably seeing a Safari bug.

comment:9 Changed 8 years ago by jmroot (Joshua Root)

  • Resolution set to fixed
  • Status changed from new to closed

comment:10 Changed 8 years ago by reid@…

Beauty! Thank you!

Note: See TracTickets for help on using tickets.