Opened 11 years ago

Closed 11 years ago

#22890 closed defect (invalid)

hdf5-18 @1.8.4+universal fails to build on ppc

Reported by: tenomoto (Takeshi Enomoto) Owned by: mmol@…
Priority: Normal Milestone:
Component: ports Version: 1.8.1
Keywords: Cc:
Port: hdf5-18

Description

The error message is as follows.

DEBUG: universal: merge: /opt/local/lib/libhdf5.dylib is a link
DEBUG: universal: merge: merging /opt/local/lib/libhdf5.la from /opt/local/var/macports/build/_Library_MacPorts_ports_science_hdf5-18/work/destroot-ppc and /opt/local/var/macports/build/_Library_MacPorts_ports_science_hdf5-18/work/destroot-ppc64
/opt/local/var/macports/build/_Library_MacPorts_ports_science_hdf5-18/work/destroot-ppc//opt/local/lib/libhdf5.la /opt/local/var/macports/build/_Library_MacPorts_ports_science_hdf5-18/work/destroot-ppc64//opt/local/lib/libhdf5.la differ: char 509, line 20
/usr/bin/lipo: can't figure out the architecture type of: /opt/local/var/macports/build/_Library_MacPorts_ports_science_hdf5-18/work/destroot-ppc//opt/local/lib/libhdf5.la
Error: Target org.macports.destroot returned: /opt/local/lib/libhdf5.la differs in /opt/local/var/macports/build/_Library_MacPorts_ports_science_hdf5-18/work/destroot-ppc and /opt/local/var/macports/build/_Library_MacPorts_ports_science_hdf5-18/work/destroot-ppc64 and cannot be merged
DEBUG: Backtrace: /opt/local/lib/libhdf5.la differs in /opt/local/var/macports/build/_Library_MacPorts_ports_science_hdf5-18/work/destroot-ppc and /opt/local/var/macports/build/_Library_MacPorts_ports_science_hdf5-18/work/destroot-ppc64 and cannot be merged
    while executing
"$procedure $targetname"
Warning: the following items did not execute (for hdf5-18): org.macports.destroot
DEBUG: invalid command name "::ui_init"
    while executing
"::ui_init error Error: stderr debuglog {Target org.macports.destroot returned: /opt/local/lib/libhdf5.la differs in /opt/local/var/macports/build/_Lib..."
    ("eval" body line 1)
    invoked from within
"eval ::ui_init $priority $prefix $channels($priority) $args"
    ("uplevel" body line 2)
    invoked from within
"uplevel 1 $body"
Error: Unable to upgrade port: 1

Change History (2)

comment:1 Changed 11 years ago by jmroot (Joshua Root)

This is often caused by dependencies not being universal.

comment:2 Changed 11 years ago by tenomoto (Takeshi Enomoto)

Resolution: invalid
Status: newclosed

You are right.

Note: See TracTickets for help on using tickets.