Opened 11 years ago

Closed 10 years ago

#22987 closed defect (duplicate)

gimp2: Dynamic session lookup supported but failed

Reported by: christophe.haro@… Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 1.8.1
Keywords: Cc: jasperfrumau@…
Port: gimp2

Description (last modified by mf2k (Frank Schima))

I just install gimp2. When I launch it, I receive number of messages :

callisto:~ haro$ gimp &
[1] 28797
callisto:~ haro$ Xlib:  extension "RANDR" missing on display "/tmp/launch-f2pPfK/:0".
Dynamic session lookup supported but failed: launchd did not provide a socket path, verify that org.freedesktop.dbus-session.plist is loaded!
Dynamic session lookup supported but failed: launchd did not provide a socket path, verify that org.freedesktop.dbus-session.plist is loaded!
Not enough memory
dyld: Library not loaded: /opt/local/lib/libjpeg.62.dylib
  Referenced from: /opt/local/lib/libgnomecanvas-2.0.dylib
  Reason: image not found

(gimp:28797): LibGimpBase-WARNING **: gimp: gimp_wire_read(): error

(gimp:28797): Gtk-WARNING **: Impossible de trouver le type de moniteur de répertoire local par défaut
...
(same error n times)
...
(gimp:28797): Gtk-CRITICAL **: gtk_icon_info_load_icon: assertion `icon_info != NULL' failed
... (and so on)

After issuing the command :

sudo launchctl load -w /Library/LaunchDaemons/org.freedesktop.dbus-system.plist

as it was suggested by ticket #20645, the command ps aux | grep dbus do nothing then replaying :

499 s000  R+     0:00.00 grep dbus

I do no figure out how to correct such a situation. Can someone help me ? Is that a serious problem ? What am I missing ?

callisto:~ haro$ uname -a
Darwin callisto.local 9.8.0 Darwin Kernel Version 9.8.0: Wed Jul 15 16:55:01 PDT 2009; root:xnu-1228.15.4~1/RELEASE_I386 i386
gimp2 @2.6.7

Thanks,

Christophe.HARO@…

Change History (10)

comment:1 Changed 11 years ago by mf2k (Frank Schima)

Description: modified (diff)

comment:2 Changed 11 years ago by mf2k (Frank Schima)

Try rebuilding libgnomecanvas.

sudo port -f uninstall libgnomecanvas
sudo port install libgnomecanvas

comment:3 in reply to:  2 Changed 11 years ago by christophe.haro@…

Replying to macsforever2000@…:

Try rebuilding libgnomecanvas.

sudo port -f uninstall libgnomecanvas
sudo port install libgnomecanvas

Thanks, but it does not work.

After rebuilding libgnomecanvas, the errors are :

callisto:~ haro$ gimp 
Xlib:  extension "RANDR" missing on display "/tmp/launch-PafXZJ/:0".
Dynamic session lookup supported but failed: launchd did not provide a socket path, verify that org.freedesktop.dbus-session.plist is loaded!
Dynamic session lookup supported but failed: launchd did not provide a socket path, verify that org.freedesktop.dbus-session.plist is loaded!
Not enough memory
Dynamic session lookup supported but failed: launchd did not provide a socket path, verify that org.freedesktop.dbus-session.plist is loaded!
Dynamic session lookup supported but failed: launchd did not provide a socket path, verify that org.freedesktop.dbus-session.plist is loaded!
Dynamic session lookup supported but failed: launchd did not provide a socket path, verify that org.freedesktop.dbus-session.plist is loaded!
Dynamic session lookup supported but failed: launchd did not provide a socket path, verify that org.freedesktop.dbus-session.plist is loaded!
Erreur GConf : Le contact du serveur de configuration a échoué ; causes possibles : vous n'avez pas activé le réseau TCP/IP pour ORBit ou des verrous NFS non valides existent suite à un blocage du système. Voir http://projects.gnome.org/gconf/ pour plus d'informations. (Détails -  1: La connexion à la session a échoué : Not enough memory)

Sorry !

Christophe.HARO@…

comment:4 Changed 11 years ago by jmroot (Joshua Root)

Port: dbus added
Resolution: duplicate
Status: newclosed

comment:5 in reply to:  4 Changed 11 years ago by christophe.haro@…

Replying to jmr@…:

#20505

I'm sorry to inform you that ticket #20505 do not solve the whole problem.

Here you can find messages when I launch gimp (gimp2 2.6.7) :

callisto:~ haro$ gimp Xlib: extension "RANDR" missing on display "/tmp/launch-PafXZJ/:0".
(gimp:17930): Gtk-WARNING **: Impossible de trouver le type de moniteur de répertoire local par défaut
(gimp:17930): Gtk-WARNING **: Impossible de trouver le type de moniteur de répertoire local par défaut
(gimp:17930): Gtk-CRITICAL **: gtk_icon_info_load_icon: assertion `icon_info != NULL' failed
(gimp:17930): Gtk-CRITICAL **: gtk_icon_info_load_icon: assertion `icon_info != NULL' failed
(gimp:17930): Gtk-WARNING **: Impossible de trouver le type de moniteur de répertoire local par défaut
(gimp:17930): Gtk-CRITICAL **: gtk_icon_info_load_icon: assertion `icon_info != NULL' failed
(gimp:17930): Gtk-WARNING **: Impossible de trouver le type de moniteur de répertoire local par défaut
(gimp:17930): Gtk-CRITICAL **: gtk_icon_info_load_icon: assertion `icon_info != NULL' failed
(gimp:17930): Gtk-CRITICAL **: gtk_icon_info_load_icon: assertion `icon_info != NULL' failed
(gimp:17930): Gtk-WARNING **: Impossible de trouver le type de moniteur de répertoire local par défaut
(gimp:17930): Gtk-CRITICAL **: gtk_icon_info_load_icon: assertion `icon_info != NULL' failed
(gimp:17930): Gtk-WARNING **: Impossible de trouver le type de moniteur de répertoire local par défaut
(file-jpeg:18120): GLib-WARNING **: g_set_prgname() called multiple times Xlib: extension "RANDR" missing on display "/tmp/launch-PafXZJ/:0".

Ok for missing extension "RANDR" , but how can I fix << (gimp:17930): Gtk-CRITICAL : gtk_icon_info_load_icon: assertion `icon_info != NULL' failed >> an other errors ?

Thanks,

Christophe.HARO@…

comment:6 Changed 11 years ago by jasperfrumau@…

Cc: jasperfrumau@… added

Cc Me!

comment:7 Changed 11 years ago by jasperfrumau@…

Resolution: duplicate
Status: closedreopened

I experience the same error using:

jaspersmbp:~ jasper$ port
MacPorts 1.9.1
Entering interactive mode... ("help" for help, "quit" to quit)

When I start up Gimp I get:

jaspersmbp:~ jasper$ gimp

(gimp:865): Gtk-WARNING **: Locale not supported by C library.
	Using the fallback 'C' locale.
Xlib:  extension "RANDR" missing on display "/tmp/launch-Cr8c8R/org.x:0".

(gimp:865): Gtk-CRITICAL **: gtk_icon_info_load_icon: assertion `icon_info != NULL' failed

(gimp:865): Gtk-CRITICAL **: gtk_icon_info_load_icon: assertion `icon_info != NULL' failed

(gimp:865): Gtk-CRITICAL **: gtk_icon_info_load_icon: assertion `icon_info != NULL' failed

Then RANDR error is common and is not an issue and cannot be solved apparently. But the gtk_icon _info_load might be..

comment:8 Changed 11 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to devans@…
Port: gimp2 added; dbus removed
Status: reopenednew

That really doesn't resemble the problem in the ticket description at all, but I'll let devans decide whether it's relevant. Does any of this actually affect the operation of the application? The RANDR line certainly doesn't; it's not even an error.

comment:9 Changed 10 years ago by jmroot (Joshua Root)

Summary: (Yet a new report on an old error : ) gimp2gimp2: missing icons causing assertion failures

comment:10 Changed 10 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed
Summary: gimp2: missing icons causing assertion failuresgimp2: Dynamic session lookup supported but failed

The original problem reported here really is a duplicate of #20505. The other error mentioned later on in the comments is covered by #24460.

Note: See TracTickets for help on using tickets.