Opened 11 years ago

Closed 10 years ago

#22997 closed enhancement (duplicate)

no_atlas variant for Tiger/PPC, please

Reported by: yaseppochi (Stephen J. Turnbull) Owned by: stechert@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: haspatch Cc: tenomoto (Takeshi Enomoto), jjstickel@…, todmorrison (Tod Morrison)
Port: octave

Description

The atlas port seems to be very fragile, and does not seem to be actively supported, at least on Tiger/PPC.

A no-atlas variant for octave, if the octave build infrastructure supports it, would allow such hosts to upgrade octave, and revert to using atlas when (or if) it is fixed.

WDYT?

Attachments (2)

octave-portfile.diff (1.7 KB) - added by jmroot (Joshua Root) 11 years ago.
patch from #25664
octave-portfile.2.diff (1.4 KB) - added by todmorrison (Tod Morrison) 11 years ago.
Corrected Portfile patch

Download all attachments as: .zip

Change History (16)

comment:1 Changed 11 years ago by mf2k (Frank Schima)

Cc: stechert@… added
Owner: changed from macports-tickets@… to alakazam@…
Version: 1.8.99

comment:2 Changed 11 years ago by tenomoto (Takeshi Enomoto)

See also #21797.

comment:3 Changed 11 years ago by tenomoto (Takeshi Enomoto)

Cc: takeshi@… added

Cc Me!

comment:4 Changed 11 years ago by tenomoto (Takeshi Enomoto)

Cc: takeshi@… removed

Cc Me!

comment:5 Changed 11 years ago by tenomoto (Takeshi Enomoto)

Cc: takeshi@… added

Cc Me!

comment:6 Changed 11 years ago by jjstickel@…

Cc: jjstickel@… added

Cc Me!

comment:7 Changed 11 years ago by jjstickel@…

See also ticket #22936.

comment:8 Changed 11 years ago by jameskyle@…

Atlas is being actively supported, though I was away for a month.

Besides the initial speed bumps in the Snow Leopard transition that everyone experienced, most of the bugs I've received were for the G4 variant of PPC (which I do not have a test system for) and involved lack of detection (which was actually an upstream problem). A patch was submitted and applied.

There are currently no open tickets for atlas, if you're experiencing issues that have to do with atlas itself, please submit a ticket so they may be resolved.

cheers,

-james

comment:9 in reply to:  8 Changed 11 years ago by jjstickel@…

Replying to jameskyle@…:

There are currently no open tickets for atlas, if you're experiencing issues that have to do with atlas itself, please submit a ticket so they may be resolved.

Ticket #22936 is an atlas ticket. Although the original ticket mentions numpy, I am now sure that the problem is with atlas, not numpy.

comment:10 Changed 11 years ago by alakazam@…

Owner: alakazam@… deleted

comment:11 Changed 11 years ago by jmroot (Joshua Root)

Cc: stechert@… removed
Owner: set to stechert@…

Changed 11 years ago by jmroot (Joshua Root)

Attachment: octave-portfile.diff added

patch from #25664

comment:12 Changed 11 years ago by jmroot (Joshua Root)

Cc: todmorrison@… added
Keywords: haspatch added

comment:13 Changed 11 years ago by jmroot (Joshua Root)

Beware that the patch is reversed and changes the Id line.

Changed 11 years ago by todmorrison (Tod Morrison)

Attachment: octave-portfile.2.diff added

Corrected Portfile patch

comment:14 Changed 10 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

Let's handle this in #21797.

Note: See TracTickets for help on using tickets.