Opened 10 years ago

Closed 10 years ago

#23437 closed defect (invalid)

VXL fails to build with CMake on Mac OS 10.6

Reported by: roger.hubbold@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc:
Port: vxl

Description (last modified by jmroot (Joshua Root))

VXL fails with a message about a missing library. Web searching reveals that others have encounter a similar problem with other software. The common factor seems to be CMake. The message is:

CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
MPEG2_vo_LIBRARY (ADVANCED)
    linked by target "vidl" in directory /opt/local/var/macports/build/_private_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_vxl/work/vxl-1.12.0/core/vidl
    linked by target "vidl_vil1" in directory /opt/local/var/macports/build/_private_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_vxl/work/vxl-1.12.0/core/vidl_vil1
    linked by target "oxp" in directory /opt/local/var/macports/build/_private_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_vxl/work/vxl-1.12.0/contrib/oxl/oxp
    linked by target "glmovie" in directory /opt/local/var/macports/build/_private_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_vxl/work/vxl-1.12.0/contrib/oxl/apps/glmovie
    linked by target "vobgetframe" in directory /opt/local/var/macports/build/_private_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_vxl/work/vxl-1.12.0/contrib/oxl/apps/glmovie

-- Configuring incomplete, errors occurred!

Error: Status 1 encountered during processing.

I've attached a file containing the output with the -d flag.

I have no idea how to fix this. Can anyone help? Any suggestions would be much appreciated.

I previously installed vxl on 10.5 (using Macports) and everything worked fine. I get the same error if I try to build from source code under 10.6.

Attachments (1)

install vxl errors (36.4 KB) - added by roger.hubbold@… 10 years ago.

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by roger.hubbold@…

Attachment: install vxl errors added

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Description: modified (diff)
Keywords: CMake removed
Port: vxl added; VXL removed
Type: requestdefect

comment:2 Changed 10 years ago by tobypeterson

Resolution: invalid
Status: newclosed

Looks like you have a bunch of crap in /usr/local - this is unsupported.

Note: See TracTickets for help on using tickets.