Opened 10 years ago

Closed 10 years ago

#23549 closed defect (fixed)

Double Path Issue (SpeedyCGI)

Reported by: leo@… Owned by: markd@…
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc:
Port: p5-cgi-speedycgi

Description

Hi

I can't find any similar issues, but I'm confused as to the cause on this.

Trying to build smokeping, but failing to build SpeedyCGI. I can't find an easy way to contact the port maintainer either.

Any thoughts?

--->  Computing dependencies for p5-cgi-speedycgi
--->  Building p5-cgi-speedycgi
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_perl_p5-cgi-speedycgi/work/CGI-SpeedyCGI-2.22" && /usr/bin/make -j2 all " returned error 2
Command output: make: *** No rule to make target `speedy_backend/speedy_backend', needed by `blib/script/speedy_backend'.  Stop.
make: *** Waiting for unfinished jobs....

Error: Status 1 encountered during processing.
Before reporting a bug, first run the command again with the -d flag to get complete output.

Change History (9)

comment:1 Changed 10 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to markd@…
Port: p5-cgi-speedycgi added

comment:2 Changed 10 years ago by markd@…

I just installed it on 10.5. I haven't upgraded yet. Are you on 10.6?

comment:3 Changed 10 years ago by leo@…

Indeed, I should have mentioned this was Snow Leopard- sorry.

comment:4 Changed 10 years ago by markd@…

Unfortunately I don't have a Mac running 10.6 right now to try. Have you tried cleaning and reinstalling to verify? 'port clean --all p5-speedycgi'

If it still fails it may be broken on Snow Leopard and I'll investigate as as soon as I can.

comment:5 Changed 10 years ago by blb@…

Actually, this looks like a parallel issue; fails for me on 10.6.2, but disabling parallel and it builds fine.

Also:

DEBUG: checking for mtree violations
Warning: violation by /mp/apache2
Warning: p5-cgi-speedycgi violates the layout of the ports-filesystems!
Warning: Please fix or indicate this misbehavior (if it is intended), it will be an error in future releases!

comment:6 Changed 10 years ago by markd@…

Yes you are correct. Thanks for investigating. As it happens I was just updating the ticket with that info when I saw the email of the ticket update. I bumped the 'buildmakejobs' variable to 2 in macports.conf it fails for me too.

Was that variable changed, or does the default of '0' that determines automatically whether to build parallel default to 2 on Snow Leopard? It defaults to 1 for me on 10.5.

blb@ do you think I should set the keyword 'use_parallel_build no' in the portfile to force it off in any case?

comment:7 Changed 10 years ago by blb@…

MacPorts 1.8 started to enable parallel building by default (unless you set buildmakejobs to 1); 0 is supposed to try and be smart about picking a value, the macports.conf comments should explain that.

Setting use_parallel_build to no is definitely the way to flag a port that doesn't like to build parallel, and was what I used to get it to build fine when I tried the quick test.

comment:8 Changed 10 years ago by leo@…

Cool, looks like you guys have solved it - put this flag in the portfile and it built. Thanks for your determination for helping me resolve it! Leo

comment:9 Changed 10 years ago by markd@…

Resolution: fixed
Status: newclosed

I set use_parallel_build flag to 'no' in the r63556.

Note: See TracTickets for help on using tickets.